Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Runtimes » PDE API Tools
PDE API Tools [message #468642] Thu, 25 June 2009 16:21
Paul Warren is currently offline Paul Warren
Messages: 34
Registered: July 2009
Member
Hi Folks,

Apologies for the cross post. I tried posting to eclipse.pde but I was not
authorized to do so.

I'm trialling the pde api tools for use within our organization and I'm
seeing some behavior that I dont understand. Hopefully someone will be able
to explain the rational.

I have a reference plugin v1.0.0 (my baseline)

I have a separate identical copy of that plugin imported into my workspace
(the working copy).

I create a baseline using the reference copy.

I enable the working copy for api analysis.

And I immediately get an error stating:-

"The minor version should be incremented in version 1.0.0.qualifier, since
new APIs have been added since version 1.0.0.qualifier."

But I havent yet changed the plugin at all.

I would not expect this sort of error to appear until I make the first
change. Is this an incorrect expectation? If so, why?

Mnay thanks
_Paul
Previous Topic:org.eclipse.core.runtime.compatibility.registry
Next Topic:equinox experience reports
Goto Forum:
  


Current Time: Sun Sep 21 18:12:51 GMT 2014

Powered by FUDForum. Page generated in 0.08872 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software