Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » PDE Fetch using SVN
PDE Fetch using SVN [message #46456] Fri, 15 May 2009 04:48 Go to next message
Eclipse User
Originally posted by: mickael.istria.openwide.fr

Hi,

I am trying to set up a PDE build that fetches source SVN. I've seen
that Subversive is able to do it (bug 227115), but I couldn't find any
documentation about how to use it...
Is there a wiki page or something like that that details requirements
and usage? What should a SVN fetch line look like in my product.map file?

Thanks in advance for your help

Regards,
Mickael
Re: PDE Fetch using SVN [message #46519 is a reply to message #46456] Fri, 15 May 2009 06:18 Go to previous messageGo to next message
Eclipse User
Originally posted by: mickael.istria.openwide.fr

> I am trying to set up a PDE build that fetches source SVN. I've seen
> that Subversive is able to do it (bug 227115), but I couldn't find any
> documentation about how to use it...
> Is there a wiki page or something like that that details requirements
> and usage? What should a SVN fetch line look like in my product.map file?

I thought I searched well before asking the mailing-list, but I forgot
googling "+subversive pde fetch" =>
http://dev.eclipse.org/newslists/news.eclipse.technology.sub versive/msg00384.html

Then I tried what was descibed in the message, and got the following
result while trying to fetch a plugin:

#map file
plugin@org.eclipse.jwt.we.model.owl=SVN,url= svn://svn.forge.objectweb.org/svnroot/scarbo,tag=trunk,path= tools/owl-model

#result
FetchFromCVS:
[CVS - path=tools/owl-model] rsh: Could not resolve hostname url=svn:
Name or service not known
[CVS - path=tools/owl-model] cvs [export aborted]: end of file from
server (consult above messages if any)


I have subversive 0.7.8.I20090506 installed on a Galileo m6, and svn
binaries are in my path.


Does anyone have an idea of the meaning and reason of this error?

By the I started a wiki page for Subversive, you can find it at
http://wiki.eclipse.org/Subversive. I'll try to report there my
experience to write a basic user documentation of PDE SVN fetch

Best regards,
Mickael
Re: PDE Fetch using SVN [message #46547 is a reply to message #46519] Fri, 15 May 2009 10:22 Go to previous messageGo to next message
Igor Burilo is currently offline Igor Burilo
Messages: 435
Registered: July 2009
Senior Member
Hello Mickael,

I suppose that you didn't install 'org.eclipse.team.svn.pde.build' plugin in
Eclipse where you run PDE build (this is because you have FetchFromCVS
instead of FetchFromSVN). You can install it from following update site:
http://download.eclipse.org/technology/subversive/0.7/pde-up date-site/,
unfortunately it is not published on Subversive site and so you probably
didn't find it.
Note that you don't necessary should have Subversive SVN Team Provider and
SVN Connectors to be installed in eclipse where you run PDE buid, you just
need 'org.eclipse.team.svn.pde.build' plugin.
Also there was a request from a user to add features/fix bugs related to SVN
Fetch, for more details please see
https://bugs.eclipse.org/bugs/show_bug.cgi?id=273230, probably you'll need
some of the fuctionality from there, but I didn't yet propogate latest
changes to pde update site.

It would be great if you create a wiki page about PDE SVN Fetch,
unfortunately we don't have detailed info about it now. If it's possible
please add this wiki page to 'Subversive' category, e.g.
http://wiki.eclipse.org/Subversive_New_and_Noteworthy or
http://wiki.eclipse.org/Subversive_Plan, as a result we'll have all
Subversive related pages list when we click on 'Subversive' category or go
to it by url: http://wiki.eclipse.org/Category:Subversive; if you experience
any problems with it, I can help/do it.

>> I am trying to set up a PDE build that fetches source SVN. I've seen that
>> Subversive is able to do it (bug 227115), but I couldn't find any
>> documentation about how to use it...
>> Is there a wiki page or something like that that details requirements and
>> usage? What should a SVN fetch line look like in my product.map file?
>
> I thought I searched well before asking the mailing-list, but I forgot
> googling "+subversive pde fetch" =>
> http://dev.eclipse.org/newslists/news.eclipse.technology.sub versive/msg00384.html
>
> Then I tried what was descibed in the message, and got the following
> result while trying to fetch a plugin:
>
> #map file
> plugin@org.eclipse.jwt.we.model.owl=SVN,url= svn://svn.forge.objectweb.org/svnroot/scarbo,tag=trunk,path= tools/owl-model
>
> #result
> FetchFromCVS:
> [CVS - path=tools/owl-model] rsh: Could not resolve hostname url=svn: Name
> or service not known
> [CVS - path=tools/owl-model] cvs [export aborted]: end of file from server
> (consult above messages if any)
>
>
> I have subversive 0.7.8.I20090506 installed on a Galileo m6, and svn
> binaries are in my path.
>
>
> Does anyone have an idea of the meaning and reason of this error?
>
> By the I started a wiki page for Subversive, you can find it at
> http://wiki.eclipse.org/Subversive. I'll try to report there my experience
> to write a basic user documentation of PDE SVN fetch
>
> Best regards,
> Mickael
Re: PDE Fetch using SVN [message #46742 is a reply to message #46547] Fri, 15 May 2009 11:20 Go to previous messageGo to next message
Eclipse User
Originally posted by: mickael.istria.openwide.fr

Great! Thanks a lot! It works quite well!

I created a new page http://wiki.eclipse.org/Subversive_PDE_Fetch where
I wrote some few things.

My question is now: why don't you distribute this plugin with your other
plugins? As a p2 installable unit?
This is a very useful piece of code, and people who want to use SVN in
automated build always have to deal with the pde-svn from sourceforge.

The Athena CBI from Dash project would probably prefer use your plugin
that downloading pde-svn, for licence, community and technical reasons...
This could be made a component of Subversive project, what do you think
about that?

Regards,
Mickael

Igor Burilo a écrit :
> Hello Mickael,
>
> I suppose that you didn't install 'org.eclipse.team.svn.pde.build' plugin in
> Eclipse where you run PDE build (this is because you have FetchFromCVS
> instead of FetchFromSVN). You can install it from following update site:
> http://download.eclipse.org/technology/subversive/0.7/pde-up date-site/,
> unfortunately it is not published on Subversive site and so you probably
> didn't find it.
> Note that you don't necessary should have Subversive SVN Team Provider and
> SVN Connectors to be installed in eclipse where you run PDE buid, you just
> need 'org.eclipse.team.svn.pde.build' plugin.
> Also there was a request from a user to add features/fix bugs related to SVN
> Fetch, for more details please see
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=273230, probably you'll need
> some of the fuctionality from there, but I didn't yet propogate latest
> changes to pde update site.
>
> It would be great if you create a wiki page about PDE SVN Fetch,
> unfortunately we don't have detailed info about it now. If it's possible
> please add this wiki page to 'Subversive' category, e.g.
> http://wiki.eclipse.org/Subversive_New_and_Noteworthy or
> http://wiki.eclipse.org/Subversive_Plan, as a result we'll have all
> Subversive related pages list when we click on 'Subversive' category or go
> to it by url: http://wiki.eclipse.org/Category:Subversive; if you experience
> any problems with it, I can help/do it.
>
>>> I am trying to set up a PDE build that fetches source SVN. I've seen that
>>> Subversive is able to do it (bug 227115), but I couldn't find any
>>> documentation about how to use it...
>>> Is there a wiki page or something like that that details requirements and
>>> usage? What should a SVN fetch line look like in my product.map file?
>> I thought I searched well before asking the mailing-list, but I forgot
>> googling "+subversive pde fetch" =>
>> http://dev.eclipse.org/newslists/news.eclipse.technology.sub versive/msg00384.html
>>
>> Then I tried what was descibed in the message, and got the following
>> result while trying to fetch a plugin:
>>
>> #map file
>> plugin@org.eclipse.jwt.we.model.owl=SVN,url= svn://svn.forge.objectweb.org/svnroot/scarbo,tag=trunk,path= tools/owl-model
>>
>> #result
>> FetchFromCVS:
>> [CVS - path=tools/owl-model] rsh: Could not resolve hostname url=svn: Name
>> or service not known
>> [CVS - path=tools/owl-model] cvs [export aborted]: end of file from server
>> (consult above messages if any)
>>
>>
>> I have subversive 0.7.8.I20090506 installed on a Galileo m6, and svn
>> binaries are in my path.
>>
>>
>> Does anyone have an idea of the meaning and reason of this error?
>>
>> By the I started a wiki page for Subversive, you can find it at
>> http://wiki.eclipse.org/Subversive. I'll try to report there my experience
>> to write a basic user documentation of PDE SVN fetch
>>
>> Best regards,
>> Mickael
>
>
Re: PDE Fetch using SVN [message #46832 is a reply to message #46742] Tue, 19 May 2009 07:43 Go to previous messageGo to next message
Igor Burilo is currently offline Igor Burilo
Messages: 435
Registered: July 2009
Senior Member
Hello Mickael,

Thanks for wiki page. I added info about SVN PDE Build in Subversive
downloads page.

> Great! Thanks a lot! It works quite well!
>
> I created a new page http://wiki.eclipse.org/Subversive_PDE_Fetch where I
> wrote some few things.
>
> My question is now: why don't you distribute this plugin with your other
> plugins? As a p2 installable unit?
> This is a very useful piece of code, and people who want to use SVN in
> automated build always have to deal with the pde-svn from sourceforge.
>
> The Athena CBI from Dash project would probably prefer use your plugin
> that downloading pde-svn, for licence, community and technical reasons...
> This could be made a component of Subversive project, what do you think
> about that?
>
> Regards,
> Mickael
>
> Igor Burilo a
Re: PDE Fetch using SVN [message #506581 is a reply to message #46832] Thu, 07 January 2010 21:51 Go to previous messageGo to next message
joel lee is currently offline joel lee
Messages: 3
Registered: January 2010
Junior Member
Hi~

I have on question.

Could you also build automatically on linux platform?

I'm trying to do that but..

If i execute build.sh then I do not load org.eclipse.team.svn.pde.build_0.7.8.I20090525-1500.jar plugin downloaded from the svn update site

Also.. I saw a log as below

fetchElement:
[eclipse.fetch] Could not retrieve feature.xml and/or build.properties: java.io.IOException: java.io.IOException: cvs: not found.

BUILD FAILED
/home/pan/workspace/org.eclipse.nexbuild.builder/build.xml:4 9: The following error occurred while executing this line:
/home/pan/app/eclipse3_4/plugins/org.eclipse.pde.build_3.4.1 .R34x_v20081217/scripts/build.xml:23: The following error occurred while executing this line:
/home/pan/app/eclipse3_4/plugins/org.eclipse.pde.build_3.4.1 .R34x_v20081217/scripts/build.xml:51: The following error occurred while executing this line:
/home/pan/workspace/org.eclipse.nexbuild.builder/build/custo mTargets.xml:9: The following error occurred while executing this line:
/home/pan/app/eclipse3_4/plugins/org.eclipse.pde.build_3.4.1 .R34x_v20081217/scripts/genericTargets.xml:44: Could not retrieve feature.xml or build.properties for feature nexcore.tool.feature.core.

please... what can i do for building?


Best regards.

[Updated on: Fri, 08 January 2010 02:53]

Report message to a moderator

Re: PDE Fetch using SVN [message #506908 is a reply to message #506581] Mon, 11 January 2010 00:28 Go to previous messageGo to next message
Igor Burilo is currently offline Igor Burilo
Messages: 435
Registered: July 2009
Senior Member
Hello joel,

Please read http://wiki.eclipse.org/Subversive_PDE_Fetch
> [eclipse.fetch] Could not retrieve feature.xml and/or build.properties:
> java.io.IOException: java.io.IOException: cvs: not found.
The error message says about 'cvs' but not about 'svn', so probably you
didn't correctly configure map files.

>
> Hi~
> I have on question.
>
> Could you also build automatically on linux platform?
>
> I'm trying to do that but..
>
> If i execute build.sh then I do not load
> org.eclipse.team.svn.pde.build_0.7.8.I20090525-1500.jar plugin downloaded
> from the svn update site
>
> Also.. I saw a log as below
>
> fetchElement:
> [eclipse.fetch] Could not retrieve feature.xml and/or build.properties:
> java.io.IOException: java.io.IOException: cvs: not found.
>
> BUILD FAILED
> /home/pan/workspace/org.eclipse.nexbuild.builder/build.xml:4 9: The
> following error occurred while executing this line:
> /home/pan/app/eclipse3_4/plugins/org.eclipse.pde.build_3.4.1
> .R34x_v20081217/scripts/build.xml:23: The following error occurred while
> executing this line:
> /home/pan/app/eclipse3_4/plugins/org.eclipse.pde.build_3.4.1
> .R34x_v20081217/scripts/build.xml:51: The following error occurred while
> executing this line:
> /home/pan/workspace/org.eclipse.nexbuild.builder/build/custo
> mTargets.xml:9: The following error occurred while executing this line:
> /home/pan/app/eclipse3_4/plugins/org.eclipse.pde.build_3.4.1
> .R34x_v20081217/scripts/genericTargets.xml:44: Could not retrieve
> feature.xml or build.properties for feature nexcore.tool.feature.core.
>
> please... what can i do for building?
Re: PDE Fetch using SVN [message #507086 is a reply to message #506908] Mon, 11 January 2010 21:52 Go to previous messageGo to next message
joel lee is currently offline joel lee
Messages: 3
Registered: January 2010
Junior Member

Hello~ Igor

I checked as you told me but my map files work good on Window platform, I performed completely build for my java sources

However, on linux platform, It could not plugin org.eclipse.team.svn.pde.build_0.7.8.I20090525-1500.jar ..I don't know..

I checked that in OSGi console...

To use getFromSVN clause, maybe I think i need that

I installed eclipse 3.4 and copied that into ECLIPSE_HOME/dropins folder..

but... i couldn't plugin

BestRegards
Joel



Re: PDE Fetch using SVN [message #508273 is a reply to message #507086] Mon, 18 January 2010 03:38 Go to previous messageGo to next message
Igor Burilo is currently offline Igor Burilo
Messages: 435
Registered: July 2009
Senior Member
Hello Joel,

>i couldn't plugin
Sorry, it's not clear what you mean, please explain it.
Do you have any related errors?

>
> Hello~ Igor
>
> I checked as you told me but my map files work good on Window platform, I
> performed completely build for my java sources
>
> However, on linux platform, It could not plugin
> org.eclipse.team.svn.pde.build_0.7.8.I20090525-1500.jar ..I don't know..
>
> I checked that in OSGi console...
>
> To use getFromSVN clause, maybe I think i need that
>
> I installed eclipse 3.4 and copied that into ECLIPSE_HOME/dropins folder..
>
> but... i couldn't plugin
>
> BestRegards
> Joel
>
>
>
>
Re: PDE Fetch using SVN [message #508280 is a reply to message #508273] Mon, 18 January 2010 04:43 Go to previous messageGo to next message
joel lee is currently offline joel lee
Messages: 3
Registered: January 2010
Junior Member
Hello, Igor

Sorry, I'm not good at english.^^;

The related error is below as I wrote before

fetchElement:
[eclipse.fetch] Could not retrieve feature.xml and/or build.properties: java.io.IOException: java.io.IOException: cvs: not found.

BUILD FAILED
/home/pan/workspace/org.eclipse.nexbuild.builder/build.xml:4 9: The following error occurred while executing this line:
/home/pan/app/eclipse3_4/plugins/org.eclipse.pde.build_3.4.1 .R34x_v20081217/scripts/build.xml:23: The following error occurred while executing this line:
/home/pan/app/eclipse3_4/plugins/org.eclipse.pde.build_3.4.1 .R34x_v20081217/scripts/build.xml:51: The following error occurred while executing this line:
/home/pan/workspace/org.eclipse.nexbuild.builder/build/custo mTargets.xml:9: The following error occurred while executing this line:
/home/pan/app/eclipse3_4/plugins/org.eclipse.pde.build_3.4.1 .R34x_v20081217/scripts/genericTargets.xml:44: Could not retrieve feature.xml or build.properties for feature nexcore.tool.feature.core.

I think If org.eclipse.team.svn.pde.build_0.7.8.I20090525-1500.jar plugin is activated
then SVN PDE build should exeute SVN Fetch not to CVS Fetch

I copied this plugin into ECLIPSE_HOME/dropin folder

But that wasn't even installed in OSGi when i executed PDE build

My Platform is linux.
Re: PDE Fetch using SVN [message #509093 is a reply to message #508280] Thu, 21 January 2010 06:28 Go to previous message
Igor Burilo is currently offline Igor Burilo
Messages: 435
Registered: July 2009
Senior Member
Hello joel,

I don't know what the problem could be, as it works on Windows it could mean
that your configuration is correct. Did you try to install Subversive PDE
from update site:
http://download.eclipse.org/technology/subversive/0.7/pde-up date-site/ (but
not just unpacking it to dropins folder)?

> Hello, Igor
>
> Sorry, I'm not good at english.^^;
>
> The related error is below as I wrote before
>
> fetchElement:
> [eclipse.fetch] Could not retrieve feature.xml and/or build.properties:
> java.io.IOException: java.io.IOException: cvs: not found.
>
> BUILD FAILED
> /home/pan/workspace/org.eclipse.nexbuild.builder/build.xml:4 9: The
> following error occurred while executing this line:
> /home/pan/app/eclipse3_4/plugins/org.eclipse.pde.build_3.4.1
> .R34x_v20081217/scripts/build.xml:23: The following error occurred while
> executing this line:
> /home/pan/app/eclipse3_4/plugins/org.eclipse.pde.build_3.4.1
> .R34x_v20081217/scripts/build.xml:51: The following error occurred while
> executing this line:
> /home/pan/workspace/org.eclipse.nexbuild.builder/build/custo
> mTargets.xml:9: The following error occurred while executing this line:
> /home/pan/app/eclipse3_4/plugins/org.eclipse.pde.build_3.4.1
> .R34x_v20081217/scripts/genericTargets.xml:44: Could not retrieve
> feature.xml or build.properties for feature nexcore.tool.feature.core.
>
> I think If org.eclipse.team.svn.pde.build_0.7.8.I20090525-1500.jar plugin
> is activated
> then SVN PDE build should exeute SVN Fetch not to CVS Fetch
> I copied this plugin into ECLIPSE_HOME/dropin folder
>
> But that wasn't even installed in OSGi when i executed PDE build
>
> My Platform is linux.
>
Previous Topic:Stability of the weekly builds
Next Topic:Check out as folder into existing project doesn't work?
Goto Forum:
  


Current Time: Mon Jul 28 18:32:30 EDT 2014

Powered by FUDForum. Page generated in 0.04157 seconds