Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » General (non-technical) » Eclipse Foundation » Eclispe IDE crashing on Linux
Eclispe IDE crashing on Linux [message #3949] Fri, 15 October 2004 12:03 Go to next message
Eclipse User
Originally posted by: piyush.gupta.st.com

Hi,

I appologise if this is not the correct group to post to (would appreciate
for directions, in that case).

However, I just downloaded the latest 3.01 release and can't get it to
start on my linux server.

The Linux host is: Red Hat Linux Advanced Server release 2.1AS/i686
(Pensacola)

Upon starting the ide using the following command:

$ /software/eclipse-motif/eclipse -vm /software/java1.4.2/jre/bin/java
-data $HOME/workspace &

The splash screen apears and then the IDE crashed with the follwoing error
message in the log file:

************************************************************ *****************
!SESSION Oct 15, 2004 13:48:31.172
---------------------------------------------
eclipse.buildId=I200406251208
java.version=1.4.2_04
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=motif, NL=en_US

!ENTRY org.eclipse.osgi Oct 15, 2004 13:48:31.174
!MESSAGE Application error
!STACK 1
java.lang.ExceptionInInitializerError
at
org.eclipse.ui.internal.themes.ThemeElementHelper.installFon t(ThemeElementHelper.java:76)
at
org.eclipse.ui.internal.themes.ThemeElementHelper.populateRe gistry(ThemeElementHelper.java:48)
at
org.eclipse.ui.internal.Workbench.initializeFonts(Workbench. java:874)
at org.eclipse.ui.internal.Workbench.init(Workbench.java:783)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:1325)
at
org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Work bench.java:254)
at
org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:141)
at
org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplicatio n.java:96)
at
org.eclipse.core.internal.runtime.PlatformActivator$1.run(Pl atformActivator.java:335)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:273)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:129)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:324)
at org.eclipse.core.launcher.Main.basicRun(Main.java:183)
at org.eclipse.core.launcher.Main.run(Main.java:644)
at org.eclipse.core.launcher.Main.main(Main.java:628)
Caused by: java.lang.NullPointerException
at
org.eclipse.jface.preference.PreferenceConverter.<clinit>(PreferenceConverter.java:85)
... 18 more
************************************************************ ******************

Any help/pointers regarding this?

thanks,
-Piyush
Re: Eclispe IDE crashing on Linux [message #3975 is a reply to message #3949] Fri, 15 October 2004 14:18 Go to previous messageGo to next message
Eclipse User
Originally posted by: ilias.lazaridis.com

On Fri, 15 Oct 2004 12:03:00 +0000 (UTC), Piyush GUPTA
<piyush.gupta@st.com> wrote:

> Hi,
>
> I appologise if this is not the correct group to post to

You don't have to apologize - the fault is most possibly not on your side.

May I ask you which path you have followed to find "eclipse.foundation"?

> (would appreciate for directions, in that case).

eclipse.platform should be the right group for your issue [btw: I have not
the knowledge to help you out]

..

--
http://lazaridis.com
Re: Eclispe IDE crashing on Linux [message #4885 is a reply to message #3975] Mon, 18 October 2004 10:58 Go to previous messageGo to next message
Eclipse User
Originally posted by: piyush.gupta.st.com

ilias wrote:

> You don't have to apologize - the fault is most possibly not on your side.

> May I ask you which path you have followed to find "eclipse.foundation"?

> > (would appreciate for directions, in that case).

I just went to the newsgroup site, read that eclipse.foundation is for
general discussion and clicked on the web interface link and posted. I
guess I was a bit hasty. definitely my mistake. :-(

> eclipse.platform should be the right group for your issue [btw: I have not
> the knowledge to help you out]

thanks for the directions! :-)

regards,
-Piyush
Re: Eclispe IDE crashing on Linux [message #5415 is a reply to message #4885] Mon, 18 October 2004 14:53 Go to previous message
Eclipse User
Originally posted by: ilias.lazaridis.com

On Mon, 18 Oct 2004 10:58:57 +0000 (UTC), Piyush GUPTA
<piyush.gupta@st.com> wrote:

> ilias wrote:
>
>> You don't have to apologize - the fault is most possibly not on your
>> side.
>
>> May I ask you which path you have followed to find "eclipse.foundation"?
>
>> > (would appreciate for directions, in that case).
>
> I just went to the newsgroup site, read that eclipse.foundation is for
> general discussion and clicked on the web interface link and posted. I
> guess I was a bit hasty. definitely my mistake. :-(

no, it isn't. [we are all 'lazy', aren't we?]

see my suggestion to the webmaster in another thread:

"
- change the position of the group (let platform be the first again)
- or: create an "eclipse.foundation.newcomer" group and place it on top of
the list, thus newcomer requests are automaticly catched (and foundation
and platform groups are happy)!
"

>> eclipse.platform should be the right group for your issue [btw: I have
>> not the knowledge to help you out]
>
> thanks for the directions! :-)

you're welcome.

..

--
http://lazaridis.com
Previous Topic:[GOVERNANCE] - The Prime Directives of Ethical Business
Next Topic:Phase 1 of the Infrastructure Migration Completed
Goto Forum:
  


Current Time: Thu Oct 23 08:06:49 GMT 2014

Powered by FUDForum. Page generated in 0.02127 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software