Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » ClassNotFoundException
ClassNotFoundException [message #45021] Tue, 06 December 2005 17:14 Go to next message
Eclipse User
Originally posted by: ruben.garcia.21csi.com

Hello Team,
If this is the wrong place to put this please let me know.
I am still trying to run an outside application with TPTP to see if it
will recognize any of the SWT objects in the program. Upon trying to
start the application from run ... run..., I get the following exception:

!SESSION Tue Dec 06 08:53:41 PST 2005
------------------------------------------
!ENTRY org.eclipse.core.launcher 4 0 2005-12-06 08:53:41.765
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.ClassNotFoundException:
org.eclipse.core.runtime.adaptor.EclipseStarter
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at org.eclipse.core.launcher.Main.invokeFramework(Main.java:331 )
at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
at org.eclipse.core.launcher.Main.run(Main.java:973)
at org.eclipse.core.launcher.Main.main(Main.java:948)
Any ideas would be great. Thx
Re: ClassNotFoundException [message #45039 is a reply to message #45021] Wed, 07 December 2005 14:04 Go to previous message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Hi Ruben,
All of the options in the Run dialog with the exception of Test are
contributed by JDT. You may want to
post your question to news://news.eclipse.org/eclipse.tools.jdt. However,
if you are having a problem profiling (e.g. Run >> Profile...), please
provide more details on your application and the steps you use to launch the
application within Eclipse.

Paul
"Ruben Garcia" <ruben.garcia@21csi.com> wrote in message
news:dn4gub$rlf$1@news.eclipse.org...
> Hello Team,
> If this is the wrong place to put this please let me know.
> I am still trying to run an outside application with TPTP to see if it
> will recognize any of the SWT objects in the program. Upon trying to
> start the application from run ... run..., I get the following exception:
>
> !SESSION Tue Dec 06 08:53:41 PST 2005
> ------------------------------------------
> !ENTRY org.eclipse.core.launcher 4 0 2005-12-06 08:53:41.765
> !MESSAGE Exception launching the Eclipse Platform:
> !STACK
> java.lang.ClassNotFoundException:
> org.eclipse.core.runtime.adaptor.EclipseStarter
> at java.net.URLClassLoader$1.run(Unknown Source)
> at java.security.AccessController.doPrivileged(Native Method)
> at java.net.URLClassLoader.findClass(Unknown Source)
> at java.lang.ClassLoader.loadClass(Unknown Source)
> at java.lang.ClassLoader.loadClass(Unknown Source)
> at org.eclipse.core.launcher.Main.invokeFramework(Main.java:331 )
> at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
> at org.eclipse.core.launcher.Main.run(Main.java:973)
> at org.eclipse.core.launcher.Main.main(Main.java:948)
> Any ideas would be great. Thx
Previous Topic:Envoking Junits from a menu (so anyone can run the tests)
Next Topic:New Agent Controller and Java 5
Goto Forum:
  


Current Time: Wed Oct 01 20:30:21 GMT 2014

Powered by FUDForum. Page generated in 0.02047 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software