Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DTP » Missing Dependency
Missing Dependency [message #445251] Fri, 31 July 2009 15:10 Go to next message
Erik Englund is currently offline Erik Englund
Messages: 49
Registered: July 2009
Member
I have added DTP to my RCP application and I get the following error when
opening the DSE while the properties view is open.

!ENTRY org.eclipse.ui.views.properties.tabbed 4 4 2009-07-31 15:08:15.324
!MESSAGE Contributor
org.eclipse.datatools.connectivity.DataSourceExplorerNavigat or cannot be
created.
!STACK 1
org.eclipse.core.runtime.CoreException: Plug-in
org.eclipse.datatools.connectivity.ui.dse was unable to load class
org.eclipse.ui.internal.navigator.resources.workbench.Tabbed PropertySheetTitleProvider.
...
Caused by: java.lang.ClassNotFoundException:
org.eclipse.ui.internal.navigator.resources.workbench.Tabbed PropertySheetTitleProvider

If I add org.eclipse.ui.navigator.resources as a dependency in
org.eclipse.datatools.connectivity.ui.dse the problem goes away.

Is this a missing dependency?
Re: Missing Dependency [message #446309 is a reply to message #445251] Fri, 31 July 2009 17:47 Go to previous messageGo to next message
Erik Englund is currently offline Erik Englund
Messages: 49
Registered: July 2009
Member
After further research I believe I have found the problem. In
org.eclipse.datatools.connectivity.ui.dse you have the following:

<extension

point="org.eclipse.ui.views.properties.tabbed.propertyContributor ">
<propertyContributor

contributorId=" org.eclipse.datatools.connectivity.DataSourceExplorerNavigat or "

labelProvider=" org.eclipse.ui.internal.navigator.resources.workbench.Tabbed PropertySheetTitleProvider ">
<propertyCategory category="general"/>
<propertyCategory category="core"/>
<propertyCategory category="appearance"/>
<propertyCategory category="advanced"/>
</propertyContributor>
</extension>

This problem is only triggered if the properties view is a tabbed
properties view.
Re: Missing Dependency [message #446453 is a reply to message #445251] Fri, 31 July 2009 18:10 Go to previous messageGo to next message
Brian Fitzpatrick is currently offline Brian Fitzpatrick
Messages: 495
Registered: July 2009
Senior Member
Erik wrote:
> I have added DTP to my RCP application and I get the following error
> when opening the DSE while the properties view is open.
>
> !ENTRY org.eclipse.ui.views.properties.tabbed 4 4 2009-07-31 15:08:15.324
> !MESSAGE Contributor
> org.eclipse.datatools.connectivity.DataSourceExplorerNavigat or cannot be
> created.
> !STACK 1
> org.eclipse.core.runtime.CoreException: Plug-in
> org.eclipse.datatools.connectivity.ui.dse was unable to load class
> org.eclipse.ui.internal.navigator.resources.workbench.Tabbed PropertySheetTitleProvider.
>
> ..
> Caused by: java.lang.ClassNotFoundException:
> org.eclipse.ui.internal.navigator.resources.workbench.Tabbed PropertySheetTitleProvider
>
>
> If I add org.eclipse.ui.navigator.resources as a dependency in
> org.eclipse.datatools.connectivity.ui.dse the problem goes away.
>
> Is this a missing dependency?
>
Hi Erik...

What version of DTP are you working with? But yes, it does sound like a
missing dependency.

--Fitz
Re: Missing Dependency [message #446457 is a reply to message #446309] Fri, 31 July 2009 18:12 Go to previous messageGo to next message
Brian Fitzpatrick is currently offline Brian Fitzpatrick
Messages: 495
Registered: July 2009
Senior Member
Erik wrote:
> After further research I believe I have found the problem. In
> org.eclipse.datatools.connectivity.ui.dse you have the following:
>
> <extension
>
> point="org.eclipse.ui.views.properties.tabbed.propertyContributor ">
> <propertyContributor
>
> contributorId=" org.eclipse.datatools.connectivity.DataSourceExplorerNavigat or "
>
>
> labelProvider=" org.eclipse.ui.internal.navigator.resources.workbench.Tabbed PropertySheetTitleProvider ">
>
> <propertyCategory category="general"/>
> <propertyCategory category="core"/>
> <propertyCategory category="appearance"/>
> <propertyCategory category="advanced"/>
> </propertyContributor>
> </extension>
>
> This problem is only triggered if the properties view is a tabbed
> properties view.
Interesting. Something to look at for our 1.7.1 release. Can you create
a Bugzilla entry for this? Thanks!
Re: Missing Dependency [message #480402 is a reply to message #446457] Sun, 16 August 2009 16:29 Go to previous message
Erik Englund is currently offline Erik Englund
Messages: 49
Registered: July 2009
Member
Bug Logged:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=286740
Re: Missing Dependency [message #596220 is a reply to message #445251] Fri, 31 July 2009 17:47 Go to previous message
Erik Englund is currently offline Erik Englund
Messages: 49
Registered: July 2009
Member
After further research I believe I have found the problem. In
org.eclipse.datatools.connectivity.ui.dse you have the following:

<extension

point="org.eclipse.ui.views.properties.tabbed.propertyContributor ">
<propertyContributor

contributorId=" org.eclipse.datatools.connectivity.DataSourceExplorerNavigat or "

labelProvider=" org.eclipse.ui.internal.navigator.resources.workbench.Tabbed PropertySheetTitleProvider ">
<propertyCategory category="general"/>
<propertyCategory category="core"/>
<propertyCategory category="appearance"/>
<propertyCategory category="advanced"/>
</propertyContributor>
</extension>

This problem is only triggered if the properties view is a tabbed
properties view.
Re: Missing Dependency [message #596237 is a reply to message #445251] Fri, 31 July 2009 18:10 Go to previous message
Brian Fitzpatrick is currently offline Brian Fitzpatrick
Messages: 495
Registered: July 2009
Senior Member
Erik wrote:
> I have added DTP to my RCP application and I get the following error
> when opening the DSE while the properties view is open.
>
> !ENTRY org.eclipse.ui.views.properties.tabbed 4 4 2009-07-31 15:08:15.324
> !MESSAGE Contributor
> org.eclipse.datatools.connectivity.DataSourceExplorerNavigat or cannot be
> created.
> !STACK 1
> org.eclipse.core.runtime.CoreException: Plug-in
> org.eclipse.datatools.connectivity.ui.dse was unable to load class
> org.eclipse.ui.internal.navigator.resources.workbench.Tabbed PropertySheetTitleProvider.
>
> ..
> Caused by: java.lang.ClassNotFoundException:
> org.eclipse.ui.internal.navigator.resources.workbench.Tabbed PropertySheetTitleProvider
>
>
> If I add org.eclipse.ui.navigator.resources as a dependency in
> org.eclipse.datatools.connectivity.ui.dse the problem goes away.
>
> Is this a missing dependency?
>
Hi Erik...

What version of DTP are you working with? But yes, it does sound like a
missing dependency.

--Fitz
Re: Missing Dependency [message #596250 is a reply to message #446309] Fri, 31 July 2009 18:12 Go to previous message
Brian Fitzpatrick is currently offline Brian Fitzpatrick
Messages: 495
Registered: July 2009
Senior Member
Erik wrote:
> After further research I believe I have found the problem. In
> org.eclipse.datatools.connectivity.ui.dse you have the following:
>
> <extension
>
> point="org.eclipse.ui.views.properties.tabbed.propertyContributor ">
> <propertyContributor
>
> contributorId=" org.eclipse.datatools.connectivity.DataSourceExplorerNavigat or "
>
>
> labelProvider=" org.eclipse.ui.internal.navigator.resources.workbench.Tabbed PropertySheetTitleProvider ">
>
> <propertyCategory category="general"/>
> <propertyCategory category="core"/>
> <propertyCategory category="appearance"/>
> <propertyCategory category="advanced"/>
> </propertyContributor>
> </extension>
>
> This problem is only triggered if the properties view is a tabbed
> properties view.
Interesting. Something to look at for our 1.7.1 release. Can you create
a Bugzilla entry for this? Thanks!
Re: Missing Dependency [message #596325 is a reply to message #446457] Sun, 16 August 2009 16:29 Go to previous message
Erik Englund is currently offline Erik Englund
Messages: 49
Registered: July 2009
Member
Bug Logged:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=286740
Previous Topic:How to generate Execution Plan in eclipse?
Next Topic:DTP Init Not Thread Safe
Goto Forum:
  


Current Time: Mon Jul 28 22:52:55 EDT 2014

Powered by FUDForum. Page generated in 0.04034 seconds