Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EPF » epf search ?
epf search ? [message #44778] Mon, 22 October 2007 09:47 Go to next message
danny foncke is currently offline danny fonckeFriend
Messages: 92
Registered: July 2009
Member
I published a simple method to a .war file
deployed it (to weblogic 8.1)
website OK
but search doesn't give any results and I get the following stacktrace :

LD> searchString: group
convert group -> group
LD> _indexPath: null
LD> _currentSearchString: group
LD> unicodes: group
LD> analyzerName: null
LD> _hits: null
java.lang.NullPointerException
at
org.eclipse.epf.web.servlet.SearchServlet.runQuery(Ljava.lan g.String;
)Z(SearchServlet.java:206)
at
org.eclipse.epf.web.servlet.SearchServlet.runSearch(Ljava.la ng.String
;)Ljava.lang.String;(SearchServlet.java:174)
at
org.eclipse.epf.web.servlet.SearchServlet.doGet(Ljavax.servl et.http.H
ttpServletRequest;Ljavax.servlet.http.HttpServletResponse;)V (SearchServlet.java:
129)
at
javax.servlet.http.HttpServlet.service(Ljavax.servlet.http.H ttpServle
tRequest;Ljavax.servlet.http.HttpServletResponse;)V(HttpServ let.java:740)
at
javax.servlet.http.HttpServlet.service(Ljavax.servlet.Servle tRequest;
Ljavax.servlet.ServletResponse;)V(HttpServlet.java:853)
at
weblogic.servlet.internal.ServletStubImpl$ServletInvocationA ction.run
()Ljava.lang.Object;(ServletStubImpl.java:1006)
at
weblogic.servlet.internal.ServletStubImpl.invokeServlet(Ljav ax.servle
t.ServletRequest;Ljavax.servlet.ServletResponse;Lweblogic.se rvlet.internal.Filte
rChainImpl;)V(ServletStubImpl.java:419)
at
weblogic.servlet.internal.ServletStubImpl.invokeServlet(Ljav ax.servle
t.ServletRequest;Ljavax.servlet.ServletResponse;)V(ServletSt ubImpl.java:315)
at
weblogic.servlet.internal.WebAppServletContext$ServletInvoca tionActio
n.run()Ljava.lang.Object;(WebAppServletContext.java:6718)
at
weblogic.security.acl.internal.AuthenticatedSubject.doAs(Lwe blogic.se
curity.subject.AbstractSubject;Ljava.security.PrivilegedActi on;)Ljava.lang.Objec
t;(AuthenticatedSubject.java:321)
at
weblogic.security.service.SecurityManager.runAs(Lweblogic.se curity.ac
l.internal.AuthenticatedSubject;Lweblogic.security.acl.inter nal.AuthenticatedSub
ject;Ljava.security.PrivilegedAction;)Ljava.lang.Object;(Sec urityManager.java:12
1)
at
weblogic.servlet.internal.WebAppServletContext.invokeServlet (Lweblogi
c.servlet.internal.ServletRequestImpl;Lweblogic.servlet.inte rnal.ServletResponse
Impl;)V(WebAppServletContext.java:3764)
at
weblogic.servlet.internal.ServletRequestImpl.execute(Lweblog ic.kernel
..ExecuteThread;)V(ServletRequestImpl.java:2644)
at
weblogic.kernel.ExecuteThread.execute(Lweblogic.kernel.Execu teRequest
;)V(ExecuteThread.java:219)
at weblogic.kernel.ExecuteThread.run()V(ExecuteThread.java:178)
at
java.lang.Thread.startThreadFromVM(Ljava.lang.Thread;)V(Unkn own Sourc
e)
Re: epf search ? [message #44877 is a reply to message #44778] Tue, 23 October 2007 19:27 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: storaskar.xx.xxx.xxx

From log
LD> _indexPath: null
LD> analyzerName: null

it looks like

_indexPath: null means that no index is available.
analyzerName is the name of analyzer used for generating index which is
null.

Can you try the following and see whether any of this makes a difference ?

1. check the deployed web app's search dir has the right files
2. try deploying it on Tomcat,
3. try OpenUP on Tomcat,
4. try OpenUP on WebLogic.

Thanks

Shilpa
Re: epf search ? [message #44927 is a reply to message #44877] Fri, 26 October 2007 07:11 Go to previous messageGo to next message
danny foncke is currently offline danny fonckeFriend
Messages: 92
Registered: July 2009
Member
Shilpa

- Deployed OpenUP to Weblogic - same error

the search dir contains the following :

dir : images
contains a lot of gifs
dir : index
deletable (4 B)
segments (28 B)
version.txt (21 B)
-8t.cfs (314 K)
file : search.html
file : search_result.xls

thanks


Shilpa Toraskar wrote:
> From log LD> _indexPath: null
> LD> analyzerName: null
>
> it looks like
> _indexPath: null means that no index is available. analyzerName is the
> name of analyzer used for generating index which is null.
>
> Can you try the following and see whether any of this makes a difference ?
>
> 1. check the deployed web app's search dir has the right files
> 2. try deploying it on Tomcat,
> 3. try OpenUP on Tomcat,
> 4. try OpenUP on WebLogic.
>
> Thanks
>
> Shilpa
>
>
Re: epf search ? [message #44951 is a reply to message #44927] Fri, 26 October 2007 16:58 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: storaskar.xx.xxx.xxx

Could you try Tomcat? I would like to nail down the issue to see .war
file is not working correctly on weblogic?

Shilpa
Re: epf search ? [message #45094 is a reply to message #44951] Mon, 29 October 2007 07:31 Go to previous message
danny foncke is currently offline danny fonckeFriend
Messages: 92
Registered: July 2009
Member
Shilpa,

I've tested using Tomcat 6.0.14 and everything works just fine.

So it seems there is a Weblogic related problem

Thanks for the help.

Danny


Shilpa Toraskar wrote:
> Could you try Tomcat? I would like to nail down the issue to see .war
> file is not working correctly on weblogic?
>
> Shilpa
>
Re: epf search ? [message #585254 is a reply to message #44778] Tue, 23 October 2007 19:27 Go to previous message
Shilpa Toraskar is currently offline Shilpa ToraskarFriend
Messages: 102
Registered: July 2009
Senior Member
From log
LD> _indexPath: null
LD> analyzerName: null

it looks like

_indexPath: null means that no index is available.
analyzerName is the name of analyzer used for generating index which is
null.

Can you try the following and see whether any of this makes a difference ?

1. check the deployed web app's search dir has the right files
2. try deploying it on Tomcat,
3. try OpenUP on Tomcat,
4. try OpenUP on WebLogic.

Thanks

Shilpa
Re: epf search ? [message #585281 is a reply to message #44877] Fri, 26 October 2007 07:11 Go to previous message
danny foncke is currently offline danny fonckeFriend
Messages: 92
Registered: July 2009
Member
Shilpa

- Deployed OpenUP to Weblogic - same error

the search dir contains the following :

dir : images
contains a lot of gifs
dir : index
deletable (4 B)
segments (28 B)
version.txt (21 B)
-8t.cfs (314 K)
file : search.html
file : search_result.xls

thanks


Shilpa Toraskar wrote:
> From log LD> _indexPath: null
> LD> analyzerName: null
>
> it looks like
> _indexPath: null means that no index is available. analyzerName is the
> name of analyzer used for generating index which is null.
>
> Can you try the following and see whether any of this makes a difference ?
>
> 1. check the deployed web app's search dir has the right files
> 2. try deploying it on Tomcat,
> 3. try OpenUP on Tomcat,
> 4. try OpenUP on WebLogic.
>
> Thanks
>
> Shilpa
>
>
Re: epf search ? [message #585296 is a reply to message #44927] Fri, 26 October 2007 16:58 Go to previous message
Shilpa Toraskar is currently offline Shilpa ToraskarFriend
Messages: 102
Registered: July 2009
Senior Member
Could you try Tomcat? I would like to nail down the issue to see .war
file is not working correctly on weblogic?

Shilpa
Re: epf search ? [message #585307 is a reply to message #44951] Mon, 29 October 2007 07:31 Go to previous message
danny foncke is currently offline danny fonckeFriend
Messages: 92
Registered: July 2009
Member
Shilpa,

I've tested using Tomcat 6.0.14 and everything works just fine.

So it seems there is a Weblogic related problem

Thanks for the help.

Danny


Shilpa Toraskar wrote:
> Could you try Tomcat? I would like to nail down the issue to see .war
> file is not working correctly on weblogic?
>
> Shilpa
>
Previous Topic:Eclipse Way
Next Topic:OpenUp white paper in french
Goto Forum:
  


Current Time: Thu Dec 18 11:45:56 GMT 2014

Powered by FUDForum. Page generated in 0.02666 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software