Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » XML Schema Definition (XSD) » Re: can't generate EMF model from XML Schema using EMF 2.0 on eclipse 3.0M8 [Ye Olde Sun JDK 1.4 / C
Re: can't generate EMF model from XML Schema using EMF 2.0 on eclipse 3.0M8 [Ye Olde Sun JDK 1.4 / C [message #44691] Mon, 17 May 2004 20:02 Go to next message
Eclipse UserFriend
Originally posted by: codeslave.ca.ibm.com

In an attempt to curb repeats of this question, I've updated the EMF
site in a few places (!) to call attention to this very simple workaround.

Feel free to let me know if I went a little overboard. ;-)

http://eclipse.org/emf/
http://download.eclipse.org/tools/emf/scripts/docs.php
http://download.eclipse.org/tools/emf/scripts/docs.php?doc=r eferences/faq.html

Nick Boldt


Michael Moser wrote:
> Ah - I see! I just tried the suggested workaround and: Bingo!
>
> I had indeed read but then ignored this notice because the explanation
> reads "...which manifests itself as a null pointer exception...".
> Since I hadn't noticed any exception my brain obviously failed to
> correlate those two. Maybe one should add to that note, that this
> exception in fact manifests as "Specify a valid XML Schema and try
> loading again".
>
> BTW: I had trouble unzipping the supplied
> technology/xsd/org.apache.xerces_2.6.2.zip file (link:
> javascript:void(getFile('../../../technology/xsd/org.apache. xerces_2.6
> ..2.zip')) from the EMF website. The file from the Apache Website
> unzips OK.
>
> Thanks and regards,
> Michael
>
> "Ed Merks" <merks@ca.ibm.com> wrote in message
> news:40A4A048.35ED5F54@ca.ibm.com...
>
>>Michael,
>>
>>If you are using the Sun JDK and you haven't followed the
>
> instructions
>
>>hilighted in bright yellow at the top of the download page in a box
>>marked PLEASE READ, you will have this problem for every schema.
>>
>>
>>Michael Moser wrote:
>>
>>
>>>BTW: I just downloaded the "library.xsd" file that is listed as
>>>example at the begin of the tutorial to see whether things work
>
> with
>
>>>this schema and I observe EXACTLY the same behaviour!
>>>
>>>Michael
>>
>
>
Re: can't generate EMF model from XML Schema using EMF 2.0 on eclipse 3.0M8 [Ye Olde Sun JDK 1.4 / [message #45288 is a reply to message #44691] Mon, 24 May 2004 10:52 Go to previous message
Michael Moser is currently offline Michael MoserFriend
Messages: 914
Registered: July 2009
Senior Member
"Nick Boldt" <codeslave@ca.ibm.com> wrote in message
news:c8b5bu$1t1$1@eclipse.org...
> ...
> Feel free to let me know if I went a little overboard. ;-)

Absolutely fine with me. Glad that I could contribute a bit to the FAQ
section! :-)

Michael
Re: can't generate EMF model from XML Schema using EMF 2.0 on eclipse 3.0M8 [Ye Olde Sun JDK 1.4 / [message #587407 is a reply to message #44691] Mon, 24 May 2004 10:52 Go to previous message
Michael Moser is currently offline Michael MoserFriend
Messages: 914
Registered: July 2009
Senior Member
"Nick Boldt" <codeslave@ca.ibm.com> wrote in message
news:c8b5bu$1t1$1@eclipse.org...
> ...
> Feel free to let me know if I went a little overboard. ;-)

Absolutely fine with me. Glad that I could contribute a bit to the FAQ
section! :-)

Michael
Previous Topic:Retrieving user information
Next Topic:How to parse a schema from an InputStream
Goto Forum:
  


Current Time: Wed Nov 26 08:00:32 GMT 2014

Powered by FUDForum. Page generated in 0.01784 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software