Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Dali » Problems running WTP 3.0.3 in Eclipse 3.4.1
Problems running WTP 3.0.3 in Eclipse 3.4.1 [message #435009] Fri, 21 November 2008 19:22 Go to next message
Steve Kuo is currently offline Steve Kuo
Messages: 14
Registered: July 2009
Junior Member
How do I properly install WTP into Eclipse? I'm running Eclipse 3.4.1
(Ganymede), fresh install. I then install WTP 3.0.3 via Eclipse's software
update (http://download.eclipse.org/webtools/updates). WTP installs, I
restart Eclipse, go to my project's properties, select JPA and I get the
error NoClassDefFoundError, unable to create the selected property page,
org/eclipse/jpt/core/internal/facet/JpaFacetDataModelPropert ies.

Do I need to install JPA facet before installing WTP?

Thanks, Steve
Re: Problems running WTP 3.0.3 in Eclipse 3.4.1 [message #435021 is a reply to message #435009] Mon, 24 November 2008 16:12 Go to previous messageGo to next message
Neil Hauge is currently offline Neil Hauge
Messages: 469
Registered: July 2009
Senior Member
Steve,

Are you able to create a new JPA project in this state? It sounds like
the JPA plugins are either not installed or not starting due to unresolved
dependencies.

Installing WTP 3.0.3 by default should include the JPA tools.

Neil

Steve Kuo wrote:

> How do I properly install WTP into Eclipse? I'm running Eclipse 3.4.1
> (Ganymede), fresh install. I then install WTP 3.0.3 via Eclipse's software
> update (http://download.eclipse.org/webtools/updates). WTP installs, I
> restart Eclipse, go to my project's properties, select JPA and I get the
> error NoClassDefFoundError, unable to create the selected property page,
> org/eclipse/jpt/core/internal/facet/JpaFacetDataModelPropert ies.

> Do I need to install JPA facet before installing WTP?

> Thanks, Steve
Re: Problems running WTP 3.0.3 in Eclipse 3.4.1 [message #435023 is a reply to message #435021] Mon, 24 November 2008 17:37 Go to previous message
Steve Kuo is currently offline Steve Kuo
Messages: 14
Registered: July 2009
Junior Member
Appears to be a bug: https://bugs.eclipse.org/bugs/show_bug.cgi?id=256187

Steve
Re: Problems running WTP 3.0.3 in Eclipse 3.4.1 [message #611875 is a reply to message #435009] Mon, 24 November 2008 16:12 Go to previous message
Neil Hauge is currently offline Neil Hauge
Messages: 469
Registered: July 2009
Senior Member
Steve,

Are you able to create a new JPA project in this state? It sounds like
the JPA plugins are either not installed or not starting due to unresolved
dependencies.

Installing WTP 3.0.3 by default should include the JPA tools.

Neil

Steve Kuo wrote:

> How do I properly install WTP into Eclipse? I'm running Eclipse 3.4.1
> (Ganymede), fresh install. I then install WTP 3.0.3 via Eclipse's software
> update (http://download.eclipse.org/webtools/updates). WTP installs, I
> restart Eclipse, go to my project's properties, select JPA and I get the
> error NoClassDefFoundError, unable to create the selected property page,
> org/eclipse/jpt/core/internal/facet/JpaFacetDataModelPropert ies.

> Do I need to install JPA facet before installing WTP?

> Thanks, Steve
Re: Problems running WTP 3.0.3 in Eclipse 3.4.1 [message #613100 is a reply to message #435021] Mon, 24 November 2008 17:37 Go to previous message
Steve Kuo is currently offline Steve Kuo
Messages: 14
Registered: July 2009
Junior Member
Appears to be a bug: https://bugs.eclipse.org/bugs/show_bug.cgi?id=256187

Steve
Previous Topic:[Fwd: [dali-dev] questions on monitoring changes on JPA Model]
Next Topic:Migration from Dali 2.0 to 2.1
Goto Forum:
  


Current Time: Tue Sep 02 13:00:47 EDT 2014

Powered by FUDForum. Page generated in 0.02602 seconds