Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Dali » Installing Dali plugin in IBM Rational Software Architect
Installing Dali plugin in IBM Rational Software Architect [message #434546] Thu, 09 August 2007 10:10 Go to next message
Bart Kummel is currently offline Bart Kummel
Messages: 10
Registered: July 2009
Junior Member
Hi,

We use IBM Rational Software Architect as development environment, and we
want to use the Dali Eclipse plugin to generate Entities using TopLink. We
cannot get Dali installed in IBM RSA though. Since IBM RSA is based on
Eclipse, it shouln't be a problem to install Eclipse plugins. We tried
installing Help > Software Updates > Find & Install and via copying the
files into the Eclipse tree, but neither of the to methods succeeded. The
plugin simply doesn't show up.

Does anyone have a suggestion on what to do to get it installed? We use a
separate installation of Eclipse Europa now as a workaround. But I think
you understand we prefer to use a single development environment.

Here's some detailed information about the version of IBM RSA we're using:
* IBM Rational Software Architect: Version: 7.0.0
* Eclipse Platform: Version: 3.2.1.r321_v20060921-b_XVA-INSQSyMtx; Build
id: M20060921-0945

Best regards,
Bart Kummel
Re: Installing Dali plugin in IBM Rational Software Architect [message #434547 is a reply to message #434546] Thu, 09 August 2007 12:51 Go to previous message
Karen Butzke is currently offline Karen Butzke
Messages: 220
Registered: July 2009
Senior Member
Hi Bart,

Dali 1.0 is dependent on Europa which includes Eclipse 3.3 and WTP 2.0.
IBM RSA is dependent on Eclipse 3.2 so Dali will not work in that
environment. You could use the Dali .5 release on Eclipse 3.2, but the
code has changed drastically between .5 and 1.0 because of changes to
support persistence.xml, orm.xml and the many JPA defaults.

thanks,
Karen
Re: Installing Dali plugin in IBM Rational Software Architect [message #605340 is a reply to message #434546] Thu, 09 August 2007 12:51 Go to previous message
Karen Butzke is currently offline Karen Butzke
Messages: 220
Registered: July 2009
Senior Member
Hi Bart,

Dali 1.0 is dependent on Europa which includes Eclipse 3.3 and WTP 2.0.
IBM RSA is dependent on Eclipse 3.2 so Dali will not work in that
environment. You could use the Dali .5 release on Eclipse 3.2, but the
code has changed drastically between .5 and 1.0 because of changes to
support persistence.xml, orm.xml and the many JPA defaults.

thanks,
Karen
Previous Topic:Installing Dali plugin in IBM Rational Software Architect
Next Topic:Use Dali with EclipseUML 2007 Free Edition
Goto Forum:
  


Current Time: Fri Oct 24 09:41:30 GMT 2014

Powered by FUDForum. Page generated in 0.01591 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software