Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Dali » DDL Generation working okay on M2?
DDL Generation working okay on M2? [message #433784] Tue, 25 April 2006 16:12 Go to next message
Kevin Sutter is currently offline Kevin Sutter
Messages: 104
Registered: July 2009
Senior Member
Hi,
Is anybody else having problems generating DDL with the M2 driver? I had
a problem report (134825) open for this in the M1 timeframe, but it
magically went away when I re-installed the Dali driver. Now, with the M2
driver, I am getting an NPE whenever I attempt to bring up the DDL wizard:

Error
Tue Apr 25 10:53:53 CDT 2006
java.lang.NullPointerException

java.lang.NullPointerException
at
org.eclipse.wst.rdb.internal.models.sql.datatypes.impl.Chara cterStringDataTypeImpl.eSet(CharacterStringDataTypeImpl.java :364)
at
org.eclipse.dali.db.ddl.OrmDdlGenerator.copyDataType(OrmDdlG enerator.java:373)
at
org.eclipse.dali.db.ddl.OrmDdlGenerator.addJoinColumn(OrmDdl Generator.java:334)
at
org.eclipse.dali.db.ddl.OrmDdlGenerator.addRefColumns(OrmDdl Generator.java:309)
at
org.eclipse.dali.db.ddl.OrmDdlGenerator.createDdl(OrmDdlGene rator.java:214)
at
org.eclipse.dali.ui.actions.GenerateDdlAction.execute(Genera teDdlAction.java:28)
at
org.eclipse.dali.ui.actions.ProjectAction.execute(ProjectAct ion.java:90)
at
org.eclipse.dali.ui.actions.ProjectAction.execute(ProjectAct ion.java:71)
at org.eclipse.dali.ui.actions.ProjectAction.run(ProjectAction. java:63)
at
org.eclipse.ui.internal.PluginAction.runWithEvent(PluginActi on.java:254)
at
org.eclipse.jface.action.ActionContributionItem.handleWidget Selection(ActionContributionItem.java:539)
at
org.eclipse.jface.action.ActionContributionItem.access$2(Act ionContributionItem.java:488)
at
org.eclipse.jface.action.ActionContributionItem$5.handleEven t(ActionContributionItem.java:400)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java :66)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:925)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.ja va:3346)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :2966)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.jav a:1914)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:1878)
at
org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Work bench.java:419)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:143)
at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplicatio n.java:95)
at
org.eclipse.core.internal.runtime.PlatformActivator$1.run(Pl atformActivator.java:78)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:92)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:68)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:376)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:169)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:64)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:615)
at org.eclipse.core.launcher.Main.invokeFramework(Main.java:336 )
at org.eclipse.core.launcher.Main.basicRun(Main.java:280)
at org.eclipse.core.launcher.Main.run(Main.java:977)
at org.eclipse.core.launcher.Main.main(Main.java:952)

Any ideas? If I could kick off the ddl generation at either the package
or the file level (hint, hint), I could possibly help narrow down the
offending annotation. :-)

Thanks,
Kevin
Re: DDL Generation working okay on M2? [message #433785 is a reply to message #433784] Tue, 25 April 2006 16:38 Go to previous messageGo to next message
Karen Butzke is currently offline Karen Butzke
Messages: 220
Registered: July 2009
Senior Member
Hi Kevin,

This problem was reported as bug #136658. Also, there was some
information in thread
http://www.eclipse.org/newsportal/article.php?id=123&gro up=eclipse.technology.dali#123
that the offending annotation was a Many-Many.
Re: DDL Generation working okay on M2? [message #433786 is a reply to message #433785] Tue, 25 April 2006 17:59 Go to previous message
Kevin Sutter is currently offline Kevin Sutter
Messages: 104
Registered: July 2009
Senior Member
You are right on, Karen. I don't know I missed that bug report... The
title jumps out at me now. And, the posting you referenced was spot on
with the ManyToMany relationship. Thanks for your quick reply!

Kevin

Karen wrote:

> Hi Kevin,

> This problem was reported as bug #136658. Also, there was some
> information in thread
>
http://www.eclipse.org/newsportal/article.php?id=123&gro up=eclipse.technology.dali#123
> that the offending annotation was a Many-Many.
Re: DDL Generation working okay on M2? [message #583238 is a reply to message #433784] Tue, 25 April 2006 16:38 Go to previous message
Karen Butzke is currently offline Karen Butzke
Messages: 220
Registered: July 2009
Senior Member
Hi Kevin,

This problem was reported as bug #136658. Also, there was some
information in thread
http://www.eclipse.org/newsportal/article.php?id=123&gro up=eclipse.technology.dali#123
that the offending annotation was a Many-Many.
Re: DDL Generation working okay on M2? [message #583254 is a reply to message #433785] Tue, 25 April 2006 17:59 Go to previous message
Kevin Sutter is currently offline Kevin Sutter
Messages: 104
Registered: July 2009
Senior Member
You are right on, Karen. I don't know I missed that bug report... The
title jumps out at me now. And, the posting you referenced was spot on
with the ManyToMany relationship. Thanks for your quick reply!

Kevin

Karen wrote:

> Hi Kevin,

> This problem was reported as bug #136658. Also, there was some
> information in thread
>
http://www.eclipse.org/newsportal/article.php?id=123&gro up=eclipse.technology.dali#123
> that the offending annotation was a Many-Many.
Previous Topic:DDL Generation working okay on M2?
Next Topic:Online help and user guide
Goto Forum:
  


Current Time: Sat Oct 25 17:34:06 GMT 2014

Powered by FUDForum. Page generated in 0.01756 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software