Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » Cannot load lib ssleay.dll
Cannot load lib ssleay.dll [message #43229] Sun, 15 March 2009 02:00 Go to next message
sNop is currently offline sNopFriend
Messages: 281
Registered: July 2009
Senior Member
Hi,

I want to install JavaHL 1.4.x and JavaHL 1.5.x as well, because I must work with older repos

If i install only JavaHL 1.5.x connector, everything is loaded without problems and i have
used this config all time, but now i have installed JavaHL 1.4.5 and Native JavaHL
implementation 1.4 and here the problem arised.

Here is the error:
http://tinyurl.com/bvt3lb

and here are version of my plugins:
http://tinyurl.com/dbl2m5

I'm using latest Eclipse 3.4.2

If you need some more info pls ask me.

Thank you very much for any advices and suggestions
Re: Cannot load lib ssleay.dll [message #43314 is a reply to message #43229] Mon, 16 March 2009 09:07 Go to previous messageGo to next message
Igor Burilo is currently offline Igor BuriloFriend
Messages: 435
Registered: July 2009
Senior Member
Hello sNop,

You can install JavaHL 1.4 and JavaHL 1.5 at the same time. Here's the
detailed description:
This is well known JVM bug (or feature :) ): both connectors uses the same
supplementary dynamic libraries, Eclipse Platform loads each plug-in with
its
own class loader and JVM allows loading of these libraries only by one class
loader not by both simultaneously. So, in order to avoid the problem please
uninstall JavaHL connector which is useless for you (for example 1.4.5-based
version).

> Hi,
>
> I want to install JavaHL 1.4.x and JavaHL 1.5.x as well, because I must
> work with older repos
>
> If i install only JavaHL 1.5.x connector, everything is loaded without
> problems and i have
> used this config all time, but now i have installed JavaHL 1.4.5 and
> Native JavaHL
> implementation 1.4 and here the problem arised.
>
> Here is the error:
> http://tinyurl.com/bvt3lb
>
> and here are version of my plugins:
> http://tinyurl.com/dbl2m5
>
> I'm using latest Eclipse 3.4.2
>
> If you need some more info pls ask me.
>
> Thank you very much for any advices and suggestions
Re: Cannot load lib ssleay.dll [message #43380 is a reply to message #43314] Mon, 16 March 2009 10:30 Go to previous messageGo to next message
sNop is currently offline sNopFriend
Messages: 281
Registered: July 2009
Senior Member
Igor Burilo napsal(a):
> Hello sNop,
>
> You can install JavaHL 1.4 and JavaHL 1.5 at the same time. Here's the
> detailed description:
> This is well known JVM bug (or feature :) ): both connectors uses the same
> supplementary dynamic libraries, Eclipse Platform loads each plug-in with
> its
> own class loader and JVM allows loading of these libraries only by one class
> loader not by both simultaneously. So, in order to avoid the problem please
> uninstall JavaHL connector which is useless for you (for example 1.4.5-based
> version).
>

Hi Igor,

but how can I show history for reposities which are in Subversion 1.4.x, if i'm using
connector JavHL 1.5.x so i get the error:
Get log messages for 'http://svn.modxcms.com/svn/tattoo/tattoo/branches/1.0' failed.
Trying to use an unsupported feature
svn: Querying mergeinfo requires version 3 of the FSFS filesystem schema; filesystem
'/usr/local/svn/tattoo/db' uses only version 2

How should I handle this ?

Thank you for advices
Re: Cannot load lib ssleay.dll [message #43411 is a reply to message #43380] Tue, 17 March 2009 09:34 Go to previous messageGo to next message
Igor Burilo is currently offline Igor BuriloFriend
Messages: 435
Registered: July 2009
Senior Member
Hello sNop,

This problem indicates that you have a BerkelyDB version mismatch.
I can see here following solutions:
1. You can run svnadmin upgrade on the Subversion repository
2. Try to use SvnKit connector for svn 1.4 (currently it's SvnKit 1.1.7)

For more info, please try to google as it more relates to SVN than to
Subversive

> Igor Burilo napsal(a):
>> Hello sNop,
>>
>> You can install JavaHL 1.4 and JavaHL 1.5 at the same time. Here's the
>> detailed description:
>> This is well known JVM bug (or feature :) ): both connectors uses the
>> same
>> supplementary dynamic libraries, Eclipse Platform loads each plug-in with
>> its
>> own class loader and JVM allows loading of these libraries only by one
>> class
>> loader not by both simultaneously. So, in order to avoid the problem
>> please
>> uninstall JavaHL connector which is useless for you (for example
>> 1.4.5-based
>> version).
>>
>
> Hi Igor,
>
> but how can I show history for reposities which are in Subversion 1.4.x,
> if i'm using
> connector JavHL 1.5.x so i get the error:
> Get log messages for
> 'http://svn.modxcms.com/svn/tattoo/tattoo/branches/1.0' failed.
> Trying to use an unsupported feature
> svn: Querying mergeinfo requires version 3 of the FSFS filesystem schema;
> filesystem
> '/usr/local/svn/tattoo/db' uses only version 2
>
> How should I handle this ?
>
> Thank you for advices
Re: Cannot load lib ssleay.dll [message #43440 is a reply to message #43411] Tue, 17 March 2009 17:26 Go to previous messageGo to next message
sNop is currently offline sNopFriend
Messages: 281
Registered: July 2009
Senior Member
Hi Igor,

thank you for reaction

> This problem indicates that you have a BerkelyDB version mismatch.
> I can see here following solutions:
> 1. You can run svnadmin upgrade on the Subversion repository

this isn't my repo and i don't have admin access and I have many repos in Subversive for
many projects which are only public accessible and i don't have admin access on many of them

> 2. Try to use SvnKit connector for svn 1.4 (currently it's SvnKit 1.1.7)
>

i try this, but i want to note that install SvnKit 1.1.7 it's impossible throught update
manager, because in few seconds downloading freez and i can't find any archoved update
site for Subversive connectors

> For more info, please try to google as it more relates to SVN than to
> Subversive
>
Re: Cannot load lib ssleay.dll [message #43471 is a reply to message #43440] Tue, 17 March 2009 17:37 Go to previous messageGo to next message
sNop is currently offline sNopFriend
Messages: 281
Registered: July 2009
Senior Member
sNop napsal(a):
> Hi Igor,
>
> thank you for reaction
>
>> This problem indicates that you have a BerkelyDB version mismatch.
>> I can see here following solutions:
>> 1. You can run svnadmin upgrade on the Subversion repository
>
> this isn't my repo and i don't have admin access and I have many repos in Subversive for
> many projects which are only public accessible and i don't have admin access on many of them
>

So ihave archoved update site here:
http://www.polarion.com/products/svn/subversive.php?src=ecli pseproject

but when i download any connector through web browser from official polarion update site,
so he have 13kB or 14kB

It's only notice i donť know if it's a bug
Re: Cannot load lib ssleay.dll [message #43502 is a reply to message #43471] Wed, 18 March 2009 08:25 Go to previous messageGo to next message
Igor Burilo is currently offline Igor BuriloFriend
Messages: 435
Registered: July 2009
Senior Member
Hello sNop,

Here's a link to latest archived update site for connectors:
http://www.polarion.org/projects/subversive/download/eclipse /2.0/builds/Subversive-connectors-2.1.0.I20090213-1500.zip. I
just checked it and it works

"sNop" <snop3@seznam.cz> ???????/???????? ? ???????? ?????????:
news:gpon4b$vhj$1@build.eclipse.org...
> sNop napsal(a):
>> Hi Igor,
>>
>> thank you for reaction
>>
>>> This problem indicates that you have a BerkelyDB version mismatch.
>>> I can see here following solutions:
>>> 1. You can run svnadmin upgrade on the Subversion repository
>>
>> this isn't my repo and i don't have admin access and I have many repos in
>> Subversive for
>> many projects which are only public accessible and i don't have admin
>> access on many of them
>>
>
> So ihave archoved update site here:
> http://www.polarion.com/products/svn/subversive.php?src=ecli pseproject
>
> but when i download any connector through web browser from official
> polarion update site,
> so he have 13kB or 14kB
>
> It's only notice i don
Re: Cannot load lib ssleay.dll [message #43534 is a reply to message #43502] Wed, 18 March 2009 11:44 Go to previous messageGo to next message
sNop is currently offline sNopFriend
Messages: 281
Registered: July 2009
Senior Member
Igor Burilo napsal(a):
> Hello sNop,
>
> Here's a link to latest archived update site for connectors:
> http://www.polarion.org/projects/subversive/download/eclipse /2.0/builds/Subversive-connectors-2.1.0.I20090213-1500.zip. I
> just checked it and it works
>

Hi Igor,

i don't know why, but i can't download svnkit 1.1.7 connector through update manager and
the same with the archive site. Few kB are downloaded then download speed drop down slowly
to the few bytes (in e.g. opera to 0,0kB) and that is all

I don't have any problem with downloading anything or with internet connection, i have
problem only with downloading stuffs which i have described above
Re: Cannot load lib ssleay.dll [message #43564 is a reply to message #43534] Wed, 18 March 2009 11:57 Go to previous messageGo to next message
sNop is currently offline sNopFriend
Messages: 281
Registered: July 2009
Senior Member
Hi Igor,

pls, can you send me archove site to my email ?

Thank you
Re: Cannot load lib ssleay.dll [message #43594 is a reply to message #43564] Thu, 19 March 2009 08:42 Go to previous messageGo to next message
Igor Burilo is currently offline Igor BuriloFriend
Messages: 435
Registered: July 2009
Senior Member
Hello sNop,

Unfortunately, it's quite big, about 19Mb. I'll investigate this problem
deeply.

> Hi Igor,
>
> pls, can you send me archove site to my email ?
>
> Thank you
Re: Cannot load lib ssleay.dll [message #43623 is a reply to message #43411] Sat, 21 March 2009 00:27 Go to previous message
sNop is currently offline sNopFriend
Messages: 281
Registered: July 2009
Senior Member
Igor Burilo napsal(a):
> Hello sNop,
>
> This problem indicates that you have a BerkelyDB version mismatch.
> I can see here following solutions:
> 1. You can run svnadmin upgrade on the Subversion repository
> 2. Try to use SvnKit connector for svn 1.4 (currently it's SvnKit 1.1.7)
>
> For more info, please try to google as it more relates to SVN than to
> Subversive
>

Hi Igor,

so i have installed SvnKit 1.1.7 Connector and I have installed JavaHL 1.5.4 connector
too, but when I try to show history from repo which have old format i get the error:
Get log messages for 'http://svn.modxcms.com/svn/tattoo/tattoo/branches/1.0' failed.
Trying to use an unsupported feature
svn: Querying mergeinfo requires version 3 of the FSFS filesystem schema; filesystem
'/usr/local/svn/tattoo/db' uses only version 2


It's somehow possible to handle old and new versions of the subversion repos with subversive ?

And if it's possible how ? What combination of the connectors i should to use ?

Thank for any advices and suggestions
Previous Topic:Weekly builds for Subversive Connectors
Next Topic:timeout getting connectors for 3.5m6
Goto Forum:
  


Current Time: Thu Dec 18 14:39:43 GMT 2014

Powered by FUDForum. Page generated in 0.02026 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software