Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DTP » problems with format SQL and code assist
problems with format SQL and code assist [message #40369] Thu, 03 January 2008 06:17 Go to next message
Eclipse User
Originally posted by: eclipsenews.20.epm.spamgourmet.com

Hi,

I've installed DTP 1.5.1 from the update site. It mostly works. I setup
some db connections (to postgres using postgres 8.2 jdbc driver). I can
browse the DBs fine in the data source explorer, execute queries, view
the results, and use the sql editor.

However some features just don't seem to work, Format SQL doesn't appear
to do anything, and code assist, while offering suggestions for SQL
keywords like SELECT, doesn't seem to know anything about the tables and
columns in my db and won't autocomplete them (I got the impression it
should be able to based on some of the docs I've seen).

I've looked at the plugins manager, no DTP components are indicated as
having problems. I also tried dropping lpgjavaruntime.jar into my
classpath, with no effect on the problems above. And then tried using
the 1.6M4 release (since another comment mentioned that lpg came bundled
in that, and I thought maybe LPG had something to do with my probs).

Am I misunderstanding something or have I done something wrong in
installation?

Thanks
Tom

(Eclipse 3.3.1 btw)
Re: problems with format SQL and code assist [message #40624 is a reply to message #40369] Wed, 16 January 2008 22:57 Go to previous message
Eclipse User
Originally posted by: eclipsenews.20.epm.spamgourmet.com

Anybody got a hint?

Oh, something I forgot to mention is that the outline view doesn't work
either. I suspect it is all related.

Tom Walter wrote:
> Hi,
>
> I've installed DTP 1.5.1 from the update site. It mostly works. I setup
> some db connections (to postgres using postgres 8.2 jdbc driver). I can
> browse the DBs fine in the data source explorer, execute queries, view
> the results, and use the sql editor.
>
> However some features just don't seem to work, Format SQL doesn't appear
> to do anything, and code assist, while offering suggestions for SQL
> keywords like SELECT, doesn't seem to know anything about the tables and
> columns in my db and won't autocomplete them (I got the impression it
> should be able to based on some of the docs I've seen).
>
> I've looked at the plugins manager, no DTP components are indicated as
> having problems. I also tried dropping lpgjavaruntime.jar into my
> classpath, with no effect on the problems above. And then tried using
> the 1.6M4 release (since another comment mentioned that lpg came bundled
> in that, and I thought maybe LPG had something to do with my probs).
>
> Am I misunderstanding something or have I done something wrong in
> installation?
>
> Thanks
> Tom
>
> (Eclipse 3.3.1 btw)
Re: problems with format SQL and code assist [message #589604 is a reply to message #40369] Wed, 16 January 2008 22:57 Go to previous message
Tom Walter is currently offline Tom Walter
Messages: 8
Registered: July 2009
Junior Member
Anybody got a hint?

Oh, something I forgot to mention is that the outline view doesn't work
either. I suspect it is all related.

Tom Walter wrote:
> Hi,
>
> I've installed DTP 1.5.1 from the update site. It mostly works. I setup
> some db connections (to postgres using postgres 8.2 jdbc driver). I can
> browse the DBs fine in the data source explorer, execute queries, view
> the results, and use the sql editor.
>
> However some features just don't seem to work, Format SQL doesn't appear
> to do anything, and code assist, while offering suggestions for SQL
> keywords like SELECT, doesn't seem to know anything about the tables and
> columns in my db and won't autocomplete them (I got the impression it
> should be able to based on some of the docs I've seen).
>
> I've looked at the plugins manager, no DTP components are indicated as
> having problems. I also tried dropping lpgjavaruntime.jar into my
> classpath, with no effect on the problems above. And then tried using
> the 1.6M4 release (since another comment mentioned that lpg came bundled
> in that, and I thought maybe LPG had something to do with my probs).
>
> Am I misunderstanding something or have I done something wrong in
> installation?
>
> Thanks
> Tom
>
> (Eclipse 3.3.1 btw)
Previous Topic:datatools tooooo sloooooow.......
Next Topic:SQL Editor using ODA conx - 1 attachment
Goto Forum:
  


Current Time: Tue Sep 23 22:27:12 GMT 2014

Powered by FUDForum. Page generated in 0.01793 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software