Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » SWTBot » Getting Exception starting swtbot with ant
Getting Exception starting swtbot with ant [message #40242] Tue, 23 June 2009 22:15 Go to next message
Markus Oley is currently offline Markus OleyFriend
Messages: 257
Registered: July 2009
Location: Germany
Senior Member
Hi,

I get the following stacktrace starting my test swtbot-test with ant:
Can anyone please tell me, what I'm doing wrong,

Thank you, Greetings
Markus


java.lang.RuntimeException: Application
" org.eclipse.swtbot.eclipse.junit4.headless.swtbottestapplica tion " could
not be found in the registry. The applications available are:
org.eclipse.ant.core.antRunner, org.eclipse.equinox.app.error,
org.eclipse.equinox.p2.artifact.repository.mirrorApplication ,
org.eclipse.equinox.p2.director.app.application,
org.eclipse.equinox.p2.metadata.generator.EclipseGenerator,
org.eclipse.equinox.p2.metadata.repository.mirrorApplication ,
org.eclipse.equinox.p2.reconciler.application,
org.eclipse.help.base.infocenterApplication,
org.eclipse.help.base.helpApplication, org.eclipse.help.base.indexTool,
org.eclipse.ui.ide.workbench, org.eclipse.update.core.standaloneUpdate,
org.eclipse.update.core.siteOptimizer,
org.eclipse.wst.server.preview.preview,
org.eclipse.wst.jsdt.core.JavaCodeFormatter, org.eclipse.pde.build.Build,
org.eclipse.swtbot.eclipse.core.swtbottestapplication,
org.eclipse.pde.junit.runtime.uitestapplication,
org.eclipse.pde.junit.runtime.legacytestapplication,
org.eclipse.pde.junit.runtime.coretestapplication,
org.eclipse.pde.junit.runtime.coretestapplicationnonmain,
org.eclipse.jdt.core.JavaCodeFormatter, org.eclipse.jdt.apt.core.aptBuild,
org.eclipse.emf.codegen.CodeGen, org.eclipse.emf.codegen.JMerger,
org.eclipse.emf.codegen.ecore.Generator,
org.eclipse.emf.importer.rose.Rose2GenModel,
org.eclipse.emf.importer.java.Java2GenModel,
org.eclipse.emf.importer.ecore.Ecore2GenModel,
org.eclipse.datatools.connectivity.console.profile.StorageFi leEditor,
org.eclipse.ant.ui.antRunner.
at
org.eclipse.equinox.internal.app.EclipseAppContainer.startDe faultApp(EclipseAppContainer.java:242)
at
org.eclipse.equinox.internal.app.MainApplicationLauncher.run (MainApplicationLauncher.java:29)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:386)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 549)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
at org.eclipse.equinox.launcher.Main.main(Main.java:1212)
at org.eclipse.core.launcher.Main.main(Main.java:30)
Re: Getting Exception starting swtbot with ant [message #40533 is a reply to message #40242] Thu, 25 June 2009 18:58 Go to previous messageGo to next message
Pascal G is currently offline Pascal GFriend
Messages: 157
Registered: July 2009
Senior Member
Make sure your Eclipse you are running against has the SWTBot plugin
installed (headless and all) and make sure that you remove the junit3
entries (because from what I see, you want to use junit4).

Markus Oley wrote:
> Hi,
> I get the following stacktrace starting my test swtbot-test with ant:
> Can anyone please tell me, what I'm doing wrong,
> Thank you, Greetings
> Markus
>
> java.lang.RuntimeException: Application
> " org.eclipse.swtbot.eclipse.junit4.headless.swtbottestapplica tion " could
> not be found in the registry. The applications available are:
> org.eclipse.ant.core.antRunner, org.eclipse.equinox.app.error,
> org.eclipse.equinox.p2.artifact.repository.mirrorApplication ,
> org.eclipse.equinox.p2.director.app.application,
> org.eclipse.equinox.p2.metadata.generator.EclipseGenerator,
> org.eclipse.equinox.p2.metadata.repository.mirrorApplication ,
> org.eclipse.equinox.p2.reconciler.application,
> org.eclipse.help.base.infocenterApplication,
> org.eclipse.help.base.helpApplication, org.eclipse.help.base.indexTool,
> org.eclipse.ui.ide.workbench, org.eclipse.update.core.standaloneUpdate,
> org.eclipse.update.core.siteOptimizer,
> org.eclipse.wst.server.preview.preview,
> org.eclipse.wst.jsdt.core.JavaCodeFormatter,
> org.eclipse.pde.build.Build,
> org.eclipse.swtbot.eclipse.core.swtbottestapplication,
> org.eclipse.pde.junit.runtime.uitestapplication,
> org.eclipse.pde.junit.runtime.legacytestapplication,
> org.eclipse.pde.junit.runtime.coretestapplication,
> org.eclipse.pde.junit.runtime.coretestapplicationnonmain,
> org.eclipse.jdt.core.JavaCodeFormatter,
> org.eclipse.jdt.apt.core.aptBuild, org.eclipse.emf.codegen.CodeGen,
> org.eclipse.emf.codegen.JMerger,
> org.eclipse.emf.codegen.ecore.Generator,
> org.eclipse.emf.importer.rose.Rose2GenModel,
> org.eclipse.emf.importer.java.Java2GenModel,
> org.eclipse.emf.importer.ecore.Ecore2GenModel,
> org.eclipse.datatools.connectivity.console.profile.StorageFi leEditor,
> org.eclipse.ant.ui.antRunner.
> at
> org.eclipse.equinox.internal.app.EclipseAppContainer.startDe faultApp(EclipseAppContainer.java:242)
>
> at
> org.eclipse.equinox.internal.app.MainApplicationLauncher.run (MainApplicationLauncher.java:29)
>
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
>
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
>
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:386)
>
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
>
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
>
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
>
> at java.lang.reflect.Method.invoke(Method.java:585)
> at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 549)
> at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
> at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
> at org.eclipse.equinox.launcher.Main.main(Main.java:1212)
> at org.eclipse.core.launcher.Main.main(Main.java:30)
>
>
Re: Getting Exception starting swtbot with ant [message #40557 is a reply to message #40533] Thu, 25 June 2009 19:13 Go to previous messageGo to next message
Markus Oley is currently offline Markus OleyFriend
Messages: 257
Registered: July 2009
Location: Germany
Senior Member
Hi again,

thank your for your answer....

I don't know where to get all of the wanted plugins....
I found the following:
org.eclipse.swtbot.eclipse.core_2.0.0.320-dev.jar
org.eclipse.swtbot.eclipse.finder_2.0.0.320-dev.jar
org.eclipse.swtbot.eclipse.spy_2.0.0.320-dev.jar
org.eclipse.swtbot.eclipse.ui_2.0.0.320-dev.jar
org.eclipse.swtbot.junit4_x_2.0.0.320-dev.jar
org.eclipse.swtbot.swt.finder_2.0.0.320-dev.jar

my feature.jar doesn't define more jars - what jars do I need in addition
and where do I get them?

Thanks in advance

Greetings
Markus
Re: Getting Exception starting swtbot with ant [message #40620 is a reply to message #40557] Thu, 25 June 2009 19:34 Go to previous message
Pascal G is currently offline Pascal GFriend
Messages: 157
Registered: July 2009
Senior Member
Go on the download page of the project website
(http://www.eclipse.org/swtbot/downloads.php) and download the Headless
Testing Framework. That'll get you a zip file you need to unzip in your
eclipse directory.

Markus Oley wrote:
> Hi again,
> thank your for your answer....
> I don't know where to get all of the wanted plugins....
> I found the following: org.eclipse.swtbot.eclipse.core_2.0.0.320-dev.jar
> org.eclipse.swtbot.eclipse.finder_2.0.0.320-dev.jar
> org.eclipse.swtbot.eclipse.spy_2.0.0.320-dev.jar
> org.eclipse.swtbot.eclipse.ui_2.0.0.320-dev.jar
> org.eclipse.swtbot.junit4_x_2.0.0.320-dev.jar
> org.eclipse.swtbot.swt.finder_2.0.0.320-dev.jar
>
> my feature.jar doesn't define more jars - what jars do I need in
> addition and where do I get them?
> Thanks in advance
>
> Greetings
> Markus
>
>
Previous Topic:TestNG Support.
Next Topic:This is a great tool.
Goto Forum:
  


Current Time: Thu Dec 18 13:45:55 GMT 2014

Powered by FUDForum. Page generated in 0.02240 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software