Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Mylyn » Problems updating from Mylyn 2.1 to 2.2 using Update Manager
Problems updating from Mylyn 2.1 to 2.2 using Update Manager [message #40233] Wed, 02 January 2008 09:15 Go to next message
Eclipse User
Originally posted by: mauro.molinari.cardinis.com

Hello!
Today I returned at work and tried to update my Mylyn 2.1 to 2.2 using
Update Manager ("search for updates of currently installed feature").

This is what Update Manager found out to be available:
-> Mylyn for Eclipse 3.3
-> Features
-> Mylyn Task List (Required) 2.2.0.I20071220-1700
-> Mylyn Focuesed UI (Required) 2.2.0.I20071220-1700
-> Integration
-> Mylyn Bridge: Eclipse IDE 2.2.0.I20071220-1700
-> Mylyn Bridge: Java Development 2.2.0.I20071220-1700
-> Mylyn Bridge: PDE, CVS and Ant 2.2.0.I20071220-1700
-> Mylyn Connector: Bugzilla 2.2.0.I20071220-1700
No other available updates are shown.
The problem is that if I check to install "Mylyn for Eclipse 3.3", the
following error message is given:

Eclipse RCP Patch 1 for 3.3 (3.3.0.v20070705_330) requires feature
"org.eclipse.rcp (3.3.0_v20070607-8y8eE8NEbsN3X_fjWS8HPNG)".

If I press on "Select required" doesn't help, obviously, because I don't
have any other updates available in the list of features to install.

What's this? Why does it show up when trying to update Mylyn, while it
seems a problem regarding Eclipse RCP? Do you have any idea?

Mauro.
Re: Problems updating from Mylyn 2.1 to 2.2 using Update Manager [message #40244 is a reply to message #40233] Wed, 02 January 2008 11:43 Go to previous messageGo to next message
Eclipse User
Originally posted by: mauro.molinari.cardinis.com

Now I think I solved that problem, by closing Eclipse and restarting
using -clean option.
However, I'm now encountering another problem...

When I try to install Mylyn I get the following error:

Java Persistence API Tools (1.0.1.v200709130000-77-5CYQCCz-Dz0NJCDCD)
requires feature "org.eclipse.datatools.connectivity.feature".

Something similar has been posted by Werner Keil in this newsgroup on
2007/10/08, but I can't find any solution for that... :-(

I'm going to try to investigate more...

Mauro.
Re: Problems updating from Mylyn 2.1 to 2.2 using Update Manager [message #40254 is a reply to message #40233] Wed, 02 January 2008 13:33 Go to previous messageGo to next message
Eclipse User
Originally posted by: mauro.molinari.cardinis.com

Nope... I haven't solved the problem :-(
After manually installing missing (and required...) DTP features, I am
still encountering the original problem:

Eclipse RCP Patch 1 for 3.3 (3.3.0.v20070705_330) requires feature
"org.eclipse.rcp (3.3.0.v20070607-8y8eE8NEbsN3X_fjWS8HPNG)"

The strange thing is that I do have both features in my eclipse/features
folder!

org.eclipse.rcp.patch1_3.3.0.v20070705_330
org.eclipse.rcp_3.3.0.v20070607-8y8eE8NEbsN3X_fjWS8HPNG

So, why am I facing this error?

Mauro.
Re: Problems updating from Mylyn 2.1 to 2.2 using Update Manager [message #40360 is a reply to message #40254] Fri, 04 January 2008 10:44 Go to previous messageGo to next message
Eclipse User
Originally posted by: mauro.molinari.cardinis.com

Just a follow up if anybody is interested because of similar problems...

I eventually fixed the problem by:
1) manually installing the whole DTP (there must have been some errors
in Eclipse for JEE Packaging... there's a similar bug about it in Bugzilla)
2) disabling and then removing RCP Patch 1 for Eclipse 3.3.1

Then, I could use update manager again to download and install Mylyn 2.2
correctly.

Moreover, today by doing a "search for updates of currently installed
features" I could actually find and install RCP Patches 1 and 2 for
Eclipse 3.3.1.1, so there may have been works in progress during last
days...
The only side note is that, going to "Manage Configuration", if I show
properties for Eclipse RCP Patch 1 for 3.3.1.1 I see:

The feature may not be configured properly.
Plug-in: "com.ibm.icu36.data.update" version: "3.6.1.v20071204_2007j"
referenced by this feature is not included at runtime. Runtime includes
plug-in version "3.6.1.v20080102_2007k" supplied by feature "Eclipse RCP
Patch 2 for 3.3.1.1" version "3.3.1.1_v20080102_3311".

Anyway, it seems a warning rather than a not-working error.

Mauro.
Re: Problems updating from Mylyn 2.1 to 2.2 using Update Manager [message #41006 is a reply to message #40360] Sat, 12 January 2008 00:19 Go to previous message
Eclipse User
Originally posted by: beatmik.acm.org

Great to see that you got to the bottom of this Mauro. As you know this
is related to the DTP/Europa install bug:

194959: Pieces missing from Eclipse IDE for Java EE Developers distribution
https://bugs.eclipse.org/bugs/show_bug.cgi?id=194959

Since quite a few Mylyn users hit it we have instructions about it in
our FAQ:

http://wiki.eclipse.org/index.php/Mylyn_FAQ#Installation_Tro ubleshooting

If they're lacking any information that would have helped you, it would
be great if you could expand on the corresponding section.

Mik


Mauro Molinari wrote:
> Just a follow up if anybody is interested because of similar problems...
>
> I eventually fixed the problem by:
> 1) manually installing the whole DTP (there must have been some errors
> in Eclipse for JEE Packaging... there's a similar bug about it in Bugzilla)
> 2) disabling and then removing RCP Patch 1 for Eclipse 3.3.1
>
> Then, I could use update manager again to download and install Mylyn 2.2
> correctly.
>
> Moreover, today by doing a "search for updates of currently installed
> features" I could actually find and install RCP Patches 1 and 2 for
> Eclipse 3.3.1.1, so there may have been works in progress during last
> days...
> The only side note is that, going to "Manage Configuration", if I show
> properties for Eclipse RCP Patch 1 for 3.3.1.1 I see:
>
> The feature may not be configured properly.
> Plug-in: "com.ibm.icu36.data.update" version: "3.6.1.v20071204_2007j"
> referenced by this feature is not included at runtime. Runtime includes
> plug-in version "3.6.1.v20080102_2007k" supplied by feature "Eclipse RCP
> Patch 2 for 3.3.1.1" version "3.3.1.1_v20080102_3311".
>
> Anyway, it seems a warning rather than a not-working error.
>
> Mauro.
Re: Problems updating from Mylyn 2.1 to 2.2 using Update Manager [message #586581 is a reply to message #40233] Wed, 02 January 2008 11:43 Go to previous message
Mauro Molinari is currently offline Mauro Molinari
Messages: 278
Registered: July 2009
Senior Member
Now I think I solved that problem, by closing Eclipse and restarting
using -clean option.
However, I'm now encountering another problem...

When I try to install Mylyn I get the following error:

Java Persistence API Tools (1.0.1.v200709130000-77-5CYQCCz-Dz0NJCDCD)
requires feature "org.eclipse.datatools.connectivity.feature".

Something similar has been posted by Werner Keil in this newsgroup on
2007/10/08, but I can't find any solution for that... :-(

I'm going to try to investigate more...

Mauro.
Re: Problems updating from Mylyn 2.1 to 2.2 using Update Manager [message #586597 is a reply to message #40233] Wed, 02 January 2008 13:33 Go to previous message
Mauro Molinari is currently offline Mauro Molinari
Messages: 278
Registered: July 2009
Senior Member
Nope... I haven't solved the problem :-(
After manually installing missing (and required...) DTP features, I am
still encountering the original problem:

Eclipse RCP Patch 1 for 3.3 (3.3.0.v20070705_330) requires feature
"org.eclipse.rcp (3.3.0.v20070607-8y8eE8NEbsN3X_fjWS8HPNG)"

The strange thing is that I do have both features in my eclipse/features
folder!

org.eclipse.rcp.patch1_3.3.0.v20070705_330
org.eclipse.rcp_3.3.0.v20070607-8y8eE8NEbsN3X_fjWS8HPNG

So, why am I facing this error?

Mauro.
Re: Problems updating from Mylyn 2.1 to 2.2 using Update Manager [message #586653 is a reply to message #40254] Fri, 04 January 2008 10:44 Go to previous message
Mauro Molinari is currently offline Mauro Molinari
Messages: 278
Registered: July 2009
Senior Member
Just a follow up if anybody is interested because of similar problems...

I eventually fixed the problem by:
1) manually installing the whole DTP (there must have been some errors
in Eclipse for JEE Packaging... there's a similar bug about it in Bugzilla)
2) disabling and then removing RCP Patch 1 for Eclipse 3.3.1

Then, I could use update manager again to download and install Mylyn 2.2
correctly.

Moreover, today by doing a "search for updates of currently installed
features" I could actually find and install RCP Patches 1 and 2 for
Eclipse 3.3.1.1, so there may have been works in progress during last
days...
The only side note is that, going to "Manage Configuration", if I show
properties for Eclipse RCP Patch 1 for 3.3.1.1 I see:

The feature may not be configured properly.
Plug-in: "com.ibm.icu36.data.update" version: "3.6.1.v20071204_2007j"
referenced by this feature is not included at runtime. Runtime includes
plug-in version "3.6.1.v20080102_2007k" supplied by feature "Eclipse RCP
Patch 2 for 3.3.1.1" version "3.3.1.1_v20080102_3311".

Anyway, it seems a warning rather than a not-working error.

Mauro.
Re: Problems updating from Mylyn 2.1 to 2.2 using Update Manager [message #586934 is a reply to message #40360] Sat, 12 January 2008 00:19 Go to previous message
Mik Kersten is currently offline Mik Kersten
Messages: 287
Registered: July 2009
Senior Member
Great to see that you got to the bottom of this Mauro. As you know this
is related to the DTP/Europa install bug:

194959: Pieces missing from Eclipse IDE for Java EE Developers distribution
https://bugs.eclipse.org/bugs/show_bug.cgi?id=194959

Since quite a few Mylyn users hit it we have instructions about it in
our FAQ:

http://wiki.eclipse.org/index.php/Mylyn_FAQ#Installation_Tro ubleshooting

If they're lacking any information that would have helped you, it would
be great if you could expand on the corresponding section.

Mik


Mauro Molinari wrote:
> Just a follow up if anybody is interested because of similar problems...
>
> I eventually fixed the problem by:
> 1) manually installing the whole DTP (there must have been some errors
> in Eclipse for JEE Packaging... there's a similar bug about it in Bugzilla)
> 2) disabling and then removing RCP Patch 1 for Eclipse 3.3.1
>
> Then, I could use update manager again to download and install Mylyn 2.2
> correctly.
>
> Moreover, today by doing a "search for updates of currently installed
> features" I could actually find and install RCP Patches 1 and 2 for
> Eclipse 3.3.1.1, so there may have been works in progress during last
> days...
> The only side note is that, going to "Manage Configuration", if I show
> properties for Eclipse RCP Patch 1 for 3.3.1.1 I see:
>
> The feature may not be configured properly.
> Plug-in: "com.ibm.icu36.data.update" version: "3.6.1.v20071204_2007j"
> referenced by this feature is not included at runtime. Runtime includes
> plug-in version "3.6.1.v20080102_2007k" supplied by feature "Eclipse RCP
> Patch 2 for 3.3.1.1" version "3.3.1.1_v20080102_3311".
>
> Anyway, it seems a warning rather than a not-working error.
>
> Mauro.
Previous Topic:Configuration Caching missing for Bugzilla 2.2.0
Next Topic:Task Synchronization
Goto Forum:
  


Current Time: Fri Oct 24 14:48:48 GMT 2014

Powered by FUDForum. Page generated in 0.02017 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software