Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » AJDT » AJDT version 1.1.11 works with AspectJ version 1.2 or 1.1.1 ?
AJDT version 1.1.11 works with AspectJ version 1.2 or 1.1.1 ? [message #39743] Tue, 03 August 2004 13:44 Go to next message
Eclipse User
Originally posted by: alessandrofm.softplan.com.br

Hi,

I
Re: AJDT version 1.1.11 works with AspectJ version 1.2 or 1.1.1 ? [message #39774 is a reply to message #39743] Tue, 03 August 2004 14:11 Go to previous messageGo to next message
Eclipse User
Originally posted by: mchapman.uk.ibm.com

On Tue, 03 Aug 2004 10:44:33 -0300, Alessandro Fragnani de Morais wrote:
> With wich version AJDT 1.1.1 works?
> Must I install it manually and configure it to works with AspectJ 1.2?

If you only want to use AspectJ inside Eclipse, then you only need to
install AJDT. Each version of AJDT includes the latest version of AspectJ
at the time of release. Despite its name the version number of the plugin
you mention refers to AJDT not to AspectJ - bit confusing I admit. I
suggest not looking too closely at the individual plugins that make up
AJDT :)

So with AJDT 1.1.11 you have the latest version of everything. I hope that
makes things a little clearer.

Matt.
Re: AJDT version 1.1.11 works with AspectJ version 1.2 or 1.1.1 ? [message #39805 is a reply to message #39774] Tue, 03 August 2004 14:34 Go to previous message
Eclipse User
Originally posted by: alessandrofm.softplan.com.br

Hi Matt,

Yes.. your answer makes things clearer.... but the plugins folder.. oh my
:-)...

So I will uninstall AspectJ 1.2 (that was installed before the plugin)..

Thanks a lot

Alessandro

--
"Matt Chapman" <mchapman@uk.ibm.com> escreveu na mensagem
news:pan.2004.08.03.14.11.43.559099@uk.ibm.com...
> On Tue, 03 Aug 2004 10:44:33 -0300, Alessandro Fragnani de Morais wrote:
> > With wich version AJDT 1.1.1 works?
> > Must I install it manually and configure it to works with AspectJ 1.2?
>
> If you only want to use AspectJ inside Eclipse, then you only need to
> install AJDT. Each version of AJDT includes the latest version of AspectJ
> at the time of release. Despite its name the version number of the plugin
> you mention refers to AJDT not to AspectJ - bit confusing I admit. I
> suggest not looking too closely at the individual plugins that make up
> AJDT :)
>
> So with AJDT 1.1.11 you have the latest version of everything. I hope that
> makes things a little clearer.
>
> Matt.
>
>
Re: AJDT version 1.1.11 works with AspectJ version 1.2 or 1.1.1 ? [message #582530 is a reply to message #39743] Tue, 03 August 2004 14:11 Go to previous message
Matt Chapman is currently offline Matt Chapman
Messages: 429
Registered: July 2009
Senior Member
On Tue, 03 Aug 2004 10:44:33 -0300, Alessandro Fragnani de Morais wrote:
> With wich version AJDT 1.1.1 works?
> Must I install it manually and configure it to works with AspectJ 1.2?

If you only want to use AspectJ inside Eclipse, then you only need to
install AJDT. Each version of AJDT includes the latest version of AspectJ
at the time of release. Despite its name the version number of the plugin
you mention refers to AJDT not to AspectJ - bit confusing I admit. I
suggest not looking too closely at the individual plugins that make up
AJDT :)

So with AJDT 1.1.11 you have the latest version of everything. I hope that
makes things a little clearer.

Matt.
Re: AJDT version 1.1.11 works with AspectJ version 1.2 or 1.1.1 ? [message #582548 is a reply to message #39774] Tue, 03 August 2004 14:34 Go to previous message
Eclipse User
Originally posted by: alessandrofm.softplan.com.br

Hi Matt,

Yes.. your answer makes things clearer.... but the plugins folder.. oh my
:-)...

So I will uninstall AspectJ 1.2 (that was installed before the plugin)..

Thanks a lot

Alessandro

--
"Matt Chapman" <mchapman@uk.ibm.com> escreveu na mensagem
news:pan.2004.08.03.14.11.43.559099@uk.ibm.com...
> On Tue, 03 Aug 2004 10:44:33 -0300, Alessandro Fragnani de Morais wrote:
> > With wich version AJDT 1.1.1 works?
> > Must I install it manually and configure it to works with AspectJ 1.2?
>
> If you only want to use AspectJ inside Eclipse, then you only need to
> install AJDT. Each version of AJDT includes the latest version of AspectJ
> at the time of release. Despite its name the version number of the plugin
> you mention refers to AJDT not to AspectJ - bit confusing I admit. I
> suggest not looking too closely at the individual plugins that make up
> AJDT :)
>
> So with AJDT 1.1.11 you have the latest version of everything. I hope that
> makes things a little clearer.
>
> Matt.
>
>
Previous Topic:AJDT version 1.1.11 works with AspectJ version 1.2 or 1.1.1 ?
Next Topic:Duplicate Eclipse classes in aspectjtools.jar ?!
Goto Forum:
  


Current Time: Tue Sep 30 19:53:34 GMT 2014

Powered by FUDForum. Page generated in 0.01701 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software