Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » SWTBot » Upgraded from build 204 to 348 and now I cannot run any SWTBot Tests
Upgraded from build 204 to 348 and now I cannot run any SWTBot Tests [message #39077] Tue, 16 June 2009 13:23 Go to next message
Jeremy  is currently offline Jeremy
Messages: 10
Registered: July 2009
Junior Member
As the title states I am unable to run any of my SWTBot tests since
upgrading from SWTBot 204 to 348. I cannot get updates often as my
company restricts web access. This is also being written on a different
machine which has internet access (don't think they want us playing while
at work). Anyways when I attempt to run the SWTBot test it errors out
right away with the following.

An internal error occurred during: "Launch SWTBot".
org/eclipse/pde/internal/core/util/CoreUtility

Also getting a NoClassDefFoundError is the above class (CoreUtility).

I am a tester so if this is something that is easy to figure out I am
sorry.
Re: Upgraded from build 204 to 348 and now I cannot run any SWTBot Tests [message #39115 is a reply to message #39077] Tue, 16 June 2009 13:40 Go to previous messageGo to next message
Ketan Padegaonkar is currently offline Ketan Padegaonkar
Messages: 873
Registered: July 2009
Senior Member
What version of eclipse are you on ? Did you download swtbot from the
correct update site ? There's an update site for 3.4(ganymede) and
another for 3.5(galileo).

Also you may find this bug relevant:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=274083

If all else fails, file a bug with the version numbers of eclipse,
swtbot and the platform you are working on.

--
Ketan
http://studios.thoughtworks.com/twist | http://twitter.com/ketanpkr

On 16/6/09 22:53, Jeremy wrote:
> As the title states I am unable to run any of my SWTBot tests since
> upgrading from SWTBot 204 to 348. I cannot get updates often as my
> company restricts web access. This is also being written on a different
> machine which has internet access (don't think they want us playing
> while at work). Anyways when I attempt to run the SWTBot test it errors
> out right away with the following.
>
> An internal error occurred during: "Launch SWTBot".
> org/eclipse/pde/internal/core/util/CoreUtility
>
> Also getting a NoClassDefFoundError is the above class (CoreUtility).
>
> I am a tester so if this is something that is easy to figure out I am
> sorry.
>
Re: Upgraded from build 204 to 348 and now I cannot run any SWTBot Tests [message #39176 is a reply to message #39115] Tue, 16 June 2009 15:47 Go to previous messageGo to next message
Paul Yeung is currently offline Paul Yeung
Messages: 3
Registered: July 2009
Junior Member
I'm having the same problem. I'm using Eclipse 3.4.1 and SWTBoT 2.0.348.
It works well until I upgraded to latest version.
Re: Upgraded from build 204 to 348 and now I cannot run any SWTBot Tests [message #39330 is a reply to message #39115] Wed, 17 June 2009 07:35 Go to previous messageGo to next message
Jeremy  is currently offline Jeremy
Messages: 10
Registered: July 2009
Junior Member
I believe we are on Eclipse 3.4 build 2000. I believe the problem is that
we need to update our Eclipse. When I looked for the Core Utility in the
plug-in view (under show view) that plugin did not exist. I am going to
try and see if our SA will allow us to upgrade our eclipse as our
development machines are not connected to the internet.
Re: Upgraded from build 204 to 348 and now I cannot run any SWTBot Tests [message #39791 is a reply to message #39176] Fri, 19 June 2009 18:41 Go to previous messageGo to next message
kprevas+eclipse@gmail.com is currently offline kprevas+eclipse@gmail.com
Messages: 2
Registered: July 2009
Junior Member
Same problem here, Eclipse 3.4.2 and SWTBot 2.0.348.
Re: Upgraded from build 204 to 348 and now I cannot run any SWTBot Tests [message #39821 is a reply to message #39791] Mon, 22 June 2009 05:04 Go to previous messageGo to next message
Eclipse User
Originally posted by: h.grosse-plankermann.iks-gmbh.com

Same for me, Eclipse 3.4.2 and SWTBot 2.0.348 using the Ganymede Update
Site.
Checked E3.5 RC4 using Galileo Update Site (which also serves SWTBot
2.0.348). Worked l
Re: Upgraded from build 204 to 348 and now I cannot run any SWTBot Tests [message #39852 is a reply to message #39821] Mon, 22 June 2009 09:07 Go to previous messageGo to next message
Ketan Padegaonkar is currently offline Ketan Padegaonkar
Messages: 873
Registered: July 2009
Senior Member
There's two versions of SWTBot for two versions of eclipse to compensate
for changes in API in eclipse and junit. You need to be using the
correct update site or things will not work as expected and you'll get
method not found errors.

--
Ketan
http://studios.thoughtworks.com/twist | http://twitter.com/ketanpkr


On 22/6/09 14:34, Holger Grosse-Plankermann wrote:
> Same for me, Eclipse 3.4.2 and SWTBot 2.0.348 using the Ganymede Update
> Site.
> Checked E3.5 RC4 using Galileo Update Site (which also serves SWTBot
> 2.0.348). Worked líke a charme!
> Perhaps the version optimized for 3.5 leaked to the 3.4 Update site?
>
> Regards,
>
> Holger
>
> "Konstantine Prevas"<kprevas@guidewire.com> schrieb im Newsbeitrag
> news:3f2d97d2dbb4e65b6610434c713579de$1@www.eclipse.org...
>> Same problem here, Eclipse 3.4.2 and SWTBot 2.0.348.
>>
>>
>
>
Re: Upgraded from build 204 to 348 and now I cannot run any SWTBot Tests [message #39882 is a reply to message #39852] Mon, 22 June 2009 09:18 Go to previous messageGo to next message
Eclipse User
Originally posted by: h.grosse-plankermann.iks-gmbh.com

I am using the Ganymede Update Site for my Eclipse 3.4.2
( http://download.eclipse.org/technology/swtbot/ganymede/dev-b uild/update-site)
and I am recieving the exceptions mentioned earlier in this thread:

An internal error occurred during: "Launch SWTBot".
org/eclipse/pde/internal/core/util/CoreUtility

The distribution I am using:
http://www.eclipse.org/downloads/download.php?file=/technolo gy/epp/downloads/release/ganymede/SR2/eclipse-rcp-ganymede-S R2-win32.zip

Any idea what could be wrong here?

Regards

Holger
"Ketan Padegaonkar" <ketanpadegaonkar@gmail.com> schrieb im Newsbeitrag
news:h1nvu3$5c0$1@build.eclipse.org...
> There's two versions of SWTBot for two versions of eclipse to compensate
> for changes in API in eclipse and junit. You need to be using the correct
> update site or things will not work as expected and you'll get method not
> found errors.
>
> --
> Ketan
> http://studios.thoughtworks.com/twist | http://twitter.com/ketanpkr
>
>
> On 22/6/09 14:34, Holger Grosse-Plankermann wrote:
>> Same for me, Eclipse 3.4.2 and SWTBot 2.0.348 using the Ganymede Update
>> Site.
>> Checked E3.5 RC4 using Galileo Update Site (which also serves SWTBot
>> 2.0.348). Worked l
Re: Upgraded from build 204 to 348 and now I cannot run any SWTBot Tests [message #39914 is a reply to message #39882] Mon, 22 June 2009 11:04 Go to previous messageGo to next message
Ketan Padegaonkar is currently offline Ketan Padegaonkar
Messages: 873
Registered: July 2009
Senior Member
Could you open a bug and attach the complete stack trace ?

--
Ketan
http://studios.thoughtworks.com/twist | http://twitter.com/ketanpkr


On 22/6/09 18:48, Holger Grosse-Plankermann wrote:
> I am using the Ganymede Update Site for my Eclipse 3.4.2
> ( http://download.eclipse.org/technology/swtbot/ganymede/dev-b uild/update-site)
> and I am recieving the exceptions mentioned earlier in this thread:
>
> An internal error occurred during: "Launch SWTBot".
> org/eclipse/pde/internal/core/util/CoreUtility
>
> The distribution I am using:
> http://www.eclipse.org/downloads/download.php?file=/technolo gy/epp/downloads/release/ganymede/SR2/eclipse-rcp-ganymede-S R2-win32.zip
>
> Any idea what could be wrong here?
>
> Regards
>
> Holger
> "Ketan Padegaonkar"<ketanpadegaonkar@gmail.com> schrieb im Newsbeitrag
> news:h1nvu3$5c0$1@build.eclipse.org...
>> There's two versions of SWTBot for two versions of eclipse to compensate
>> for changes in API in eclipse and junit. You need to be using the correct
>> update site or things will not work as expected and you'll get method not
>> found errors.
>>
>> --
>> Ketan
>> http://studios.thoughtworks.com/twist | http://twitter.com/ketanpkr
>>
>>
>> On 22/6/09 14:34, Holger Grosse-Plankermann wrote:
>>> Same for me, Eclipse 3.4.2 and SWTBot 2.0.348 using the Ganymede Update
>>> Site.
>>> Checked E3.5 RC4 using Galileo Update Site (which also serves SWTBot
>>> 2.0.348). Worked líke a charme!
>>> Perhaps the version optimized for 3.5 leaked to the 3.4 Update site?
>>>
>>> Regards,
>>>
>>> Holger
>>>
>>> "Konstantine Prevas"<kprevas@guidewire.com> schrieb im Newsbeitrag
>>> news:3f2d97d2dbb4e65b6610434c713579de$1@www.eclipse.org...
>>>> Same problem here, Eclipse 3.4.2 and SWTBot 2.0.348.
>>>>
>>>>
>>>
>
>
Re: Upgraded from build 204 to 348 and now I cannot run any SWTBot Tests [message #39946 is a reply to message #39882] Mon, 22 June 2009 11:47 Go to previous messageGo to next message
Ketan Padegaonkar is currently offline Ketan Padegaonkar
Messages: 873
Registered: July 2009
Senior Member
On 22/6/09 18:48, Holger Grosse-Plankermann wrote:
> I am using the Ganymede Update Site for my Eclipse 3.4.2
> ( http://download.eclipse.org/technology/swtbot/ganymede/dev-b uild/update-site)
> and I am recieving the exceptions mentioned earlier in this thread:
>
> An internal error occurred during: "Launch SWTBot".
> org/eclipse/pde/internal/core/util/CoreUtility
>
> The distribution I am using:
> http://www.eclipse.org/downloads/download.php?file=/technolo gy/epp/downloads/release/ganymede/SR2/eclipse-rcp-ganymede-S R2-win32.zip
>
> Any idea what could be wrong here?
>
> Regards
>
> Holger
> "Ketan Padegaonkar"<ketanpadegaonkar@gmail.com> schrieb im Newsbeitrag
> news:h1nvu3$5c0$1@build.eclipse.org...
>> There's two versions of SWTBot for two versions of eclipse to compensate
>> for changes in API in eclipse and junit. You need to be using the correct
>> update site or things will not work as expected and you'll get method not
>> found errors.
>>
>> --
>> Ketan
>> http://studios.thoughtworks.com/twist | http://twitter.com/ketanpkr
>>
>>
>> On 22/6/09 14:34, Holger Grosse-Plankermann wrote:
>>> Same for me, Eclipse 3.4.2 and SWTBot 2.0.348 using the Ganymede Update
>>> Site.
>>> Checked E3.5 RC4 using Galileo Update Site (which also serves SWTBot
>>> 2.0.348). Worked líke a charme!
>>> Perhaps the version optimized for 3.5 leaked to the 3.4 Update site?
>>>
>>> Regards,
>>>
>>> Holger
>>>
>>> "Konstantine Prevas"<kprevas@guidewire.com> schrieb im Newsbeitrag
>>> news:3f2d97d2dbb4e65b6610434c713579de$1@www.eclipse.org...
>>>> Same problem here, Eclipse 3.4.2 and SWTBot 2.0.348.
>>>>
>>>>
>>>
>
>
Re: Upgraded from build 204 to 348 and now I cannot run any SWTBot Tests [message #39977 is a reply to message #39882] Mon, 22 June 2009 11:49 Go to previous messageGo to next message
Ketan Padegaonkar is currently offline Ketan Padegaonkar
Messages: 873
Registered: July 2009
Senior Member
I think I've found the fix. This was introduced as part of bug 268881.
I'll push out a build shortly.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=268881

--
Ketan
http://studios.thoughtworks.com/twist | http://twitter.com/ketanpkr


On 22/6/09 18:48, Holger Grosse-Plankermann wrote:
> I am using the Ganymede Update Site for my Eclipse 3.4.2
> ( http://download.eclipse.org/technology/swtbot/ganymede/dev-b uild/update-site)
> and I am recieving the exceptions mentioned earlier in this thread:
>
> An internal error occurred during: "Launch SWTBot".
> org/eclipse/pde/internal/core/util/CoreUtility
>
> The distribution I am using:
> http://www.eclipse.org/downloads/download.php?file=/technolo gy/epp/downloads/release/ganymede/SR2/eclipse-rcp-ganymede-S R2-win32.zip
>
> Any idea what could be wrong here?
>
> Regards
>
> Holger
> "Ketan Padegaonkar"<ketanpadegaonkar@gmail.com> schrieb im Newsbeitrag
> news:h1nvu3$5c0$1@build.eclipse.org...
>> There's two versions of SWTBot for two versions of eclipse to compensate
>> for changes in API in eclipse and junit. You need to be using the correct
>> update site or things will not work as expected and you'll get method not
>> found errors.
>>
>> --
>> Ketan
>> http://studios.thoughtworks.com/twist | http://twitter.com/ketanpkr
>>
>>
>> On 22/6/09 14:34, Holger Grosse-Plankermann wrote:
>>> Same for me, Eclipse 3.4.2 and SWTBot 2.0.348 using the Ganymede Update
>>> Site.
>>> Checked E3.5 RC4 using Galileo Update Site (which also serves SWTBot
>>> 2.0.348). Worked líke a charme!
>>> Perhaps the version optimized for 3.5 leaked to the 3.4 Update site?
>>>
>>> Regards,
>>>
>>> Holger
>>>
>>> "Konstantine Prevas"<kprevas@guidewire.com> schrieb im Newsbeitrag
>>> news:3f2d97d2dbb4e65b6610434c713579de$1@www.eclipse.org...
>>>> Same problem here, Eclipse 3.4.2 and SWTBot 2.0.348.
>>>>
>>>>
>>>
>
>
Re: Upgraded from build 204 to 348 and now I cannot run any SWTBot Tests [message #40005 is a reply to message #39077] Mon, 22 June 2009 12:43 Go to previous messageGo to next message
Ketan Padegaonkar is currently offline Ketan Padegaonkar
Messages: 873
Registered: July 2009
Senior Member
I've fixed this issue and pushed out a new build.

You may notice that the update takes too long, or fails midway -- the
eclipse servers are currently taking a *huge* hammering because of all
the buzz and activity happening for the new upcoming release. Please be
patient and retry again if the download fails, it took me 4 retries to
download the whole thing.

--
Ketan
http://studios.thoughtworks.com/twist | http://twitter.com/ketanpkr


On 16/6/09 22:53, Jeremy wrote:
> As the title states I am unable to run any of my SWTBot tests since
> upgrading from SWTBot 204 to 348. I cannot get updates often as my
> company restricts web access. This is also being written on a different
> machine which has internet access (don't think they want us playing
> while at work). Anyways when I attempt to run the SWTBot test it errors
> out right away with the following.
>
> An internal error occurred during: "Launch SWTBot".
> org/eclipse/pde/internal/core/util/CoreUtility
>
> Also getting a NoClassDefFoundError is the above class (CoreUtility).
>
> I am a tester so if this is something that is easy to figure out I am
> sorry.
>
Re: Upgraded from build 204 to 348 and now I cannot run any SWTBot Tests [message #40036 is a reply to message #39977] Mon, 22 June 2009 14:43 Go to previous messageGo to next message
Jeremy  is currently offline Jeremy
Messages: 10
Registered: July 2009
Junior Member
Was the new build created to correct this issue yet?
Re: Upgraded from build 204 to 348 and now I cannot run any SWTBot Tests [message #40066 is a reply to message #40036] Mon, 22 June 2009 16:05 Go to previous messageGo to next message
Ketan Padegaonkar is currently offline Ketan Padegaonkar
Messages: 873
Registered: July 2009
Senior Member
On 23/6/09 00:13, Jeremy wrote:
> Was the new build created to correct this issue yet?

Yes it has, just pull a new update.

--
Ketan
http://studios.thoughtworks.com/twist | http://twitter.com/ketanpkr
Re: Upgraded from build 204 to 348 and now I cannot run any SWTBot Tests [message #40163 is a reply to message #40066] Tue, 23 June 2009 05:17 Go to previous message
Eclipse User
Originally posted by: h.grosse-plankermann.iks-gmbh.com

Works for me!
Thank you Ketan!

Regards,

Holger

"Ketan Padegaonkar" <ketanpadegaonkar@gmail.com> schrieb im Newsbeitrag
news:h1oodk$rqa$1@build.eclipse.org...
> On 23/6/09 00:13, Jeremy wrote:
>> Was the new build created to correct this issue yet?
>
> Yes it has, just pull a new update.
>
> --
> Ketan
> http://studios.thoughtworks.com/twist | http://twitter.com/ketanpkr
Previous Topic:test RCP application using swt/swing bridge
Next Topic:SWTWorkbenchBot#button works only on button class with style == SWT.PUSH - why?
Goto Forum:
  


Current Time: Wed Aug 27 17:15:35 EDT 2014

Powered by FUDForum. Page generated in 0.03113 seconds