Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Modeling (top-level project) » Help installing EMF
Help installing EMF [message #381250] Wed, 03 October 2007 07:01 Go to next message
No real name is currently offline No real name
Messages: 53
Registered: July 2009
Member
I could use some help installing EMF.

I've installed Eclipse 3.3.1 on Linux and I'm trying to install the EMF
plugin, but I get the following error message:

----------
Requested operation cannot be performed because it would invalidate the
current configuration. See details for more information.

EMF Model Query OCL Integration 1.1.0.v200706071712-10-7w311817182823)
requires plug-in "org.eclipse.emf.ocl (1.1.0)", or compatible.
EMF Validation Framework OCL Integration
(1.1.0.v200706071520-10-7w311817182631) requires plug-in
"org.eclipse.emf.ocl (1.0.0)", or compatible.
-----------

I tried looking for the "org.eclipse.emf.ocl (1.1.0)" plugin and I found
and installed this:

mdt-ocl-runtime-I200709261803.zip

but that didn't make any difference.

Any help is appreciated.

Richard
Re: Help installing EMF [message #381251 is a reply to message #381250] Wed, 03 October 2007 12:40 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 26125
Registered: July 2009
Senior Member
Richard,

Please use the EMF newsgroup for questions about EMF. I've added it to
the "to" list of the reply. I'll ask Christian to look at the specifics
of these numbers. Note that when unzipping plugins, it's often
necessary to run with "-clean" to refresh Eclipse's cached plugin
configuration. It would be good to try that.


Richard Geddes wrote:
> I could use some help installing EMF.
>
> I've installed Eclipse 3.3.1 on Linux and I'm trying to install the EMF
> plugin, but I get the following error message:
>
> ----------
> Requested operation cannot be performed because it would invalidate the
> current configuration. See details for more information.
>
> EMF Model Query OCL Integration 1.1.0.v200706071712-10-7w311817182823)
> requires plug-in "org.eclipse.emf.ocl (1.1.0)", or compatible.
> EMF Validation Framework OCL Integration
> (1.1.0.v200706071520-10-7w311817182631) requires plug-in
> "org.eclipse.emf.ocl (1.0.0)", or compatible.
> -----------
>
> I tried looking for the "org.eclipse.emf.ocl (1.1.0)" plugin and I found
> and installed this:
>
> mdt-ocl-runtime-I200709261803.zip
>
> but that didn't make any difference.
>
> Any help is appreciated.
>
> Richard
>
Re: Help installing EMF [message #381252 is a reply to message #381251] Wed, 03 October 2007 14:02 Go to previous messageGo to next message
No real name is currently offline No real name
Messages: 53
Registered: July 2009
Member
Ed,

Thank you for pointing me in the right direction... I'm new to the
Eclipse system. Also, I recall that when I unzipped

mdt-ocl-runtime-I200709261803.zip

into my plugins directory, I was prompted that there was already an
existing file with the name that was being unzipped... to which I
answered 'no' initially... I took the '-clean' in your suggestion to
mean to answer 'yes to all'... (unzip has no -clean option in linux).
Anyway, that got rid of the error message... :).

-------
However, I new error message has popped up

The current configuration contains errors and this operation can have
unpredictable results.
Object Constraint Language (OCL) 2.0
(1.2.0.v200709262202-3309oA55P5R_F_DAU) requires plug-in
"org.eclipse.emf.ecore (2.4.0)", or equivalent.
OCL 2.0 Binding for UML (1.2.0.v200709262202-11-7w31181_322622)
requires plug-in "org.eclipse.emf.ecore (2.3.0)", or compatible.
-------

and I will take it up with the newsgroup you suggested (eclipse.tools.emf).

Thank you once again.
Richard

Ed Merks wrote:
> Richard,
>
> Please use the EMF newsgroup for questions about EMF. I've added it to
> the "to" list of the reply. I'll ask Christian to look at the specifics
> of these numbers. Note that when unzipping plugins, it's often
> necessary to run with "-clean" to refresh Eclipse's cached plugin
> configuration. It would be good to try that.
>
>
> Richard Geddes wrote:
>> I could use some help installing EMF.
>>
>> I've installed Eclipse 3.3.1 on Linux and I'm trying to install the EMF
>> plugin, but I get the following error message:
>>
>> ----------
>> Requested operation cannot be performed because it would invalidate the
>> current configuration. See details for more information.
>>
>> EMF Model Query OCL Integration 1.1.0.v200706071712-10-7w311817182823)
>> requires plug-in "org.eclipse.emf.ocl (1.1.0)", or compatible.
>> EMF Validation Framework OCL Integration
>> (1.1.0.v200706071520-10-7w311817182631) requires plug-in
>> "org.eclipse.emf.ocl (1.0.0)", or compatible.
>> -----------
>>
>> I tried looking for the "org.eclipse.emf.ocl (1.1.0)" plugin and I found
>> and installed this:
>>
>> mdt-ocl-runtime-I200709261803.zip
>>
>> but that didn't make any difference.
>>
>> Any help is appreciated.
>>
>> Richard
>>
Re: Help installing EMF [message #381253 is a reply to message #381252] Wed, 03 October 2007 14:15 Go to previous message
Ed Merks is currently offline Ed Merks
Messages: 26125
Registered: July 2009
Senior Member
Richard,

Be very careful to look at all dependencies of what you download to make
sure they are all for Eclipse 3.3.x. It sounds like you've unzipped OCL
1.2 which is for Eclipse 3.4 and EMF 2.4. You'll probably need to clean
up your installation and start again. Be sure to check the "Build
Dependencies" section of each download zip. I suppose you might as well
get all the stuff for 3.3.1 which was released last week. The -clean
argument is for when you run Eclipse itself, not an argument for unzip...


Richard Geddes wrote:
> Ed,
>
> Thank you for pointing me in the right direction... I'm new to the
> Eclipse system. Also, I recall that when I unzipped
>
> mdt-ocl-runtime-I200709261803.zip
>
> into my plugins directory, I was prompted that there was already an
> existing file with the name that was being unzipped... to which I
> answered 'no' initially... I took the '-clean' in your suggestion to
> mean to answer 'yes to all'... (unzip has no -clean option in linux).
> Anyway, that got rid of the error message... :).
>
> -------
> However, I new error message has popped up
>
> The current configuration contains errors and this operation can have
> unpredictable results.
> Object Constraint Language (OCL) 2.0
> (1.2.0.v200709262202-3309oA55P5R_F_DAU) requires plug-in
> "org.eclipse.emf.ecore (2.4.0)", or equivalent.
> OCL 2.0 Binding for UML (1.2.0.v200709262202-11-7w31181_322622)
> requires plug-in "org.eclipse.emf.ecore (2.3.0)", or compatible.
> -------
>
> and I will take it up with the newsgroup you suggested (eclipse.tools.emf).
>
> Thank you once again.
> Richard
>
> Ed Merks wrote:
>
>> Richard,
>>
>> Please use the EMF newsgroup for questions about EMF. I've added it to
>> the "to" list of the reply. I'll ask Christian to look at the specifics
>> of these numbers. Note that when unzipping plugins, it's often
>> necessary to run with "-clean" to refresh Eclipse's cached plugin
>> configuration. It would be good to try that.
>>
>>
>> Richard Geddes wrote:
>>
>>> I could use some help installing EMF.
>>>
>>> I've installed Eclipse 3.3.1 on Linux and I'm trying to install the EMF
>>> plugin, but I get the following error message:
>>>
>>> ----------
>>> Requested operation cannot be performed because it would invalidate the
>>> current configuration. See details for more information.
>>>
>>> EMF Model Query OCL Integration 1.1.0.v200706071712-10-7w311817182823)
>>> requires plug-in "org.eclipse.emf.ocl (1.1.0)", or compatible.
>>> EMF Validation Framework OCL Integration
>>> (1.1.0.v200706071520-10-7w311817182631) requires plug-in
>>> "org.eclipse.emf.ocl (1.0.0)", or compatible.
>>> -----------
>>>
>>> I tried looking for the "org.eclipse.emf.ocl (1.1.0)" plugin and I found
>>> and installed this:
>>>
>>> mdt-ocl-runtime-I200709261803.zip
>>>
>>> but that didn't make any difference.
>>>
>>> Any help is appreciated.
>>>
>>> Richard
>>>
>>>
Re: Help installing EMF [message #600097 is a reply to message #381250] Wed, 03 October 2007 12:40 Go to previous message
Ed Merks is currently offline Ed Merks
Messages: 26125
Registered: July 2009
Senior Member
Richard,

Please use the EMF newsgroup for questions about EMF. I've added it to
the "to" list of the reply. I'll ask Christian to look at the specifics
of these numbers. Note that when unzipping plugins, it's often
necessary to run with "-clean" to refresh Eclipse's cached plugin
configuration. It would be good to try that.


Richard Geddes wrote:
> I could use some help installing EMF.
>
> I've installed Eclipse 3.3.1 on Linux and I'm trying to install the EMF
> plugin, but I get the following error message:
>
> ----------
> Requested operation cannot be performed because it would invalidate the
> current configuration. See details for more information.
>
> EMF Model Query OCL Integration 1.1.0.v200706071712-10-7w311817182823)
> requires plug-in "org.eclipse.emf.ocl (1.1.0)", or compatible.
> EMF Validation Framework OCL Integration
> (1.1.0.v200706071520-10-7w311817182631) requires plug-in
> "org.eclipse.emf.ocl (1.0.0)", or compatible.
> -----------
>
> I tried looking for the "org.eclipse.emf.ocl (1.1.0)" plugin and I found
> and installed this:
>
> mdt-ocl-runtime-I200709261803.zip
>
> but that didn't make any difference.
>
> Any help is appreciated.
>
> Richard
>
Re: Help installing EMF [message #600105 is a reply to message #381251] Wed, 03 October 2007 14:02 Go to previous message
No real name is currently offline No real name
Messages: 53
Registered: July 2009
Member
Ed,

Thank you for pointing me in the right direction... I'm new to the
Eclipse system. Also, I recall that when I unzipped

mdt-ocl-runtime-I200709261803.zip

into my plugins directory, I was prompted that there was already an
existing file with the name that was being unzipped... to which I
answered 'no' initially... I took the '-clean' in your suggestion to
mean to answer 'yes to all'... (unzip has no -clean option in linux).
Anyway, that got rid of the error message... :).

-------
However, I new error message has popped up

The current configuration contains errors and this operation can have
unpredictable results.
Object Constraint Language (OCL) 2.0
(1.2.0.v200709262202-3309oA55P5R_F_DAU) requires plug-in
"org.eclipse.emf.ecore (2.4.0)", or equivalent.
OCL 2.0 Binding for UML (1.2.0.v200709262202-11-7w31181_322622)
requires plug-in "org.eclipse.emf.ecore (2.3.0)", or compatible.
-------

and I will take it up with the newsgroup you suggested (eclipse.tools.emf).

Thank you once again.
Richard

Ed Merks wrote:
> Richard,
>
> Please use the EMF newsgroup for questions about EMF. I've added it to
> the "to" list of the reply. I'll ask Christian to look at the specifics
> of these numbers. Note that when unzipping plugins, it's often
> necessary to run with "-clean" to refresh Eclipse's cached plugin
> configuration. It would be good to try that.
>
>
> Richard Geddes wrote:
>> I could use some help installing EMF.
>>
>> I've installed Eclipse 3.3.1 on Linux and I'm trying to install the EMF
>> plugin, but I get the following error message:
>>
>> ----------
>> Requested operation cannot be performed because it would invalidate the
>> current configuration. See details for more information.
>>
>> EMF Model Query OCL Integration 1.1.0.v200706071712-10-7w311817182823)
>> requires plug-in "org.eclipse.emf.ocl (1.1.0)", or compatible.
>> EMF Validation Framework OCL Integration
>> (1.1.0.v200706071520-10-7w311817182631) requires plug-in
>> "org.eclipse.emf.ocl (1.0.0)", or compatible.
>> -----------
>>
>> I tried looking for the "org.eclipse.emf.ocl (1.1.0)" plugin and I found
>> and installed this:
>>
>> mdt-ocl-runtime-I200709261803.zip
>>
>> but that didn't make any difference.
>>
>> Any help is appreciated.
>>
>> Richard
>>
Re: Help installing EMF [message #600117 is a reply to message #381252] Wed, 03 October 2007 14:15 Go to previous message
Ed Merks is currently offline Ed Merks
Messages: 26125
Registered: July 2009
Senior Member
Richard,

Be very careful to look at all dependencies of what you download to make
sure they are all for Eclipse 3.3.x. It sounds like you've unzipped OCL
1.2 which is for Eclipse 3.4 and EMF 2.4. You'll probably need to clean
up your installation and start again. Be sure to check the "Build
Dependencies" section of each download zip. I suppose you might as well
get all the stuff for 3.3.1 which was released last week. The -clean
argument is for when you run Eclipse itself, not an argument for unzip...


Richard Geddes wrote:
> Ed,
>
> Thank you for pointing me in the right direction... I'm new to the
> Eclipse system. Also, I recall that when I unzipped
>
> mdt-ocl-runtime-I200709261803.zip
>
> into my plugins directory, I was prompted that there was already an
> existing file with the name that was being unzipped... to which I
> answered 'no' initially... I took the '-clean' in your suggestion to
> mean to answer 'yes to all'... (unzip has no -clean option in linux).
> Anyway, that got rid of the error message... :).
>
> -------
> However, I new error message has popped up
>
> The current configuration contains errors and this operation can have
> unpredictable results.
> Object Constraint Language (OCL) 2.0
> (1.2.0.v200709262202-3309oA55P5R_F_DAU) requires plug-in
> "org.eclipse.emf.ecore (2.4.0)", or equivalent.
> OCL 2.0 Binding for UML (1.2.0.v200709262202-11-7w31181_322622)
> requires plug-in "org.eclipse.emf.ecore (2.3.0)", or compatible.
> -------
>
> and I will take it up with the newsgroup you suggested (eclipse.tools.emf).
>
> Thank you once again.
> Richard
>
> Ed Merks wrote:
>
>> Richard,
>>
>> Please use the EMF newsgroup for questions about EMF. I've added it to
>> the "to" list of the reply. I'll ask Christian to look at the specifics
>> of these numbers. Note that when unzipping plugins, it's often
>> necessary to run with "-clean" to refresh Eclipse's cached plugin
>> configuration. It would be good to try that.
>>
>>
>> Richard Geddes wrote:
>>
>>> I could use some help installing EMF.
>>>
>>> I've installed Eclipse 3.3.1 on Linux and I'm trying to install the EMF
>>> plugin, but I get the following error message:
>>>
>>> ----------
>>> Requested operation cannot be performed because it would invalidate the
>>> current configuration. See details for more information.
>>>
>>> EMF Model Query OCL Integration 1.1.0.v200706071712-10-7w311817182823)
>>> requires plug-in "org.eclipse.emf.ocl (1.1.0)", or compatible.
>>> EMF Validation Framework OCL Integration
>>> (1.1.0.v200706071520-10-7w311817182631) requires plug-in
>>> "org.eclipse.emf.ocl (1.0.0)", or compatible.
>>> -----------
>>>
>>> I tried looking for the "org.eclipse.emf.ocl (1.1.0)" plugin and I found
>>> and installed this:
>>>
>>> mdt-ocl-runtime-I200709261803.zip
>>>
>>> but that didn't make any difference.
>>>
>>> Any help is appreciated.
>>>
>>> Richard
>>>
>>>
Previous Topic:Help installing EMF
Next Topic:Eclipse University Training...is it usefull?
Goto Forum:
  


Current Time: Mon Oct 20 09:59:31 GMT 2014

Powered by FUDForum. Page generated in 0.02447 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software