Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMT (Generative Modeling Technologies) » [TCS] Language Project example and dependent project's version
[TCS] Language Project example and dependent project's version [message #380455] Thu, 22 November 2007 09:08 Go to next message
Gustavo Cabral is currently offline Gustavo Cabral
Messages: 20
Registered: July 2009
Junior Member
Hi everyone,

I have tried the TCS/Language Project example
(http://wiki.eclipse.org/TCS/Language_Project) with metamodel and
syntax from the LOTOS example
(http://www.eclipse.org/m2m/atl/usecases/FIACRE2LOTOS/) but I just cant
make
it work!

I am using:
- the latest classic eclipse,
- updating with the EMF plugin,
- downloading the latest ATL plugin (I also install a build I
made from the CVS)

....but no success!

I think it is some major problem with the Eclipse X ATL X EMF versions. I
re-compiled and installed the latest version of ATL from the CVS
repository
but it didnt work. The classes:

org.eclipse.m2m.atl.engine.AtlEMFModelHandler;
org.eclipse.m2m.atl.engine.AtlModelHandler;
import org.eclipse.gmt.tcs.injector.TCSInjector;
org.eclipse.m2m.atl.engine.EnginePlugin;
org.eclipse.m2m.atl.engine.MarkerMaker;

cannot be found when I try to compile the "TCS Builder plugin" and the
"TCS Wizard plugin".

Through the ant approach, I get the following error:

-----------
.....

BUILD FAILED
/home/gustavo/Desktop/eclipseClassicX/workspace/AMMAScripts/ build.dsl.xml:55:
The following error occurred while executing this line:
/home/gustavo/Desktop/eclipseClassicX/workspace/AMMAScripts/ build.dsl.xml:78:
The following error occurred while executing this line:
/home/gustavo/Desktop/eclipseClassicX/workspace/AMMAScripts/ build.metamodel.xml:68:
Problem: failed to create task or type am3.loadModel
Cause: The name is undefined.
Action: Check the spelling.
Action: Check that any custom tasks/types have been declared.
Action: Check that any <presetdef>/<macrodef> declarations have taken
place.

------------

Can any one help me? What versions should I use?

Thank you for your time,
Gustavo Cabral
Re: [TCS] Language Project example and dependent project's version [message #380462 is a reply to message #380455] Thu, 22 November 2007 22:49 Go to previous messageGo to next message
Frédéric Jouault is currently offline Frédéric Jouault
Messages: 572
Registered: July 2009
Senior Member
Hello,

To use the plugin builder, you should use the latest version of ATL and
AM3 (i.e., CVS HEAD).

To use the ant builder, you need the AM3 ant plugin, and to set the
script to execute in the same JRE as Eclipse (otherwise, the tasks will
not be found). See bottom of http://wiki.eclipse.org/AM3_Ant_Tasks.

As for the example, note that you can also directly use the FIACRE and
LOTOS projects from the TCS Zoo, which are configured to use the ant
builder. See http://wiki.eclipse.org/TCS/Zoo.


Regards,

Frédéric Jouault


Gustavo Cabral wrote:
> Hi everyone,
>
> I have tried the TCS/Language Project example
> (http://wiki.eclipse.org/TCS/Language_Project) with metamodel and
> syntax from the LOTOS example
> (http://www.eclipse.org/m2m/atl/usecases/FIACRE2LOTOS/) but I just cant
> make
> it work!
>
> I am using:
> - the latest classic eclipse, - updating with the EMF plugin,
> - downloading the latest ATL plugin (I also install a build I
> made from the CVS)
>
> ....but no success!
>
> I think it is some major problem with the Eclipse X ATL X EMF versions.
> I re-compiled and installed the latest version of ATL from the CVS
> repository but it didnt work. The classes:
>
> org.eclipse.m2m.atl.engine.AtlEMFModelHandler;
> org.eclipse.m2m.atl.engine.AtlModelHandler;
> import org.eclipse.gmt.tcs.injector.TCSInjector;
> org.eclipse.m2m.atl.engine.EnginePlugin;
> org.eclipse.m2m.atl.engine.MarkerMaker;
>
> cannot be found when I try to compile the "TCS Builder plugin" and the
> "TCS Wizard plugin".
> Through the ant approach, I get the following error:
>
> -----------
> .....
>
> BUILD FAILED
> /home/gustavo/Desktop/eclipseClassicX/workspace/AMMAScripts/ build.dsl.xml:55:
> The following error occurred while executing this line:
> /home/gustavo/Desktop/eclipseClassicX/workspace/AMMAScripts/ build.dsl.xml:78:
> The following error occurred while executing this line:
> /home/gustavo/Desktop/eclipseClassicX/workspace/AMMAScripts/ build.metamodel.xml:68:
> Problem: failed to create task or type am3.loadModel
> Cause: The name is undefined.
> Action: Check the spelling.
> Action: Check that any custom tasks/types have been declared.
> Action: Check that any <presetdef>/<macrodef> declarations have taken
> place.
>
> ------------
>
> Can any one help me? What versions should I use?
>
> Thank you for your time,
> Gustavo Cabral
>
>
>
Re: [TCS] Language Project example and dependent project's version [message #380474 is a reply to message #380462] Mon, 26 November 2007 07:33 Go to previous messageGo to next message
Gustavo Cabral is currently offline Gustavo Cabral
Messages: 20
Registered: July 2009
Junior Member
Thank you Frédéric,

Everything is working now! :) What I did was:

1) I downloaded a fresh class Eclipse build
(eclipse-SDK-3.3.1.1-linux-gtk.tar.gz)

2) Updated Eclipse (Help -> Software Update) with EMF (with the 2 core
plugins only)

3) Checked out, deployed, and installed the following plug-ins:

org.eclipse.am3.core
org.eclipse.am3.tools.tge
org.eclipse.am3.ui
org.eclipse.gmt.am3
org.eclipse.gmt.am3.core
org.eclipse.gmt.am3.modelhandler.emf
org.eclipse.gmt.am3.modelhandler.mdr
org.eclipse.gmt.am3.repository.lightweight
org.eclipse.gmt.am3.tools.ant
org.eclipse.gmt.tcs.builder
org.eclipse.m2m.atl.adt.builder
org.eclipse.m2m.atl.adt.debug
org.eclipse.m2m.atl.adt.editor
org.eclipse.m2m.atl.adt.perspective
org.eclipse.m2m.atl.adt.wizard
org.eclipse.m2m.atl.compilers.atl2006
org.eclipse.m2m.atl.drivers.emf4atl
org.eclipse.m2m.atl.drivers.mdr4atl
org.eclipse.m2m.atl.drivers.mdr4atl-feature
org.eclipse.m2m.atl.drivers.uml24atl
org.eclipse.m2m.atl.engine
org.eclipse.m2m.atl.engine.emfvm
org.eclipse.m2m.atl.engine.vm
org.eclipse.m2m.atl.ocl.core
org.eclipse.m2m.atl.service.core

* It is necessary to downloaded and set some necessary jars:

http://www.sciences.univ-nantes.fr/lina/atl/www/AMMAScripts/ libs/
http://mdr.netbeans.org/download/

4) Followed the Language_Project Ant-based approach.

http://wiki.eclipse.org/TCS/Language_Project#Creating_a_Lang uage_Project_For_Ant-based_Builder

Success! Thank you again.

Some questions:

* I think I am missing some plugin because I don't have the
"Inject to Ecore" options when I right click KM3 metamodels
(even when I am at the ATL perspective). Which one I should
have installed and forgot it?

* When I change the grammar from my DSL, does TGE acknowledge the new
megamodel (DSL grammar) version?

* Is there some documentation about some "new" keywords used
at the TCS file? "nonPrimary", for instance, what does it mean? :(

Thank you for the help again.

Thank you,
Gustavo

ps.: I am using the TCS framework to implement a "Formal Specification
Generation from Requirements" transformation strategy. After that, I am
using the system's model to accomplish testing (Model-based Testing). ;)
Re: [TCS] Language Project example and dependent project's version [message #380480 is a reply to message #380474] Mon, 26 November 2007 22:05 Go to previous messageGo to next message
Frédéric Jouault is currently offline Frédéric Jouault
Messages: 572
Registered: July 2009
Senior Member
Hi Gustavo,

Thank you for your description of the installation process. This will
hopefully help other people. Please, do not hesitate to contribute
things like this to the wiki (e.g., the
http://wiki.eclipse.org/TCS/Language_Project page does not give much
details about installation of the plugin builder).


> * I think I am missing some plugin because I don't have the "Inject to
> Ecore" options when I right click KM3 metamodels
> (even when I am at the ATL perspective). Which one I should
> have installed and forgot it?

These actions are available in the "AM3 Resource Navigator" view (you
can open it by going to menu "Window->Show View->Other...->ATL")


> * When I change the grammar from my DSL, does TGE acknowledge the new
> megamodel (DSL grammar) version?

The new version is used by TGE when it reparses the file (when you save
the file, or close then reopen the editor). However, I would advise
closing and reopening, because I noticed some problems in the outline
otherwise.


> * Is there some documentation about some "new" keywords used
> at the TCS file? "nonPrimary", for instance, what does it mean? :(

nonPrimary means that the expression is not a "primary" expression (like
LetExp in OCL). Technically, you should use nonPrimary on any
expression (i.e., with "operatored" superclass) that is not represented
using an operatorTemplate (therefore, not left-recursive), but that is
right-recursive.

The documentation is not complete yet, but we are working on improving it.


Regards,

Frédéric Jouault
Re: [TCS] Language Project example and dependent project's version [message #380481 is a reply to message #380480] Tue, 27 November 2007 02:47 Go to previous messageGo to next message
Gustavo Cabral is currently offline Gustavo Cabral
Messages: 20
Registered: July 2009
Junior Member
Hi,

I used the ATL view too, but when I right click a KM3 file, for instance,
I get no inject options.

No problem, the ANT DSL script creates the ecore file for me ;)

Gustavo
Re: [TCS] Language Project example and dependent project's version [message #380490 is a reply to message #380481] Thu, 29 November 2007 11:39 Go to previous message
Frédéric Jouault is currently offline Frédéric Jouault
Messages: 572
Registered: July 2009
Senior Member
Hello,

> I used the ATL view too, but when I right click a KM3 file, for instance,
> I get no inject options.

Which ATL view? The ATL perspective?

The view you need to be in is called "AM3 Resource Navigator".

> No problem, the ANT DSL script creates the ecore file for me ;)

Ok ;-).


Regards,

Frédéric Jouault
Re: [TCS] Language Project example and dependent project's version [message #609304 is a reply to message #380455] Thu, 22 November 2007 22:49 Go to previous message
Frédéric Jouault is currently offline Frédéric Jouault
Messages: 572
Registered: July 2009
Senior Member
Hello,

To use the plugin builder, you should use the latest version of ATL and
AM3 (i.e., CVS HEAD).

To use the ant builder, you need the AM3 ant plugin, and to set the
script to execute in the same JRE as Eclipse (otherwise, the tasks will
not be found). See bottom of http://wiki.eclipse.org/AM3_Ant_Tasks

As for the example, note that you can also directly use the FIACRE and
LOTOS projects from the TCS Zoo, which are configured to use the ant
builder. See http://wiki.eclipse.org/TCS/Zoo


Regards,

Frédéric Jouault


Gustavo Cabral wrote:
> Hi everyone,
>
> I have tried the TCS/Language Project example
> (http://wiki.eclipse.org/TCS/Language_Project) with metamodel and
> syntax from the LOTOS example
> (http://www.eclipse.org/m2m/atl/usecases/FIACRE2LOTOS/) but I just cant
> make
> it work!
>
> I am using:
> - the latest classic eclipse, - updating with the EMF plugin,
> - downloading the latest ATL plugin (I also install a build I
> made from the CVS)
>
> ....but no success!
>
> I think it is some major problem with the Eclipse X ATL X EMF versions.
> I re-compiled and installed the latest version of ATL from the CVS
> repository but it didnt work. The classes:
>
> org.eclipse.m2m.atl.engine.AtlEMFModelHandler;
> org.eclipse.m2m.atl.engine.AtlModelHandler;
> import org.eclipse.gmt.tcs.injector.TCSInjector;
> org.eclipse.m2m.atl.engine.EnginePlugin;
> org.eclipse.m2m.atl.engine.MarkerMaker;
>
> cannot be found when I try to compile the "TCS Builder plugin" and the
> "TCS Wizard plugin".
> Through the ant approach, I get the following error:
>
> -----------
> .....
>
> BUILD FAILED
> /home/gustavo/Desktop/eclipseClassicX/workspace/AMMAScripts/ build.dsl.xml:55:
> The following error occurred while executing this line:
> /home/gustavo/Desktop/eclipseClassicX/workspace/AMMAScripts/ build.dsl.xml:78:
> The following error occurred while executing this line:
> /home/gustavo/Desktop/eclipseClassicX/workspace/AMMAScripts/ build.metamodel.xml:68:
> Problem: failed to create task or type am3.loadModel
> Cause: The name is undefined.
> Action: Check the spelling.
> Action: Check that any custom tasks/types have been declared.
> Action: Check that any <presetdef>/<macrodef> declarations have taken
> place.
>
> ------------
>
> Can any one help me? What versions should I use?
>
> Thank you for your time,
> Gustavo Cabral
>
>
>
Re: [TCS] Language Project example and dependent project's version [message #609668 is a reply to message #380462] Mon, 26 November 2007 07:33 Go to previous message
Gustavo Cabral is currently offline Gustavo Cabral
Messages: 20
Registered: July 2009
Junior Member
Thank you Frédéric,

Everything is working now! :) What I did was:

1) I downloaded a fresh class Eclipse build
(eclipse-SDK-3.3.1.1-linux-gtk.tar.gz)

2) Updated Eclipse (Help -> Software Update) with EMF (with the 2 core
plugins only)

3) Checked out, deployed, and installed the following plug-ins:

org.eclipse.am3.core
org.eclipse.am3.tools.tge
org.eclipse.am3.ui
org.eclipse.gmt.am3
org.eclipse.gmt.am3.core
org.eclipse.gmt.am3.modelhandler.emf
org.eclipse.gmt.am3.modelhandler.mdr
org.eclipse.gmt.am3.repository.lightweight
org.eclipse.gmt.am3.tools.ant
org.eclipse.gmt.tcs.builder
org.eclipse.m2m.atl.adt.builder
org.eclipse.m2m.atl.adt.debug
org.eclipse.m2m.atl.adt.editor
org.eclipse.m2m.atl.adt.perspective
org.eclipse.m2m.atl.adt.wizard
org.eclipse.m2m.atl.compilers.atl2006
org.eclipse.m2m.atl.drivers.emf4atl
org.eclipse.m2m.atl.drivers.mdr4atl
org.eclipse.m2m.atl.drivers.mdr4atl-feature
org.eclipse.m2m.atl.drivers.uml24atl
org.eclipse.m2m.atl.engine
org.eclipse.m2m.atl.engine.emfvm
org.eclipse.m2m.atl.engine.vm
org.eclipse.m2m.atl.ocl.core
org.eclipse.m2m.atl.service.core

* It is necessary to downloaded and set some necessary jars:

http://www.sciences.univ-nantes.fr/lina/atl/www/AMMAScripts/ libs/
http://mdr.netbeans.org/download/

4) Followed the Language_Project Ant-based approach.

http://wiki.eclipse.org/TCS/Language_Project#Creating_a_Lang uage_Project_For_Ant-based_Builder

Success! Thank you again.

Some questions:

* I think I am missing some plugin because I don't have the
"Inject to Ecore" options when I right click KM3 metamodels
(even when I am at the ATL perspective). Which one I should
have installed and forgot it?

* When I change the grammar from my DSL, does TGE acknowledge the new
megamodel (DSL grammar) version?

* Is there some documentation about some "new" keywords used
at the TCS file? "nonPrimary", for instance, what does it mean? :(

Thank you for the help again.

Thank you,
Gustavo

ps.: I am using the TCS framework to implement a "Formal Specification
Generation from Requirements" transformation strategy. After that, I am
using the system's model to accomplish testing (Model-based Testing). ;)
Re: [TCS] Language Project example and dependent project's version [message #609674 is a reply to message #380474] Mon, 26 November 2007 22:05 Go to previous message
Frédéric Jouault is currently offline Frédéric Jouault
Messages: 572
Registered: July 2009
Senior Member
Hi Gustavo,

Thank you for your description of the installation process. This will
hopefully help other people. Please, do not hesitate to contribute
things like this to the wiki (e.g., the
http://wiki.eclipse.org/TCS/Language_Project page does not give much
details about installation of the plugin builder).


> * I think I am missing some plugin because I don't have the "Inject to
> Ecore" options when I right click KM3 metamodels
> (even when I am at the ATL perspective). Which one I should
> have installed and forgot it?

These actions are available in the "AM3 Resource Navigator" view (you
can open it by going to menu "Window->Show View->Other...->ATL")


> * When I change the grammar from my DSL, does TGE acknowledge the new
> megamodel (DSL grammar) version?

The new version is used by TGE when it reparses the file (when you save
the file, or close then reopen the editor). However, I would advise
closing and reopening, because I noticed some problems in the outline
otherwise.


> * Is there some documentation about some "new" keywords used
> at the TCS file? "nonPrimary", for instance, what does it mean? :(

nonPrimary means that the expression is not a "primary" expression (like
LetExp in OCL). Technically, you should use nonPrimary on any
expression (i.e., with "operatored" superclass) that is not represented
using an operatorTemplate (therefore, not left-recursive), but that is
right-recursive.

The documentation is not complete yet, but we are working on improving it.


Regards,

Frédéric Jouault
Re: [TCS] Language Project example and dependent project's version [message #609677 is a reply to message #380480] Tue, 27 November 2007 02:47 Go to previous message
Gustavo Cabral is currently offline Gustavo Cabral
Messages: 20
Registered: July 2009
Junior Member
Hi,

I used the ATL view too, but when I right click a KM3 file, for instance,
I get no inject options.

No problem, the ANT DSL script creates the ecore file for me ;)

Gustavo
Re: [TCS] Language Project example and dependent project's version [message #609689 is a reply to message #380481] Thu, 29 November 2007 11:39 Go to previous message
Frédéric Jouault is currently offline Frédéric Jouault
Messages: 572
Registered: July 2009
Senior Member
Hello,

> I used the ATL view too, but when I right click a KM3 file, for instance,
> I get no inject options.

Which ATL view? The ATL perspective?

The view you need to be in is called "AM3 Resource Navigator".

> No problem, the ANT DSL script creates the ecore file for me ;)

Ok ;-).


Regards,

Frédéric Jouault
Previous Topic:[Epsilon] @Override on interface implementations
Next Topic:Bug or me ??
Goto Forum:
  


Current Time: Sun Apr 20 19:43:44 EDT 2014

Powered by FUDForum. Page generated in 0.03995 seconds