Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Dynamic Languages Toolkit (DLTK) » dltk 1.0 ruby support howto?
dltk 1.0 ruby support howto? [message #38882] Thu, 16 July 2009 15:04 Go to next message
Wolfgang Kittenberger is currently offline Wolfgang Kittenberger
Messages: 3
Registered: July 2009
Junior Member
I wanted to test the new dltk 1.0 & ruby IDE. I learned that this will be
supported on Galileo, so I downloaded "eclipse-SDK-3.5-macosx-cocoa.tar",
expanded it and tried to install dltk as I did it under Ganymed via the
update site: http://download.eclipse.org/technology/dltk/updates/. But
there 1.0 is not offered, only five different 0.9x versions.

Then I downloaded from
http://download.eclipse.org/technology/dltk/downloads/drops/ R1.0/R-1.0-200906171219/
the dltk core and the ruby IDE, and moved the content of the features and
plugins directories in the eclipse 3.5 directory.

I can see the wanted features and plugins in the "Installation Details" of
the "About" menu, but I do NOT see in the "Preferences" the "Ruby" menu
item to configure my interpreter,... So it seems that I cant use the Ruby
IDE of DLTK 1.0

What did I wrong???

here the dltk related info from the "configuration":

*** Features:
...
org.eclipse.dltk.core (1.0.0.v20090610-1638-7C--EAAoOQBPbbrBcPz0b)
"Eclipse Dynamic Languages Toolkit"
org.eclipse.dltk.ruby (1.0.0.v20090610-1638-7B--E_EkMO1NTYtAZCz-9) "Ruby
Development Tools"
...

*** Plug-in Registry:
...
org.eclipse.dltk (1.0.0.v20090615-1430) "Eclipse Dynamic Languages
Toolkit" [Resolved]
org.eclipse.dltk.ruby (1.0.0.v20090615-1430) "Ruby Development Tools"
[Resolved]
...
Re: dltk 1.0 ruby support howto? [message #38909 is a reply to message #38882] Fri, 17 July 2009 00:41 Go to previous messageGo to next message
Alex Panchenko is currently offline Alex Panchenko
Messages: 342
Registered: July 2009
Senior Member
Hi Wolfgang,

DLTK 1.0 requires EMF runtime, please find the link at the 1.0 download
page. I have updated the download page, so it should be clearer now.

Also you can install from the Galileo update site
http://download.eclipse.org/releases/galileo/

Regards,
Alex

Wolfgang Kittenberger wrote:
> I wanted to test the new dltk 1.0 & ruby IDE. I learned that this will
> be supported on Galileo, so I downloaded
> "eclipse-SDK-3.5-macosx-cocoa.tar", expanded it and tried to install
> dltk as I did it under Ganymed via the update site:
> http://download.eclipse.org/technology/dltk/updates/. But there 1.0 is
> not offered, only five different 0.9x versions.
>
> Then I downloaded from
> http://download.eclipse.org/technology/dltk/downloads/drops/ R1.0/R-1.0-200906171219/
> the dltk core and the ruby IDE, and moved the content of the features
> and plugins directories in the eclipse 3.5 directory.
>
> I can see the wanted features and plugins in the "Installation Details"
> of the "About" menu, but I do NOT see in the "Preferences" the "Ruby"
> menu item to configure my interpreter,... So it seems that I cant use
> the Ruby IDE of DLTK 1.0
>
> What did I wrong???
> here the dltk related info from the "configuration":
>
> *** Features:
> ..
> org.eclipse.dltk.core (1.0.0.v20090610-1638-7C--EAAoOQBPbbrBcPz0b)
> "Eclipse Dynamic Languages Toolkit"
> org.eclipse.dltk.ruby (1.0.0.v20090610-1638-7B--E_EkMO1NTYtAZCz-9) "Ruby
> Development Tools"
> ..
>
> *** Plug-in Registry:
> ..
> org.eclipse.dltk (1.0.0.v20090615-1430) "Eclipse Dynamic Languages
> Toolkit" [Resolved]
> org.eclipse.dltk.ruby (1.0.0.v20090615-1430) "Ruby Development Tools"
> [Resolved]
> ..
>
Re: dltk 1.0 ruby support howto? [message #38933 is a reply to message #38909] Fri, 17 July 2009 12:40 Go to previous message
Wolfgang Kittenberger is currently offline Wolfgang Kittenberger
Messages: 3
Registered: July 2009
Junior Member
Hi Alex,

Great - this solved my challenge. Now I am able to create a ruby
project,....
Thanks for the fast help and best regards

Wolfgang Kittenberger
Previous Topic:Not able to get option to switch to debug perspective for remote files
Next Topic:dltk ruby ide 1.0 features?
Goto Forum:
  


Current Time: Sat Aug 23 11:31:07 EDT 2014

Powered by FUDForum. Page generated in 0.01738 seconds