Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMT (Generative Modeling Technologies) » [TCS] Problem building TCS Language project
[TCS] Problem building TCS Language project [message #379932] Wed, 10 October 2007 23:08 Go to next message
Andy Carpenter is currently offline Andy CarpenterFriend
Messages: 145
Registered: July 2009
Senior Member
I've been attempting to build a TCS language project and have
a problem that I have managed to solve, but now have
one that, at the moment I cannot solve.

My current situation is this. I've created a TCS language
project as described on the TCS wiki, including checking
out the AMMACore and AMMAScripts.

Having done this, while compiling the generated java of the parser,
the class org.eclipse.gmt.tcs.injector.TCSInjector is not found.
Checking out the org.eclipse.gmt.tcs.injector project and exporting
that into a jar that was included on the classpath of the TCS
language project solved this.

Next during the building of the megamodel phase, the class
org.atl.engine.injectors.ebnf.AM3_ANTLR3Lexer is not found.
I have tried to solve this by checking out the AM3 dsl from
org.eclipse.gmt/AM3/dsls/AM3. However, when I build this I
get the class org/eclipse/gmt/tcs/injector/AM3_ANTLR3Lexer,
so, this does not solve my problem.

Any thoughts would be appreciated.

Andy.

--
-- ------------------------------------------------------------ -------------
Dr Andy Carpenter
School of Computer Science,
University of Manchester, Manchester M13 9PL, UK
Email: Andy.Carpenter@manchester.ac.uk
Tel: +44 161 275 6168
Fax: +44 161 275 6280
Re: [TCS] Problem building TCS Language project [message #379936 is a reply to message #379932] Thu, 11 October 2007 07:58 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: mikael.barbero.gmail.com

Hi Andy,

Which version of ATL do you have on your eclipse? TCS need the last CVS
version to work (and you don't need the org.eclipse.gmt.tcs project).

Have fun.

Regards,
Mikael

Andy Carpenter wrote:
> I've been attempting to build a TCS language project and have
> a problem that I have managed to solve, but now have
> one that, at the moment I cannot solve.
>
> My current situation is this. I've created a TCS language
> project as described on the TCS wiki, including checking
> out the AMMACore and AMMAScripts.
>
> Having done this, while compiling the generated java of the parser,
> the class org.eclipse.gmt.tcs.injector.TCSInjector is not found.
> Checking out the org.eclipse.gmt.tcs.injector project and exporting
> that into a jar that was included on the classpath of the TCS
> language project solved this.
>
> Next during the building of the megamodel phase, the class
> org.atl.engine.injectors.ebnf.AM3_ANTLR3Lexer is not found.
> I have tried to solve this by checking out the AM3 dsl from
> org.eclipse.gmt/AM3/dsls/AM3. However, when I build this I
> get the class org/eclipse/gmt/tcs/injector/AM3_ANTLR3Lexer,
> so, this does not solve my problem.
>
> Any thoughts would be appreciated.
>
> Andy.
>



--
Mikaël Barbero - PhD Candidate
ATLAS Group (INRIA & LINA) - University of Nantes
2, rue de la Houssinière
44322 Nantes Cedex 3 - France
tel. +33 2 51 12 58 08 /\ cell.+33 6 07 63 19 00
email: Mikael.Barbero@{gmail.com, univ-nantes.fr}
http://www.sciences.univ-nantes.fr/lina/atl/
Re: [TCS] Problem building TCS Language project [message #379938 is a reply to message #379936] Thu, 11 October 2007 11:56 Go to previous messageGo to next message
Andy Carpenter is currently offline Andy CarpenterFriend
Messages: 145
Registered: July 2009
Senior Member
Mikael,

Thanks for the information. I was using ATL 2.0.0 from the
update site on eclipse 3.3. I have now checked out ATL from
cvs and installed the plugins into my extension location. Now
the class not found error is for
org/atl/engine/injectors/ebnf/EBNFInjector2
is there another plugin that I should check out and install?

Andy.


"Mika
Re: [TCS] Problem building TCS Language project [message #379939 is a reply to message #379938] Thu, 11 October 2007 12:38 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: mikael.barbero.gmail.com

You should try to re-build your parser.

Regards,
Mikael

Andy Carpenter wrote:
> Mikael,
>
> Thanks for the information. I was using ATL 2.0.0 from the
> update site on eclipse 3.3. I have now checked out ATL from
> cvs and installed the plugins into my extension location. Now
> the class not found error is for
> org/atl/engine/injectors/ebnf/EBNFInjector2
> is there another plugin that I should check out and install?
>
> Andy.
>
>
> "Mikaël Barbero" <mikael.barbero@gmail.com> wrote in message
> news:fekl28$tvg$1@build.eclipse.org...
>> Hi Andy,
>>
>> Which version of ATL do you have on your eclipse? TCS need the last CVS
>> version to work (and you don't need the org.eclipse.gmt.tcs project).
>>
>> Have fun.
>>
>> Regards,
>> Mikael
>>
>> Andy Carpenter wrote:
>>> I've been attempting to build a TCS language project and have
>>> a problem that I have managed to solve, but now have
>>> one that, at the moment I cannot solve.
>>>
>>> My current situation is this. I've created a TCS language
>>> project as described on the TCS wiki, including checking
>>> out the AMMACore and AMMAScripts.
>>>
>>> Having done this, while compiling the generated java of the parser,
>>> the class org.eclipse.gmt.tcs.injector.TCSInjector is not found.
>>> Checking out the org.eclipse.gmt.tcs.injector project and exporting
>>> that into a jar that was included on the classpath of the TCS
>>> language project solved this.
>>>
>>> Next during the building of the megamodel phase, the class
>>> org.atl.engine.injectors.ebnf.AM3_ANTLR3Lexer is not found.
>>> I have tried to solve this by checking out the AM3 dsl from
>>> org.eclipse.gmt/AM3/dsls/AM3. However, when I build this I
>>> get the class org/eclipse/gmt/tcs/injector/AM3_ANTLR3Lexer,
>>> so, this does not solve my problem.
>>>
>>> Any thoughts would be appreciated.
>>>
>>> Andy.
>>>
>>
>>
>> --
>> Mikaël Barbero - PhD Candidate
>> ATLAS Group (INRIA & LINA) - University of Nantes
>> 2, rue de la Houssinière
>> 44322 Nantes Cedex 3 - France
>> tel. +33 2 51 12 58 08 /\ cell.+33 6 07 63 19 00
>> email: Mikael.Barbero@{gmail.com, univ-nantes.fr}
>> http://www.sciences.univ-nantes.fr/lina/atl/
>
>



--
Mikaël Barbero - PhD Candidate
ATLAS Group (INRIA & LINA) - University of Nantes
2, rue de la Houssinière
44322 Nantes Cedex 3 - France
tel. +33 2 51 12 58 08 /\ cell.+33 6 07 63 19 00
email: Mikael.Barbero@{gmail.com, univ-nantes.fr}
http://www.sciences.univ-nantes.fr/lina/atl/
Re: [TCS] Problem building TCS Language project [message #379940 is a reply to message #379939] Thu, 11 October 2007 14:39 Go to previous messageGo to next message
Andy Carpenter is currently offline Andy CarpenterFriend
Messages: 145
Registered: July 2009
Senior Member
That is what I was trying to do when I got the class not
found exception for org/atl/engine/injectors/ebnf/EBNFInjector2.

Andy.


"Mika
Re: [TCS] Problem building TCS Language project [message #380153 is a reply to message #379939] Thu, 11 October 2007 19:59 Go to previous messageGo to next message
Andy Carpenter is currently offline Andy CarpenterFriend
Messages: 145
Registered: July 2009
Senior Member
I'm getting the following error in the eclipse log when
starting eclipse

!ENTRY org.eclipse.gmt.am3.dsls.km3 4 0 2007-10-11 20:55:11.281
!MESSAGE Unable to execute early startup code for an extension
!STACK 0
java.lang.NoClassDefFoundError: org/atl/engine/extractors/ebnf/EBNFExtractor
at org.eclipse.gmt.am3.dsls.km3.Startup.earlyStartup(Startup.ja va:12)
at
org.eclipse.ui.internal.EarlyStartupRunnable.runEarlyStartup (EarlyStartupRunnable.java:87)
at
org.eclipse.ui.internal.EarlyStartupRunnable.run(EarlyStartu pRunnable.java:66)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
at org.eclipse.ui.internal.Workbench$54.run(Workbench.java:2190 )
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

Andy.


"Mika
Re: [TCS] Problem building TCS Language project [message #380157 is a reply to message #380153] Fri, 12 October 2007 16:12 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: mikael.barbero.gmail.com

Did you take AM3 project from the CVS ? New TCS also work with this
version (not only ATL CVS).

Regards,
Mikael

Andy Carpenter wrote:
> I'm getting the following error in the eclipse log when
> starting eclipse
>
> !ENTRY org.eclipse.gmt.am3.dsls.km3 4 0 2007-10-11 20:55:11.281
> !MESSAGE Unable to execute early startup code for an extension
> !STACK 0
> java.lang.NoClassDefFoundError: org/atl/engine/extractors/ebnf/EBNFExtractor
> at org.eclipse.gmt.am3.dsls.km3.Startup.earlyStartup(Startup.ja va:12)
> at
> org.eclipse.ui.internal.EarlyStartupRunnable.runEarlyStartup (EarlyStartupRunnable.java:87)
> at
> org.eclipse.ui.internal.EarlyStartupRunnable.run(EarlyStartu pRunnable.java:66)
> at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
> at org.eclipse.ui.internal.Workbench$54.run(Workbench.java:2190 )
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
>
> Andy.
>
>
> "Mikaël Barbero" <mikael.barbero@gmail.com> wrote in message
> news:fel5g4$k7h$1@build.eclipse.org...
>> You should try to re-build your parser.
>>
>> Regards,
>> Mikael
>>
>> Andy Carpenter wrote:
>>> Mikael,
>>>
>>> Thanks for the information. I was using ATL 2.0.0 from the
>>> update site on eclipse 3.3. I have now checked out ATL from
>>> cvs and installed the plugins into my extension location. Now
>>> the class not found error is for
>>> org/atl/engine/injectors/ebnf/EBNFInjector2
>>> is there another plugin that I should check out and install?
>>>
>>> Andy.
>>>
>>>
>>> "Mikaël Barbero" <mikael.barbero@gmail.com> wrote in message
>>> news:fekl28$tvg$1@build.eclipse.org...
>>>> Hi Andy,
>>>>
>>>> Which version of ATL do you have on your eclipse? TCS need the last CVS
>>>> version to work (and you don't need the org.eclipse.gmt.tcs project).
>>>>
>>>> Have fun.
>>>>
>>>> Regards,
>>>> Mikael
>>>>
>>>> Andy Carpenter wrote:
>>>>> I've been attempting to build a TCS language project and have
>>>>> a problem that I have managed to solve, but now have
>>>>> one that, at the moment I cannot solve.
>>>>>
>>>>> My current situation is this. I've created a TCS language
>>>>> project as described on the TCS wiki, including checking
>>>>> out the AMMACore and AMMAScripts.
>>>>>
>>>>> Having done this, while compiling the generated java of the parser,
>>>>> the class org.eclipse.gmt.tcs.injector.TCSInjector is not found.
>>>>> Checking out the org.eclipse.gmt.tcs.injector project and exporting
>>>>> that into a jar that was included on the classpath of the TCS
>>>>> language project solved this.
>>>>>
>>>>> Next during the building of the megamodel phase, the class
>>>>> org.atl.engine.injectors.ebnf.AM3_ANTLR3Lexer is not found.
>>>>> I have tried to solve this by checking out the AM3 dsl from
>>>>> org.eclipse.gmt/AM3/dsls/AM3. However, when I build this I
>>>>> get the class org/eclipse/gmt/tcs/injector/AM3_ANTLR3Lexer,
>>>>> so, this does not solve my problem.
>>>>>
>>>>> Any thoughts would be appreciated.
>>>>>
>>>>> Andy.
>>>>>
>>>>
>>>> --
>>>> Mikaël Barbero - PhD Candidate
>>>> ATLAS Group (INRIA & LINA) - University of Nantes
>>>> 2, rue de la Houssinière
>>>> 44322 Nantes Cedex 3 - France
>>>> tel. +33 2 51 12 58 08 /\ cell.+33 6 07 63 19 00
>>>> email: Mikael.Barbero@{gmail.com, univ-nantes.fr}
>>>> http://www.sciences.univ-nantes.fr/lina/atl/
>>>
>>
>>
>> --
>> Mikaël Barbero - PhD Candidate
>> ATLAS Group (INRIA & LINA) - University of Nantes
>> 2, rue de la Houssinière
>> 44322 Nantes Cedex 3 - France
>> tel. +33 2 51 12 58 08 /\ cell.+33 6 07 63 19 00
>> email: Mikael.Barbero@{gmail.com, univ-nantes.fr}
>> http://www.sciences.univ-nantes.fr/lina/atl/
>
>



--
Mikaël Barbero - PhD Candidate
ATLAS Group (INRIA & LINA) - University of Nantes
2, rue de la Houssinière
44322 Nantes Cedex 3 - France
tel. +33 2 51 12 58 08 /\ cell.+33 6 07 63 19 00
email: Mikael.Barbero@{gmail.com, univ-nantes.fr}
http://www.sciences.univ-nantes.fr/lina/atl/
Re: [TCS] Problem building TCS Language project [message #380174 is a reply to message #380157] Tue, 23 October 2007 10:24 Go to previous message
Andy Carpenter is currently offline Andy CarpenterFriend
Messages: 145
Registered: July 2009
Senior Member
Thanks Mikael, I can now run TCS projects.

As the way that I got this sorted required some thought, it seems
appropriate to document what I did.

The first thing was to checkout a number of projects into
a empty single workspace. In particular, all projects from
dev.eclipse.org/cvsroot/modeling/org.eclipse.m2m/org.eclipse .m2m.atl/plugins
all projects from
dev.eclipse.org/cvsroot/technology/org.eclipse.gmt/AM3/plugi ns
plus from
dev.eclipse.org/cvsroot/technology/org.eclipse.gmt/AM3 the following
projects
org.eclipse.am3.core
org.eclipse.am3.tools.tge
org.eclipse.am3.ui
org.eclipse.gmt.am3.dsls.km3
org.eclipse.gmt.am3.dsls-feature
org.eclipse.gmt.am3.tools.ant
org.eclipse.gmt.am3-feature

I then got the mdr jars from http://mdr.netbeans.org/download/
(downloading mdr-standalone.zip) and unzipped its contents into
org.eclipse.m2m.atl.drivers.mdr4atl/lib and
org.eclipse.gmt.am3.modelhandler.mdr/lib

This leaves the project org.eclipse.gmt.am3.repository.teneo with
an error, but it appears that this project is not required.

Finally I exported the all of the features into an extension location
File -> Export,
Plug-in Development -> Deployable features,
Select all

Having done this, I was able to restart eclipse and create a TCL
language project in my development workspace as described on
the TCS wiki.



>>>> Thanks for the information. I was using ATL 2.0.0 from the
>>>> update site on eclipse 3.3. I have now checked out ATL from
>>>> cvs and installed the plugins into my extension location. Now
>>>> the class not found error is for
>>>> org/atl/engine/injectors/ebnf/EBNFInjector2
>>>> is there another plugin that I should check out and install?
Re: [TCS] Problem building TCS Language project [message #608143 is a reply to message #379932] Thu, 11 October 2007 07:58 Go to previous message
Eclipse UserFriend
Originally posted by: mikael.barbero.gmail.com

Hi Andy,

Which version of ATL do you have on your eclipse? TCS need the last CVS
version to work (and you don't need the org.eclipse.gmt.tcs project).

Have fun.

Regards,
Mikael

Andy Carpenter wrote:
> I've been attempting to build a TCS language project and have
> a problem that I have managed to solve, but now have
> one that, at the moment I cannot solve.
>
> My current situation is this. I've created a TCS language
> project as described on the TCS wiki, including checking
> out the AMMACore and AMMAScripts.
>
> Having done this, while compiling the generated java of the parser,
> the class org.eclipse.gmt.tcs.injector.TCSInjector is not found.
> Checking out the org.eclipse.gmt.tcs.injector project and exporting
> that into a jar that was included on the classpath of the TCS
> language project solved this.
>
> Next during the building of the megamodel phase, the class
> org.atl.engine.injectors.ebnf.AM3_ANTLR3Lexer is not found.
> I have tried to solve this by checking out the AM3 dsl from
> org.eclipse.gmt/AM3/dsls/AM3. However, when I build this I
> get the class org/eclipse/gmt/tcs/injector/AM3_ANTLR3Lexer,
> so, this does not solve my problem.
>
> Any thoughts would be appreciated.
>
> Andy.
>



--
Mikaël Barbero - PhD Candidate
ATLAS Group (INRIA & LINA) - University of Nantes
2, rue de la Houssinière
44322 Nantes Cedex 3 - France
tel. +33 2 51 12 58 08 /\ cell.+33 6 07 63 19 00
email: Mikael.Barbero@{gmail.com, univ-nantes.fr}
http://www.sciences.univ-nantes.fr/lina/atl/
Re: [TCS] Problem building TCS Language project [message #608145 is a reply to message #379936] Thu, 11 October 2007 11:56 Go to previous message
Andy Carpenter is currently offline Andy CarpenterFriend
Messages: 145
Registered: July 2009
Senior Member
Mikael,

Thanks for the information. I was using ATL 2.0.0 from the
update site on eclipse 3.3. I have now checked out ATL from
cvs and installed the plugins into my extension location. Now
the class not found error is for
org/atl/engine/injectors/ebnf/EBNFInjector2
is there another plugin that I should check out and install?

Andy.


"Mika
Re: [TCS] Problem building TCS Language project [message #608146 is a reply to message #379938] Thu, 11 October 2007 12:38 Go to previous message
Eclipse UserFriend
Originally posted by: mikael.barbero.gmail.com

You should try to re-build your parser.

Regards,
Mikael

Andy Carpenter wrote:
> Mikael,
>
> Thanks for the information. I was using ATL 2.0.0 from the
> update site on eclipse 3.3. I have now checked out ATL from
> cvs and installed the plugins into my extension location. Now
> the class not found error is for
> org/atl/engine/injectors/ebnf/EBNFInjector2
> is there another plugin that I should check out and install?
>
> Andy.
>
>
> "Mikaël Barbero" <mikael.barbero@gmail.com> wrote in message
> news:fekl28$tvg$1@build.eclipse.org...
>> Hi Andy,
>>
>> Which version of ATL do you have on your eclipse? TCS need the last CVS
>> version to work (and you don't need the org.eclipse.gmt.tcs project).
>>
>> Have fun.
>>
>> Regards,
>> Mikael
>>
>> Andy Carpenter wrote:
>>> I've been attempting to build a TCS language project and have
>>> a problem that I have managed to solve, but now have
>>> one that, at the moment I cannot solve.
>>>
>>> My current situation is this. I've created a TCS language
>>> project as described on the TCS wiki, including checking
>>> out the AMMACore and AMMAScripts.
>>>
>>> Having done this, while compiling the generated java of the parser,
>>> the class org.eclipse.gmt.tcs.injector.TCSInjector is not found.
>>> Checking out the org.eclipse.gmt.tcs.injector project and exporting
>>> that into a jar that was included on the classpath of the TCS
>>> language project solved this.
>>>
>>> Next during the building of the megamodel phase, the class
>>> org.atl.engine.injectors.ebnf.AM3_ANTLR3Lexer is not found.
>>> I have tried to solve this by checking out the AM3 dsl from
>>> org.eclipse.gmt/AM3/dsls/AM3. However, when I build this I
>>> get the class org/eclipse/gmt/tcs/injector/AM3_ANTLR3Lexer,
>>> so, this does not solve my problem.
>>>
>>> Any thoughts would be appreciated.
>>>
>>> Andy.
>>>
>>
>>
>> --
>> Mikaël Barbero - PhD Candidate
>> ATLAS Group (INRIA & LINA) - University of Nantes
>> 2, rue de la Houssinière
>> 44322 Nantes Cedex 3 - France
>> tel. +33 2 51 12 58 08 /\ cell.+33 6 07 63 19 00
>> email: Mikael.Barbero@{gmail.com, univ-nantes.fr}
>> http://www.sciences.univ-nantes.fr/lina/atl/
>
>



--
Mikaël Barbero - PhD Candidate
ATLAS Group (INRIA & LINA) - University of Nantes
2, rue de la Houssinière
44322 Nantes Cedex 3 - France
tel. +33 2 51 12 58 08 /\ cell.+33 6 07 63 19 00
email: Mikael.Barbero@{gmail.com, univ-nantes.fr}
http://www.sciences.univ-nantes.fr/lina/atl/
Re: [TCS] Problem building TCS Language project [message #608147 is a reply to message #379939] Thu, 11 October 2007 14:39 Go to previous message
Andy Carpenter is currently offline Andy CarpenterFriend
Messages: 145
Registered: July 2009
Senior Member
That is what I was trying to do when I got the class not
found exception for org/atl/engine/injectors/ebnf/EBNFInjector2.

Andy.


"Mika
Re: [TCS] Problem building TCS Language project [message #608151 is a reply to message #379939] Thu, 11 October 2007 19:59 Go to previous message
Andy Carpenter is currently offline Andy CarpenterFriend
Messages: 145
Registered: July 2009
Senior Member
I'm getting the following error in the eclipse log when
starting eclipse

!ENTRY org.eclipse.gmt.am3.dsls.km3 4 0 2007-10-11 20:55:11.281
!MESSAGE Unable to execute early startup code for an extension
!STACK 0
java.lang.NoClassDefFoundError: org/atl/engine/extractors/ebnf/EBNFExtractor
at org.eclipse.gmt.am3.dsls.km3.Startup.earlyStartup(Startup.ja va:12)
at
org.eclipse.ui.internal.EarlyStartupRunnable.runEarlyStartup (EarlyStartupRunnable.java:87)
at
org.eclipse.ui.internal.EarlyStartupRunnable.run(EarlyStartu pRunnable.java:66)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
at org.eclipse.ui.internal.Workbench$54.run(Workbench.java:2190 )
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

Andy.


"Mika
Re: [TCS] Problem building TCS Language project [message #608163 is a reply to message #380153] Fri, 12 October 2007 16:12 Go to previous message
Eclipse UserFriend
Originally posted by: mikael.barbero.gmail.com

Did you take AM3 project from the CVS ? New TCS also work with this
version (not only ATL CVS).

Regards,
Mikael

Andy Carpenter wrote:
> I'm getting the following error in the eclipse log when
> starting eclipse
>
> !ENTRY org.eclipse.gmt.am3.dsls.km3 4 0 2007-10-11 20:55:11.281
> !MESSAGE Unable to execute early startup code for an extension
> !STACK 0
> java.lang.NoClassDefFoundError: org/atl/engine/extractors/ebnf/EBNFExtractor
> at org.eclipse.gmt.am3.dsls.km3.Startup.earlyStartup(Startup.ja va:12)
> at
> org.eclipse.ui.internal.EarlyStartupRunnable.runEarlyStartup (EarlyStartupRunnable.java:87)
> at
> org.eclipse.ui.internal.EarlyStartupRunnable.run(EarlyStartu pRunnable.java:66)
> at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
> at org.eclipse.ui.internal.Workbench$54.run(Workbench.java:2190 )
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
>
> Andy.
>
>
> "Mikaël Barbero" <mikael.barbero@gmail.com> wrote in message
> news:fel5g4$k7h$1@build.eclipse.org...
>> You should try to re-build your parser.
>>
>> Regards,
>> Mikael
>>
>> Andy Carpenter wrote:
>>> Mikael,
>>>
>>> Thanks for the information. I was using ATL 2.0.0 from the
>>> update site on eclipse 3.3. I have now checked out ATL from
>>> cvs and installed the plugins into my extension location. Now
>>> the class not found error is for
>>> org/atl/engine/injectors/ebnf/EBNFInjector2
>>> is there another plugin that I should check out and install?
>>>
>>> Andy.
>>>
>>>
>>> "Mikaël Barbero" <mikael.barbero@gmail.com> wrote in message
>>> news:fekl28$tvg$1@build.eclipse.org...
>>>> Hi Andy,
>>>>
>>>> Which version of ATL do you have on your eclipse? TCS need the last CVS
>>>> version to work (and you don't need the org.eclipse.gmt.tcs project).
>>>>
>>>> Have fun.
>>>>
>>>> Regards,
>>>> Mikael
>>>>
>>>> Andy Carpenter wrote:
>>>>> I've been attempting to build a TCS language project and have
>>>>> a problem that I have managed to solve, but now have
>>>>> one that, at the moment I cannot solve.
>>>>>
>>>>> My current situation is this. I've created a TCS language
>>>>> project as described on the TCS wiki, including checking
>>>>> out the AMMACore and AMMAScripts.
>>>>>
>>>>> Having done this, while compiling the generated java of the parser,
>>>>> the class org.eclipse.gmt.tcs.injector.TCSInjector is not found.
>>>>> Checking out the org.eclipse.gmt.tcs.injector project and exporting
>>>>> that into a jar that was included on the classpath of the TCS
>>>>> language project solved this.
>>>>>
>>>>> Next during the building of the megamodel phase, the class
>>>>> org.atl.engine.injectors.ebnf.AM3_ANTLR3Lexer is not found.
>>>>> I have tried to solve this by checking out the AM3 dsl from
>>>>> org.eclipse.gmt/AM3/dsls/AM3. However, when I build this I
>>>>> get the class org/eclipse/gmt/tcs/injector/AM3_ANTLR3Lexer,
>>>>> so, this does not solve my problem.
>>>>>
>>>>> Any thoughts would be appreciated.
>>>>>
>>>>> Andy.
>>>>>
>>>>
>>>> --
>>>> Mikaël Barbero - PhD Candidate
>>>> ATLAS Group (INRIA & LINA) - University of Nantes
>>>> 2, rue de la Houssinière
>>>> 44322 Nantes Cedex 3 - France
>>>> tel. +33 2 51 12 58 08 /\ cell.+33 6 07 63 19 00
>>>> email: Mikael.Barbero@{gmail.com, univ-nantes.fr}
>>>> http://www.sciences.univ-nantes.fr/lina/atl/
>>>
>>
>>
>> --
>> Mikaël Barbero - PhD Candidate
>> ATLAS Group (INRIA & LINA) - University of Nantes
>> 2, rue de la Houssinière
>> 44322 Nantes Cedex 3 - France
>> tel. +33 2 51 12 58 08 /\ cell.+33 6 07 63 19 00
>> email: Mikael.Barbero@{gmail.com, univ-nantes.fr}
>> http://www.sciences.univ-nantes.fr/lina/atl/
>
>



--
Mikaël Barbero - PhD Candidate
ATLAS Group (INRIA & LINA) - University of Nantes
2, rue de la Houssinière
44322 Nantes Cedex 3 - France
tel. +33 2 51 12 58 08 /\ cell.+33 6 07 63 19 00
email: Mikael.Barbero@{gmail.com, univ-nantes.fr}
http://www.sciences.univ-nantes.fr/lina/atl/
Re: [TCS] Problem building TCS Language project [message #608171 is a reply to message #380157] Tue, 23 October 2007 10:24 Go to previous message
Andy Carpenter is currently offline Andy CarpenterFriend
Messages: 145
Registered: July 2009
Senior Member
Thanks Mikael, I can now run TCS projects.

As the way that I got this sorted required some thought, it seems
appropriate to document what I did.

The first thing was to checkout a number of projects into
a empty single workspace. In particular, all projects from
dev.eclipse.org/cvsroot/modeling/org.eclipse.m2m/org.eclipse .m2m.atl/plugins
all projects from
dev.eclipse.org/cvsroot/technology/org.eclipse.gmt/AM3/plugi ns
plus from
dev.eclipse.org/cvsroot/technology/org.eclipse.gmt/AM3 the following
projects
org.eclipse.am3.core
org.eclipse.am3.tools.tge
org.eclipse.am3.ui
org.eclipse.gmt.am3.dsls.km3
org.eclipse.gmt.am3.dsls-feature
org.eclipse.gmt.am3.tools.ant
org.eclipse.gmt.am3-feature

I then got the mdr jars from http://mdr.netbeans.org/download/
(downloading mdr-standalone.zip) and unzipped its contents into
org.eclipse.m2m.atl.drivers.mdr4atl/lib and
org.eclipse.gmt.am3.modelhandler.mdr/lib

This leaves the project org.eclipse.gmt.am3.repository.teneo with
an error, but it appears that this project is not required.

Finally I exported the all of the features into an extension location
File -> Export,
Plug-in Development -> Deployable features,
Select all

Having done this, I was able to restart eclipse and create a TCL
language project in my development workspace as described on
the TCS wiki.



>>>> Thanks for the information. I was using ATL 2.0.0 from the
>>>> update site on eclipse 3.3. I have now checked out ATL from
>>>> cvs and installed the plugins into my extension location. Now
>>>> the class not found error is for
>>>> org/atl/engine/injectors/ebnf/EBNFInjector2
>>>> is there another plugin that I should check out and install?
Previous Topic:[TCS] "Unable to determine generatted class" error
Next Topic:[GEMS] GEMS EMF Intelligence Release Candidate
Goto Forum:
  


Current Time: Mon Nov 24 18:13:46 GMT 2014

Powered by FUDForum. Page generated in 0.02966 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software