Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Dynamic Languages Toolkit (DLTK) » Ruby 1.9.x
Ruby 1.9.x [message #38786] Sun, 12 July 2009 12:39 Go to next message
Eclipse User
Originally posted by: gszpem.gmail.com

Hello,

Is there a way to set up using Ruby version 1.9.x? I'm mostly interested
in the editor support and the basic build (it should complain about the
new hash literal syntax, etc..)

I don't see any relevant preferences, except perhaps the 'Interpreters'
but does that effect source parsing for syntax highlighting, error markers?
(Also, I'm not using an external interpreter, just a JRuby 1.3.1 bundle as
part of the Eclipse product).

Thanks in advance,Gergo
Re: Ruby 1.9.x - supported? [message #484303 is a reply to message #38786] Sat, 05 September 2009 18:43 Go to previous messageGo to next message
Gergely Nagy is currently offline Gergely Nagy
Messages: 17
Registered: July 2009
Junior Member
Is there any way for the editor to support Ruby 1.9 syntax?
Thanks,
Gergo
Re: Ruby 1.9.x - supported? [message #484343 is a reply to message #484303] Sun, 06 September 2009 23:44 Go to previous messageGo to next message
Alex Panchenko is currently offline Alex Panchenko
Messages: 342
Registered: July 2009
Senior Member
Gergely Nagy wrote:
> Is there any way for the editor to support Ruby 1.9 syntax?
> Thanks, Gergo

Hi Gergo,

At the moment it's not supported, I hope it would be done during 2.0
development cycle.

Regards,
Alex
Re: Ruby 1.9.x - supported? [message #974854 is a reply to message #484343] Wed, 07 November 2012 06:36 Go to previous messageGo to next message
Yonatan Schor is currently offline Yonatan Schor
Messages: 1
Registered: November 2012
Junior Member
I seem to have a dltk.ruby_4+ jar in my eclipse plugins folder.
Still, Ruby 1.9+ maps syntax like the following is regarded by the IDE as an error:
{ code: "AAA" }

Only the old Ruby map syntax is supported:
{ :code=> "AAA" }


Any way I can solve this without patching the plugin?
Re: Ruby 1.9.x - supported? [message #1064756 is a reply to message #974854] Thu, 20 June 2013 16:33 Go to previous message
Ivan Storck is currently offline Ivan Storck
Messages: 1
Registered: June 2013
Junior Member
Any updates on this? it's been over 6 months, Ruby 2.0 is out now.
Previous Topic:Using another debugging tool
Next Topic:Integration Build: I-201306060709 download page not working
Goto Forum:
  


Current Time: Sat Aug 30 08:36:08 EDT 2014

Powered by FUDForum. Page generated in 0.02329 seconds