Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Modeling (top-level project) » error at topcased
error at topcased [message #378349] Fri, 18 August 2006 12:57 Go to next message
Eclipse UserFriend
Originally posted by: erelender.gmail.com

I design my metamodel using ecore and create the plugin using .genmodel
file.
It successfully creates the plugin. I copy the plugin to eclipse/plugins
folder. When i try to create a model from my plugin i get an error:

The selected wizard could not be started.
Reason:
plugin myproject was unable to load class
org.topcased.myproject.presentationmyprojectModelWizard.

i check the file and everything seems to be ok.

Any help is welcome, thank you
Re: error at topcased [message #378350 is a reply to message #378349] Fri, 18 August 2006 13:33 Go to previous messageGo to next message
David Sciamma is currently offline David SciammaFriend
Messages: 78
Registered: July 2009
Member
Hi,

You need to export the generated plugin before deploying it instead of
just copy it to the eclipse/plugins folder.
To export your project :
Right Click on the project > Export > Deployable Plugins and Fragments >
Finish

Regards,

PS : you should use the Topcased user mailing list :
http://gforge.enseeiht.fr/mail/?group_id=7

Ender EREL a écrit :
> I design my metamodel using ecore and create the plugin using .genmodel
> file.
> It successfully creates the plugin. I copy the plugin to eclipse/plugins
> folder. When i try to create a model from my plugin i get an error:
>
> The selected wizard could not be started.
> Reason:
> plugin myproject was unable to load class
> org.topcased.myproject.presentationmyprojectModelWizard.
>
> i check the file and everything seems to be ok.
> Any help is welcome, thank you
>


--
David SCIAMMA

Expert Eclipse / Eclipse Expert
ANYWARE TECHNOLOGIES
Tel : + 33 (0)5.61.00.73.44
Fax : + 33 (0)5.61.00.51.46
http://www.anyware-tech.com
Re: error at topcased [message #378351 is a reply to message #378349] Fri, 18 August 2006 13:45 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 26226
Registered: July 2009
Senior Member
This is a multi-part message in MIME format.
--------------040606050603020706000906
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 7bit

Ender,

This is more of an EMF newsgroup question. Did launching a runtime
workspace and running it there work correctly. Did you run eclipse.exe
-clean after you copied the new plugins into the plugin folder to
refresh the configuration? Probably your MANIFEST.MF has

Bundle-ClassPath: .

which means it will look in the root of the plugin for the .class
files. But they are built into the bin directory, which the runtime
workspace will use. You need to export the plugin to jar it and use it
that way...


Ender EREL wrote:
> I design my metamodel using ecore and create the plugin using
> .genmodel file.
> It successfully creates the plugin. I copy the plugin to
> eclipse/plugins folder. When i try to create a model from my plugin i
> get an error:
>
> The selected wizard could not be started.
> Reason:
> plugin myproject was unable to load class
> org.topcased.myproject.presentationmyprojectModelWizard.
>
> i check the file and everything seems to be ok.
> Any help is welcome, thank you
>


--------------040606050603020706000906
Content-Type: text/html; charset=ISO-8859-15
Content-Transfer-Encoding: 8bit

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html;charset=ISO-8859-15"
http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Ender,<br>
<br>
This is more of an EMF newsgroup question.
Re: error at topcased [message #578941 is a reply to message #378349] Fri, 18 August 2006 13:33 Go to previous message
David Sciamma is currently offline David SciammaFriend
Messages: 78
Registered: July 2009
Member
Hi,

You need to export the generated plugin before deploying it instead of
just copy it to the eclipse/plugins folder.
To export your project :
Right Click on the project > Export > Deployable Plugins and Fragments >
Finish

Regards,

PS : you should use the Topcased user mailing list :
http://gforge.enseeiht.fr/mail/?group_id=7

Ender EREL a écrit :
> I design my metamodel using ecore and create the plugin using .genmodel
> file.
> It successfully creates the plugin. I copy the plugin to eclipse/plugins
> folder. When i try to create a model from my plugin i get an error:
>
> The selected wizard could not be started.
> Reason:
> plugin myproject was unable to load class
> org.topcased.myproject.presentationmyprojectModelWizard.
>
> i check the file and everything seems to be ok.
> Any help is welcome, thank you
>


--
David SCIAMMA

Expert Eclipse / Eclipse Expert
ANYWARE TECHNOLOGIES
Tel : + 33 (0)5.61.00.73.44
Fax : + 33 (0)5.61.00.51.46
http://www.anyware-tech.com
Re: error at topcased [message #578957 is a reply to message #378349] Fri, 18 August 2006 13:45 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 26226
Registered: July 2009
Senior Member
This is a multi-part message in MIME format.
--------------040606050603020706000906
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 7bit

Ender,

This is more of an EMF newsgroup question. Did launching a runtime
workspace and running it there work correctly. Did you run eclipse.exe
-clean after you copied the new plugins into the plugin folder to
refresh the configuration? Probably your MANIFEST.MF has

Bundle-ClassPath: .

which means it will look in the root of the plugin for the .class
files. But they are built into the bin directory, which the runtime
workspace will use. You need to export the plugin to jar it and use it
that way...


Ender EREL wrote:
> I design my metamodel using ecore and create the plugin using
> .genmodel file.
> It successfully creates the plugin. I copy the plugin to
> eclipse/plugins folder. When i try to create a model from my plugin i
> get an error:
>
> The selected wizard could not be started.
> Reason:
> plugin myproject was unable to load class
> org.topcased.myproject.presentationmyprojectModelWizard.
>
> i check the file and everything seems to be ok.
> Any help is welcome, thank you
>


--------------040606050603020706000906
Content-Type: text/html; charset=ISO-8859-15
Content-Transfer-Encoding: 8bit

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html;charset=ISO-8859-15"
http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Ender,<br>
<br>
This is more of an EMF newsgroup question.
Previous Topic:error at topcased
Next Topic:Artists needed for logo contest
Goto Forum:
  


Current Time: Wed Nov 26 23:21:58 GMT 2014

Powered by FUDForum. Page generated in 0.08442 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software