Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » java.lang.NoClassDefFoundError: org/eclipse/emf/edit/domain/EditingDomain
java.lang.NoClassDefFoundError: org/eclipse/emf/edit/domain/EditingDomain [message #38664] Wed, 02 November 2005 18:59 Go to next message
Alisa Smith is currently offline Alisa Smith
Messages: 6
Registered: July 2009
Junior Member
I have multiple projects in my workspace. I was able to import and run my
JUnit tests just fine for one of my projects - getting passed/failed
results. However, my other projects I am getting an inconclusive result
with an error (see below). I am using TPTP 4.1.0 Development Release
10-28-2005. Does anyone know why I am getting this error:


java.lang.NoClassDefFoundError: org/eclipse/emf/edit/domain/EditingDomain
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Unknown Source)
at
org.eclipse.hyades.test.java.runner.HyadesJUnitRunner.main(H yadesJUnitRunner.java:139)
Re: java.lang.NoClassDefFoundError: org/eclipse/emf/edit/domain/EditingDomain [message #39491 is a reply to message #38664] Fri, 04 November 2005 14:55 Go to previous message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Hi Alisa,
In your situation, the TPTP JUnit runner thinks that the
org.eclipse.emf.edit.domain.EditingDomain class is the TPTP JUnit test
suite. Of course, this class is not TPTP JUnit test suite so the execution
will ultimately fail but your failure is caused by a missing dependency
(org.eclipse.emf.edit plugin) in the org.eclipse.hyades.test.tools.core
plugin. As such, the class loader for the
org.eclipse.hyades.test.tools.core plugin cannot find the
org.eclipse.emf.edit.domain.EditingDomain class in the org.eclipse.emf.edit
plugin.

Can you provide the test suite and steps used to execute this test
suite?

Paul

"Alisa Smith" <smithali@ugs.com> wrote in message
news:c500519878c515bcd76c5f179ab60d6a$1@www.eclipse.org...
> I have multiple projects in my workspace. I was able to import and run my
> JUnit tests just fine for one of my projects - getting passed/failed
> results. However, my other projects I am getting an inconclusive result
> with an error (see below). I am using TPTP 4.1.0 Development Release
> 10-28-2005. Does anyone know why I am getting this error:
>
>
> java.lang.NoClassDefFoundError: org/eclipse/emf/edit/domain/EditingDomain
> at java.lang.Class.forName0(Native Method)
> at java.lang.Class.forName(Unknown Source)
> at
>
org.eclipse.hyades.test.java.runner.HyadesJUnitRunner.main(H yadesJUnitRunner
..java:139)
>
>
>
Previous Topic:exception with dynamic class loading
Next Topic:Trace log file
Goto Forum:
  


Current Time: Thu Sep 18 18:07:22 GMT 2014

Powered by FUDForum. Page generated in 0.01787 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software