Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMT (Generative Modeling Technologies) » [TCS]TCS-Importer.jar that works with ATL CVSHEAD?
[TCS]TCS-Importer.jar that works with ATL CVSHEAD? [message #378268] Thu, 21 June 2007 19:04 Go to next message
Eclipse User
Originally posted by: matt.mcgill.gmail.com

Hello,

Is there an updated TCS-Importer.jar anywhere to be found, on the web or
in CVS, which will work correctly with the current ATL sources as found
in the m2m CVS repository and the current AM3 sources as found in the
gmt CVS repository?

I can only make the TCS stuff in the TCS toolkit work with the 20070217
ATL bundle, but I can't find sources for that release. And I can't get
the CVSHEAD sources for ATL/AM3 to work with the stuff in the TCS
toolkit. This is a major roadblock right now -- any solutions?

-Matt McGill
Re: [TCS]TCS-Importer.jar that works with ATL CVSHEAD? [message #378269 is a reply to message #378268] Sat, 23 June 2007 07:36 Go to previous message
Frédéric Jouault is currently offline Frédéric Jouault
Messages: 572
Registered: July 2009
Senior Member
Hello,

> Is there an updated TCS-Importer.jar anywhere to be found, on the web or
> in CVS, which will work correctly with the current ATL sources as found
> in the m2m CVS repository and the current AM3 sources as found in the
> gmt CVS repository?
>
> I can only make the TCS stuff in the TCS toolkit work with the 20070217
> ATL bundle, but I can't find sources for that release. And I can't get
> the CVSHEAD sources for ATL/AM3 to work with the stuff in the TCS
> toolkit. This is a major roadblock right now -- any solutions?

We are working on the ATL CVS HEAD right now. The new version uses ANTLR
3 ;-).

We have not had the time yet to work on AM3, but this is the next step.
However, new versions of KM3 and TCS parsers have already been committed
to AM3 yesterday. TGE now works again.

Of course, if you want an older version of ATL to work with AM3, you can
simply check out an older version from CVS.


Regards,

Frédéric Jouault
Re: [TCS]TCS-Importer.jar that works with ATL CVSHEAD? [message #602095 is a reply to message #378268] Sat, 23 June 2007 07:36 Go to previous message
Frédéric Jouault is currently offline Frédéric Jouault
Messages: 572
Registered: July 2009
Senior Member
Hello,

> Is there an updated TCS-Importer.jar anywhere to be found, on the web or
> in CVS, which will work correctly with the current ATL sources as found
> in the m2m CVS repository and the current AM3 sources as found in the
> gmt CVS repository?
>
> I can only make the TCS stuff in the TCS toolkit work with the 20070217
> ATL bundle, but I can't find sources for that release. And I can't get
> the CVSHEAD sources for ATL/AM3 to work with the stuff in the TCS
> toolkit. This is a major roadblock right now -- any solutions?

We are working on the ATL CVS HEAD right now. The new version uses ANTLR
3 ;-).

We have not had the time yet to work on AM3, but this is the next step.
However, new versions of KM3 and TCS parsers have already been committed
to AM3 yesterday. TGE now works again.

Of course, if you want an older version of ATL to work with AM3, you can
simply check out an older version from CVS.


Regards,

Frédéric Jouault
Previous Topic:[TCS]TCS-Importer.jar that works with ATL CVSHEAD?
Next Topic:[MOFScript] Java Integration - Parse Error
Goto Forum:
  


Current Time: Thu Oct 02 02:32:12 GMT 2014

Powered by FUDForum. Page generated in 0.01922 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software