Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » MDT (Model Development Tools) » UMLEnvironmentFactory.EvaluationMode unresolved in OCL Console example
UMLEnvironmentFactory.EvaluationMode unresolved in OCL Console example [message #377991] Wed, 21 November 2007 18:48 Go to next message
John Yotka is currently offline John YotkaFriend
Messages: 143
Registered: July 2009
Senior Member
I downloaded the 1.2.0M3 release and created the OCL Console example.
the following line gets a "cannot be resolved" error. In looking at the
source for UMLEnvironmentFactory I don't see the EvaluationMode or the
setEvaluationMode method.

factory.setEvaluationMode(UMLEnvironmentFactory.EvaluationMo de.RUNTIME_OBJECTS);
Re: UMLEnvironmentFactory.EvaluationMode unresolved in OCL Console example [message #377992 is a reply to message #377991] Wed, 21 November 2007 19:20 Go to previous messageGo to next message
Kenn Hussey is currently offline Kenn HusseyFriend
Messages: 1618
Registered: July 2009
Senior Member
John,

This is a question for the OCL newsgroup (copied).

Kenn

"John Yotka" <john.yotka@datria.com> wrote in message
news:fi1uhd$o7b$1@build.eclipse.org...
>I downloaded the 1.2.0M3 release and created the OCL Console example. the
>following line gets a "cannot be resolved" error. In looking at the source
>for UMLEnvironmentFactory I don't see the EvaluationMode or the
>setEvaluationMode method.
>
> factory.setEvaluationMode(UMLEnvironmentFactory.EvaluationMo de.RUNTIME_OBJECTS);
Re: UMLEnvironmentFactory.EvaluationMode unresolved in OCL Console example [message #377993 is a reply to message #377992] Wed, 21 November 2007 22:40 Go to previous message
Eclipse UserFriend
Originally posted by: cdamus.ca.ibm.com

Hi, John,

I just downloaded the OCL 1.2 M3 SDK and created the console example in my
workspace. I don't see any compile errors.

How did you install the SDK?

There was a brief interval of flux in this API during M3 development, but it
looks like the milestone build lines up. Perhaps you somehow got the wrong
version of the SDK examples?

Cheers,

Christian


Kenn Hussey wrote:

> John,
>
> This is a question for the OCL newsgroup (copied).
>
> Kenn
>
> "John Yotka" <john.yotka@datria.com> wrote in message
> news:fi1uhd$o7b$1@build.eclipse.org...
>>I downloaded the 1.2.0M3 release and created the OCL Console example. the
>>following line gets a "cannot be resolved" error. In looking at the
>>source for UMLEnvironmentFactory I don't see the EvaluationMode or the
>>setEvaluationMode method.
>>
>>
factory.setEvaluationMode(UMLEnvironmentFactory.EvaluationMo de.RUNTIME_OBJECTS);
Re: UMLEnvironmentFactory.EvaluationMode unresolved in OCL Console example [message #578520 is a reply to message #377991] Wed, 21 November 2007 19:20 Go to previous message
Kenn Hussey is currently offline Kenn HusseyFriend
Messages: 1618
Registered: July 2009
Senior Member
John,

This is a question for the OCL newsgroup (copied).

Kenn

"John Yotka" <john.yotka@datria.com> wrote in message
news:fi1uhd$o7b$1@build.eclipse.org...
>I downloaded the 1.2.0M3 release and created the OCL Console example. the
>following line gets a "cannot be resolved" error. In looking at the source
>for UMLEnvironmentFactory I don't see the EvaluationMode or the
>setEvaluationMode method.
>
> factory.setEvaluationMode(UMLEnvironmentFactory.EvaluationMo de.RUNTIME_OBJECTS);
Re: UMLEnvironmentFactory.EvaluationMode unresolved in OCL Console example [message #578534 is a reply to message #377992] Wed, 21 November 2007 22:40 Go to previous message
Eclipse UserFriend
Originally posted by: cdamus.ca.ibm.com

Hi, John,

I just downloaded the OCL 1.2 M3 SDK and created the console example in my
workspace. I don't see any compile errors.

How did you install the SDK?

There was a brief interval of flux in this API during M3 development, but it
looks like the milestone build lines up. Perhaps you somehow got the wrong
version of the SDK examples?

Cheers,

Christian


Kenn Hussey wrote:

> John,
>
> This is a question for the OCL newsgroup (copied).
>
> Kenn
>
> "John Yotka" <john.yotka@datria.com> wrote in message
> news:fi1uhd$o7b$1@build.eclipse.org...
>>I downloaded the 1.2.0M3 release and created the OCL Console example. the
>>following line gets a "cannot be resolved" error. In looking at the
>>source for UMLEnvironmentFactory I don't see the EvaluationMode or the
>>setEvaluationMode method.
>>
>>
factory.setEvaluationMode(UMLEnvironmentFactory.EvaluationMo de.RUNTIME_OBJECTS);
Previous Topic:UMLEnvironmentFactory.EvaluationMode unresolved in OCL Console example
Next Topic:Domain specific view on uml model
Goto Forum:
  


Current Time: Sat Dec 20 15:56:35 GMT 2014

Powered by FUDForum. Page generated in 0.02123 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software