Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMT (Generative Modeling Technologies) » [OAW] import of an ecore MM in XPAND template
[OAW] import of an ecore MM in XPAND template [message #376872] Tue, 24 April 2007 04:27 Go to next message
Sylvain is currently offline Sylvain
Messages: 40
Registered: July 2009
Member
Hi All,

I'm trying OAW for java code generation from a model that conforms to a
metamodel written in ecore. Everything work fine when the metamodel is
in the same folder as the xpand template, but I don't know how to
import this MM if it is defined in another eclipse plugin. I've tried
to add dependencies, to change the build path, to import the model
using his nsURI just as gmf do, but nothing work, it can't find the
metamodel...

Please Help !
Sylvain

--
Sylvain
Re: [OAW] import of an ecore MM in XPAND template [message #376873 is a reply to message #376872] Tue, 24 April 2007 04:30 Go to previous message
Sylvain is currently offline Sylvain
Messages: 40
Registered: July 2009
Member
Oups it seems that i'm not totally awaked: the response is in a
previous post. sorry


> Hi All,
>
> I'm trying OAW for java code generation from a model that conforms to a
> metamodel written in ecore. Everything work fine when the metamodel is in the
> same folder as the xpand template, but I don't know how to import this MM if
> it is defined in another eclipse plugin. I've tried to add dependencies, to
> change the build path, to import the model using his nsURI just as gmf do,
> but nothing work, it can't find the metamodel...
>
> Please Help !
> Sylvain

--
Sylvain
Re: [OAW] import of an ecore MM in XPAND template [message #580477 is a reply to message #376872] Tue, 24 April 2007 04:30 Go to previous message
Sylvain is currently offline Sylvain
Messages: 40
Registered: July 2009
Member
Oups it seems that i'm not totally awaked: the response is in a
previous post. sorry


> Hi All,
>
> I'm trying OAW for java code generation from a model that conforms to a
> metamodel written in ecore. Everything work fine when the metamodel is in the
> same folder as the xpand template, but I don't know how to import this MM if
> it is defined in another eclipse plugin. I've tried to add dependencies, to
> change the build path, to import the model using his nsURI just as gmf do,
> but nothing work, it can't find the metamodel...
>
> Please Help !
> Sylvain

--
Sylvain
Previous Topic:[OAW] import of an ecore MM in XPAND template
Next Topic:[TCS] About MetaModels used for injection
Goto Forum:
  


Current Time: Sat Apr 19 18:32:51 EDT 2014

Powered by FUDForum. Page generated in 0.01545 seconds