Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Service Oriented Architecture Tools Platform (STP) » SOPERA Validation: XSD Validation: cvc-elt.1: Cannot find the declaration of element 'wsp:Policy'.
SOPERA Validation: XSD Validation: cvc-elt.1: Cannot find the declaration of element 'wsp:Policy'. [message #375074] Tue, 19 May 2009 16:07 Go to next message
Juan Pedro Silva is currently offline Juan Pedro Silva
Messages: 258
Registered: July 2009
Senior Member
This is a multi-part message in MIME format.
--------------040808060709000805020103
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit

Hi everybody, back again.
I'm trying to use STP`s Policy editor and Policy Validator (I'm new to
all this, so please apologize me if I'm asking basic stuff).
However, I'm having problems while validating even the simplest of
policy documents (no matter if created by the wizard or downloaded from
the Internet).
The error I'm getting is:

SOPERA Validation: XSD Validation: ['org.xml.sax.SAXParseException:
cvc-elt.1: Cannot find the declaration of element 'wsp:Policy'.']

It looks like an Internet connection issue, but eclipse connects
perfectly to the Internet, and the rest of the validators work fine (XSD
and WSDL validators work ok). I even downloaded the policy schema and
added it to the XML Catalog, and I'm still getting the same error message.
Does anybody have any ideas on the reason/solution for this?.
Thanks in advance.
Regards,
Juan Pedro

--------------040808060709000805020103
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
</head>
<body bgcolor="#ffffff" text="#000000">
Hi everybody, back again.<br>
I'm trying to use STP`s Policy editor and Policy Validator (I'm new to
all this, so please apologize me if I'm asking basic stuff).<br>
However, I'm having problems while validating even the simplest of
policy documents (no matter if created by the wizard or downloaded from
the Internet).<br>
The error I'm getting is:<br>
<br>
<font color="#ff0000"><font face="Courier">SOPERA Validation: XSD
Validation: ['org.xml.sax.SAXParseException: cvc-elt.1: Cannot find the
declaration of element 'wsp:Policy'.']</font><br>
<br>
<font color="#000000">It looks like an Internet connection issue, but
eclipse connects perfectly to the Internet, and the rest of the
validators work fine (XSD and WSDL validators work ok). I even
downloaded the policy schema and added it to the XML Catalog, and I'm
still getting the same error message.<br>
Does anybody have any ideas on the reason/solution for this?.<br>
Thanks in advance.<br>
Regards,<br>
&nbsp;&nbsp;&nbsp; &nbsp;&nbsp; &nbsp;&nbsp; &nbsp;&nbsp;&nbsp; Juan Pedro<br>
</font></font>
</body>
</html>

--------------040808060709000805020103--
Re: SOPERA Validation: XSD Validation: cvc-elt.1: Cannot find the declaration of element 'wsp:Policy [message #375075 is a reply to message #375074] Wed, 20 May 2009 08:00 Go to previous messageGo to next message
Eclipse User
Originally posted by: formatzeh.gmx.de

Hola Juan ;)
recently I had a similar problem. But directly with the SOPERA-Platform
(which uses STP as well). Maybe you find this thread useful:
http://forum.sopera.com/showthread.php?t=47

regards
Gilbert

Juan Pedro Silva schrieb:
> Hi everybody, back again.
> I'm trying to use STP`s Policy editor and Policy Validator (I'm new to
> all this, so please apologize me if I'm asking basic stuff).
> However, I'm having problems while validating even the simplest of
> policy documents (no matter if created by the wizard or downloaded from
> the Internet).
> The error I'm getting is:
>
> SOPERA Validation: XSD Validation: ['org.xml.sax.SAXParseException:
> cvc-elt.1: Cannot find the declaration of element 'wsp:Policy'.']
>
> It looks like an Internet connection issue, but eclipse connects
> perfectly to the Internet, and the rest of the validators work fine (XSD
> and WSDL validators work ok). I even downloaded the policy schema and
> added it to the XML Catalog, and I'm still getting the same error message.
> Does anybody have any ideas on the reason/solution for this?.
> Thanks in advance.
> Regards,
> Juan Pedro
>
Re: SOPERA Validation: XSD Validation: cvc-elt.1: Cannot find the declaration of element 'wsp:Policy [message #375076 is a reply to message #375075] Thu, 21 May 2009 10:15 Go to previous messageGo to next message
Juan Pedro Silva is currently offline Juan Pedro Silva
Messages: 258
Registered: July 2009
Senior Member
Gilbert, thank you very much for your answer.
Cheers,
Juan Pedro

Gilbert Mirenque escribió:
> Hola Juan ;)
> recently I had a similar problem. But directly with the SOPERA-Platform
> (which uses STP as well). Maybe you find this thread useful:
> http://forum.sopera.com/showthread.php?t=47
>
> regards
> Gilbert
>
> Juan Pedro Silva schrieb:
>
>> Hi everybody, back again.
>> I'm trying to use STP`s Policy editor and Policy Validator (I'm new to
>> all this, so please apologize me if I'm asking basic stuff).
>> However, I'm having problems while validating even the simplest of
>> policy documents (no matter if created by the wizard or downloaded from
>> the Internet).
>> The error I'm getting is:
>>
>> SOPERA Validation: XSD Validation: ['org.xml.sax.SAXParseException:
>> cvc-elt.1: Cannot find the declaration of element 'wsp:Policy'.']
>>
>> It looks like an Internet connection issue, but eclipse connects
>> perfectly to the Internet, and the rest of the validators work fine (XSD
>> and WSDL validators work ok). I even downloaded the policy schema and
>> added it to the XML Catalog, and I'm still getting the same error message.
>> Does anybody have any ideas on the reason/solution for this?.
>> Thanks in advance.
>> Regards,
>> Juan Pedro
>>
>>
Re: SOPERA Validation: XSD Validation: cvc-elt.1: Cannot find the declaration of element 'wsp:Policy [message #483628 is a reply to message #375076] Wed, 02 September 2009 11:50 Go to previous message
Juan Pedro Silva is currently offline Juan Pedro Silva
Messages: 258
Registered: July 2009
Senior Member
Hi everybody, back again.
I checked the thread referred-to by Gilbert with no luck (it relates to
schema imports, which is not my case).
Does anyone know which could be the reason for this error?:

SOPERA Validation: XSD Validation: ['org.xml.sax.SAXParseException:
cvc-elt.1: Cannot find the declaration of element 'wsp:Policy'.']

As I said, I get it even in the simplest of policy documents (no matter
if created by the wizard or downloaded from
the Internet).
Hope you could help me.
Best regards,
Juan Pedro

Juan Pedro Silva escribió:
> Gilbert, thank you very much for your answer.
> Cheers,
> Juan Pedro
>
> Gilbert Mirenque escribió:
>> Hola Juan ;)
>> recently I had a similar problem. But directly with the SOPERA-Platform
>> (which uses STP as well). Maybe you find this thread useful:
>> http://forum.sopera.com/showthread.php?t=47
>>
>> regards
>> Gilbert
>>
>> Juan Pedro Silva schrieb:
>>
>>> Hi everybody, back again.
>>> I'm trying to use STP`s Policy editor and Policy Validator (I'm new to
>>> all this, so please apologize me if I'm asking basic stuff).
>>> However, I'm having problems while validating even the simplest of
>>> policy documents (no matter if created by the wizard or downloaded from
>>> the Internet).
>>> The error I'm getting is:
>>>
>>> SOPERA Validation: XSD Validation: ['org.xml.sax.SAXParseException:
>>> cvc-elt.1: Cannot find the declaration of element 'wsp:Policy'.']
>>>
>>> It looks like an Internet connection issue, but eclipse connects
>>> perfectly to the Internet, and the rest of the validators work fine
>>> (XSD
>>> and WSDL validators work ok). I even downloaded the policy schema and
>>> added it to the XML Catalog, and I'm still getting the same error
>>> message.
>>> Does anybody have any ideas on the reason/solution for this?.
>>> Thanks in advance.
>>> Regards,
>>> Juan Pedro
>>>
>>>
Re: SOPERA Validation: XSD Validation: cvc-elt.1: Cannot find the declaration of element 'wsp:Policy [message #621206 is a reply to message #375074] Wed, 20 May 2009 08:00 Go to previous message
Eclipse User
Originally posted by: formatzeh.gmx.de

Hola Juan ;)
recently I had a similar problem. But directly with the SOPERA-Platform
(which uses STP as well). Maybe you find this thread useful:
http://forum.sopera.com/showthread.php?t=47

regards
Gilbert

Juan Pedro Silva schrieb:
> Hi everybody, back again.
> I'm trying to use STP`s Policy editor and Policy Validator (I'm new to
> all this, so please apologize me if I'm asking basic stuff).
> However, I'm having problems while validating even the simplest of
> policy documents (no matter if created by the wizard or downloaded from
> the Internet).
> The error I'm getting is:
>
> SOPERA Validation: XSD Validation: ['org.xml.sax.SAXParseException:
> cvc-elt.1: Cannot find the declaration of element 'wsp:Policy'.']
>
> It looks like an Internet connection issue, but eclipse connects
> perfectly to the Internet, and the rest of the validators work fine (XSD
> and WSDL validators work ok). I even downloaded the policy schema and
> added it to the XML Catalog, and I'm still getting the same error message.
> Does anybody have any ideas on the reason/solution for this?.
> Thanks in advance.
> Regards,
> Juan Pedro
>
Re: SOPERA Validation: XSD Validation: cvc-elt.1: Cannot find the declaration of element 'wsp:Policy [message #621207 is a reply to message #375075] Thu, 21 May 2009 10:15 Go to previous message
Juan Pedro Silva is currently offline Juan Pedro Silva
Messages: 258
Registered: July 2009
Senior Member
Gilbert, thank you very much for your answer.
Cheers,
Juan Pedro

Gilbert Mirenque escribió:
> Hola Juan ;)
> recently I had a similar problem. But directly with the SOPERA-Platform
> (which uses STP as well). Maybe you find this thread useful:
> http://forum.sopera.com/showthread.php?t=47
>
> regards
> Gilbert
>
> Juan Pedro Silva schrieb:
>
>> Hi everybody, back again.
>> I'm trying to use STP`s Policy editor and Policy Validator (I'm new to
>> all this, so please apologize me if I'm asking basic stuff).
>> However, I'm having problems while validating even the simplest of
>> policy documents (no matter if created by the wizard or downloaded from
>> the Internet).
>> The error I'm getting is:
>>
>> SOPERA Validation: XSD Validation: ['org.xml.sax.SAXParseException:
>> cvc-elt.1: Cannot find the declaration of element 'wsp:Policy'.']
>>
>> It looks like an Internet connection issue, but eclipse connects
>> perfectly to the Internet, and the rest of the validators work fine (XSD
>> and WSDL validators work ok). I even downloaded the policy schema and
>> added it to the XML Catalog, and I'm still getting the same error message.
>> Does anybody have any ideas on the reason/solution for this?.
>> Thanks in advance.
>> Regards,
>> Juan Pedro
>>
>>
Re: SOPERA Validation: XSD Validation: cvc-elt.1: Cannot find the declaration of element 'wsp:Policy [message #621222 is a reply to message #375076] Wed, 02 September 2009 11:50 Go to previous message
Juan Pedro Silva is currently offline Juan Pedro Silva
Messages: 258
Registered: July 2009
Senior Member
Hi everybody, back again.
I checked the thread referred-to by Gilbert with no luck (it relates to
schema imports, which is not my case).
Does anyone know which could be the reason for this error?:

SOPERA Validation: XSD Validation: ['org.xml.sax.SAXParseException:
cvc-elt.1: Cannot find the declaration of element 'wsp:Policy'.']

As I said, I get it even in the simplest of policy documents (no matter
if created by the wizard or downloaded from
the Internet).
Hope you could help me.
Best regards,
Juan Pedro

Juan Pedro Silva escribió:
> Gilbert, thank you very much for your answer.
> Cheers,
> Juan Pedro
>
> Gilbert Mirenque escribió:
>> Hola Juan ;)
>> recently I had a similar problem. But directly with the SOPERA-Platform
>> (which uses STP as well). Maybe you find this thread useful:
>> http://forum.sopera.com/showthread.php?t=47
>>
>> regards
>> Gilbert
>>
>> Juan Pedro Silva schrieb:
>>
>>> Hi everybody, back again.
>>> I'm trying to use STP`s Policy editor and Policy Validator (I'm new to
>>> all this, so please apologize me if I'm asking basic stuff).
>>> However, I'm having problems while validating even the simplest of
>>> policy documents (no matter if created by the wizard or downloaded from
>>> the Internet).
>>> The error I'm getting is:
>>>
>>> SOPERA Validation: XSD Validation: ['org.xml.sax.SAXParseException:
>>> cvc-elt.1: Cannot find the declaration of element 'wsp:Policy'.']
>>>
>>> It looks like an Internet connection issue, but eclipse connects
>>> perfectly to the Internet, and the rest of the validators work fine
>>> (XSD
>>> and WSDL validators work ok). I even downloaded the policy schema and
>>> added it to the XML Catalog, and I'm still getting the same error
>>> message.
>>> Does anybody have any ideas on the reason/solution for this?.
>>> Thanks in advance.
>>> Regards,
>>> Juan Pedro
>>>
>>>
Previous Topic:Is BPMN and BPEL the right choice for my problem?
Next Topic:SVN access.
Goto Forum:
  


Current Time: Mon Sep 22 10:12:57 GMT 2014

Powered by FUDForum. Page generated in 0.15542 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software