Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Service Oriented Architecture Tools Platform (STP) » B2J execution fails
B2J execution fails [message #374112] Wed, 04 July 2007 08:55 Go to next message
Krassimir Kondarev is currently offline Krassimir KondarevFriend
Messages: 32
Registered: July 2009
Member
Hi all,

I am trying to run the example B2J from the beginners tutorial with the
last Europa release. When executing, I get the following error message:

An internal error occurred during: "Launching B2J_Test".
Lbpel_3_1183539276983/xmlns/http___www_eclipse_org_stp_b2j_2 006_02/_Address;

And in the error log is this stack trace:

java.lang.NoClassDefFoundError:
Lbpel_2_1183539076745/xmlns/http___www_eclipse_org_stp_b2j_2 006_02/_Address;
at java.lang.Class.getDeclaredFields0(Native Method)
at java.lang.Class.privateGetDeclaredFields(Class.java:2232)
at java.lang.Class.getDeclaredField(Class.java:1852)
at
org.eclipse.stp.b2j.core.jengine.internal.miniengine.MiniCon troller.launchRunner(MiniController.java:368)
at
org.eclipse.stp.b2j.core.jengine.internal.miniengine.MiniCon troller.launchRunner(MiniController.java:345)
at
org.eclipse.stp.b2j.core.publicapi.engine.WorkbenchBPELEngin e.runInternal(WorkbenchBPELEngine.java:509)
at
org.eclipse.stp.b2j.core.publicapi.engine.WorkbenchBPELEngin e.runProgram(WorkbenchBPELEngine.java:139)
at
org.eclipse.stp.b2j.core.publicapi.engine.WorkbenchBPELEngin e.runProgram(WorkbenchBPELEngine.java:125)
at
org.eclipse.stp.b2j.ui.internal.launchconfig.LaunchConfigDel egate.launch(LaunchConfigDelegate.java:304)
at
org.eclipse.debug.internal.core.LaunchConfiguration.launch(L aunchConfiguration.java:766)
at
org.eclipse.debug.internal.core.LaunchConfiguration.launch(L aunchConfiguration.java:608)
at
org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(D ebugUIPlugin.java:899)
at
org.eclipse.debug.internal.ui.DebugUIPlugin$7.run(DebugUIPlu gin.java:1102)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

Any ideas?

Cheers,
Krassimir
Re: B2J execution fails [message #374221 is a reply to message #374112] Tue, 04 September 2007 13:11 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: steenbrahe.gmail.com

Hi,

I get the exact same failure as Krassimir when I follow the B2J tutorial
and executes the example bpel file. The concole output that is written
before the error dialog appears can be seen below.
I am using the Eclipse 3.3 Europa distribution.

Do anyone have a solution to the problem - it will be highly appriciated:o)

Cheers

Steen

CONSOLE OUTPUT:
BPEL File: test_general.bpel
Generating engine program...

XSD Translator: ignored element [complexType]
Java Binding: : WSIF Java Binding return type required but no return
type specified
Java Binding: : WSIF Java Binding return type required but no return
type specified
XSDTranslator: UNIMPLEMENTED: unable to map top level elements to types
(null)
XSDTranslator: making direct alias from
http://www.eclipse.org/stp/b2j/2006/02:Address to
http://www.eclipse.org/stp/b2j/2006/02:Address

Generated engine program (3sec)

Connecting to engine daemon...
Connecting to in-jvm mini engine daemon
Connected to engine daemon (0sec)

Creating engine instance...
Created engine instance (0sec)

Setting engine program...
Set engine program (0sec)

Turning on only warning and error logging

Total launch time 3sec

Launching engine program
Re: B2J execution fails [message #374326 is a reply to message #374221] Wed, 24 October 2007 12:13 Go to previous message
Eclipse UserFriend
Originally posted by: antony.scapatech.com

Bug 207289 reported in Bugzilla to address this issue:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=207289

A fix has been checked into CVS HEAD and the B2J in-jvm engine should
again be able to run the same sample files as the distributed engine.

It is worth mentioning though that some of the sample files are out of
date and do not work - such as the test_messaging.bpel sample file.

I have reported a new bug (207291) for this:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=207291

thanks

Antony

Georgiew, Emanuel wrote:
> Hi!
>
> Try selecting the distributed execution environment instead of the
> localhost option, when configuring the "Run As" dialogue ... There
> should be an entry for the localhost machine too. This worked for me for
> most of the examples.
>
> Kind regards,
> Emanuel
>
>
> On Tue, 04 Sep 2007 15:11:23 +0200, Steen Brahe <steenbrahe@gmail.com>
> wrote:
>
>> Hi,
>>
>> I get the exact same failure as Krassimir when I follow the B2J
>> tutorial and executes the example bpel file. The concole output that
>> is written before the error dialog appears can be seen below.
>> I am using the Eclipse 3.3 Europa distribution.
>>
>> Do anyone have a solution to the problem - it will be highly
>> appriciated:o)
>>
>> Cheers
>>
>> Steen
>>
>> CONSOLE OUTPUT:
>> BPEL File: test_general.bpel
>> Generating engine program...
>>
>> XSD Translator: ignored element [complexType]
>> Java Binding: : WSIF Java Binding return type required but no return
>> type specified
>> Java Binding: : WSIF Java Binding return type required but no return
>> type specified
>> XSDTranslator: UNIMPLEMENTED: unable to map top level elements to
>> types (null)
>> XSDTranslator: making direct alias from
>> http://www.eclipse.org/stp/b2j/2006/02:Address to
>> http://www.eclipse.org/stp/b2j/2006/02:Address
>>
>> Generated engine program (3sec)
>>
>> Connecting to engine daemon...
>> Connecting to in-jvm mini engine daemon
>> Connected to engine daemon (0sec)
>>
>> Creating engine instance...
>> Created engine instance (0sec)
>>
>> Setting engine program...
>> Set engine program (0sec)
>>
>> Turning on only warning and error logging
>>
>> Total launch time 3sec
>>
>> Launching engine program
>
>
>
Re: B2J execution fails [message #593028 is a reply to message #374112] Tue, 04 September 2007 13:11 Go to previous message
Eclipse UserFriend
Originally posted by: steenbrahe.gmail.com

Hi,

I get the exact same failure as Krassimir when I follow the B2J tutorial
and executes the example bpel file. The concole output that is written
before the error dialog appears can be seen below.
I am using the Eclipse 3.3 Europa distribution.

Do anyone have a solution to the problem - it will be highly appriciated:o)

Cheers

Steen

CONSOLE OUTPUT:
BPEL File: test_general.bpel
Generating engine program...

XSD Translator: ignored element [complexType]
Java Binding: : WSIF Java Binding return type required but no return
type specified
Java Binding: : WSIF Java Binding return type required but no return
type specified
XSDTranslator: UNIMPLEMENTED: unable to map top level elements to types
(null)
XSDTranslator: making direct alias from
http://www.eclipse.org/stp/b2j/2006/02:Address to
http://www.eclipse.org/stp/b2j/2006/02:Address

Generated engine program (3sec)

Connecting to engine daemon...
Connecting to in-jvm mini engine daemon
Connected to engine daemon (0sec)

Creating engine instance...
Created engine instance (0sec)

Setting engine program...
Set engine program (0sec)

Turning on only warning and error logging

Total launch time 3sec

Launching engine program
Re: B2J execution fails [message #594041 is a reply to message #374221] Wed, 03 October 2007 17:24 Go to previous message
Eclipse UserFriend
Originally posted by: georgiew.emanuel.alice-dsl.net

Hi!

Try selecting the distributed execution environment instead of the
localhost option, when configuring the "Run As" dialogue ... There should
be an entry for the localhost machine too. This worked for me for most of
the examples.

Kind regards,
Emanuel


On Tue, 04 Sep 2007 15:11:23 +0200, Steen Brahe <steenbrahe@gmail.com>
wrote:

> Hi,
>
> I get the exact same failure as Krassimir when I follow the B2J tutorial
> and executes the example bpel file. The concole output that is written
> before the error dialog appears can be seen below.
> I am using the Eclipse 3.3 Europa distribution.
>
> Do anyone have a solution to the problem - it will be highly
> appriciated:o)
>
> Cheers
>
> Steen
>
> CONSOLE OUTPUT:
> BPEL File: test_general.bpel
> Generating engine program...
>
> XSD Translator: ignored element [complexType]
> Java Binding: : WSIF Java Binding return type required but no return
> type specified
> Java Binding: : WSIF Java Binding return type required but no return
> type specified
> XSDTranslator: UNIMPLEMENTED: unable to map top level elements to types
> (null)
> XSDTranslator: making direct alias from
> http://www.eclipse.org/stp/b2j/2006/02:Address to
> http://www.eclipse.org/stp/b2j/2006/02:Address
>
> Generated engine program (3sec)
>
> Connecting to engine daemon...
> Connecting to in-jvm mini engine daemon
> Connected to engine daemon (0sec)
>
> Creating engine instance...
> Created engine instance (0sec)
>
> Setting engine program...
> Set engine program (0sec)
>
> Turning on only warning and error logging
>
> Total launch time 3sec
>
> Launching engine program



--
Using Opera's revolutionary e-mail client: http://www.opera.com/mail/
Re: B2J execution fails [message #601179 is a reply to message #594041] Wed, 24 October 2007 12:13 Go to previous message
Antony Miguel is currently offline Antony MiguelFriend
Messages: 49
Registered: July 2009
Member
Bug 207289 reported in Bugzilla to address this issue:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=207289

A fix has been checked into CVS HEAD and the B2J in-jvm engine should
again be able to run the same sample files as the distributed engine.

It is worth mentioning though that some of the sample files are out of
date and do not work - such as the test_messaging.bpel sample file.

I have reported a new bug (207291) for this:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=207291

thanks

Antony

Georgiew, Emanuel wrote:
> Hi!
>
> Try selecting the distributed execution environment instead of the
> localhost option, when configuring the "Run As" dialogue ... There
> should be an entry for the localhost machine too. This worked for me for
> most of the examples.
>
> Kind regards,
> Emanuel
>
>
> On Tue, 04 Sep 2007 15:11:23 +0200, Steen Brahe <steenbrahe@gmail.com>
> wrote:
>
>> Hi,
>>
>> I get the exact same failure as Krassimir when I follow the B2J
>> tutorial and executes the example bpel file. The concole output that
>> is written before the error dialog appears can be seen below.
>> I am using the Eclipse 3.3 Europa distribution.
>>
>> Do anyone have a solution to the problem - it will be highly
>> appriciated:o)
>>
>> Cheers
>>
>> Steen
>>
>> CONSOLE OUTPUT:
>> BPEL File: test_general.bpel
>> Generating engine program...
>>
>> XSD Translator: ignored element [complexType]
>> Java Binding: : WSIF Java Binding return type required but no return
>> type specified
>> Java Binding: : WSIF Java Binding return type required but no return
>> type specified
>> XSDTranslator: UNIMPLEMENTED: unable to map top level elements to
>> types (null)
>> XSDTranslator: making direct alias from
>> http://www.eclipse.org/stp/b2j/2006/02:Address to
>> http://www.eclipse.org/stp/b2j/2006/02:Address
>>
>> Generated engine program (3sec)
>>
>> Connecting to engine daemon...
>> Connecting to in-jvm mini engine daemon
>> Connected to engine daemon (0sec)
>>
>> Creating engine instance...
>> Created engine instance (0sec)
>>
>> Setting engine program...
>> Set engine program (0sec)
>>
>> Turning on only warning and error logging
>>
>> Total launch time 3sec
>>
>> Launching engine program
>
>
>
Previous Topic:BPM Specification metamodels
Next Topic:B2J generated files do not compile
Goto Forum:
  


Current Time: Sat Nov 29 07:38:10 GMT 2014

Powered by FUDForum. Page generated in 0.02357 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software