Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Dynamic Languages Toolkit (DLTK) » Adding Interpreter without any libraries
Adding Interpreter without any libraries [message #37899] Thu, 04 June 2009 02:24 Go to next message
Sheela is currently offline Sheela
Messages: 52
Registered: July 2009
Member
Hi,
I am using eclipse 3.4.1 with S1.0M4 DLTK .

In my IDE whenever we add a new interpreter (fssdbg.exe) through
interpreter preference page,it throws an expception "Failed to resolve
library locations for fssdbg.exe " and gives stack trace for
"java.lang.Exception: Output:".

Here we observed that whenever we add an interpreter it tries to run the
file returned by method "createPathFile" of
AbstractInterpreterInstallType and try to resolve the library locations.

but in our case we require no libraries with our interpreter.Is there any
mechanism by which we can remove this library resolving part or handle the
errors if no libraries found?

Please Help

Regards
Sheela
Re: Adding Interpreter without any libraries [message #37933 is a reply to message #37899] Thu, 04 June 2009 03:29 Go to previous message
Alex Panchenko is currently offline Alex Panchenko
Messages: 342
Registered: July 2009
Senior Member
Hi Sheela,

E.g. you can override

public synchronized LibraryLocation[] getDefaultLibraryLocations( final
IFileHandle installLocation,
EnvironmentVariable[] variables,
IProgressMonitor monitor)

and return empty array.

I think this DLTK part should be improved, but most probably it would
happen after 1.0 release.

Regards,
Alex

Sheela wrote:
> Hi,
> I am using eclipse 3.4.1 with S1.0M4 DLTK .
>
> In my IDE whenever we add a new interpreter (fssdbg.exe) through
> interpreter preference page,it throws an expception "Failed to resolve
> library locations for fssdbg.exe " and gives stack trace for
> "java.lang.Exception: Output:".
>
> Here we observed that whenever we add an interpreter it tries to run the
> file returned by method "createPathFile" of
> AbstractInterpreterInstallType and try to resolve the library locations.
>
> but in our case we require no libraries with our interpreter.Is there
> any mechanism by which we can remove this library resolving part or
> handle the errors if no libraries found?
>
> Please Help
>
> Regards
> Sheela
>
Previous Topic:[BUILD] S-1.0RC2a-200905280900
Next Topic:Replace ExpressionList
Goto Forum:
  


Current Time: Thu Jul 31 07:43:38 EDT 2014

Powered by FUDForum. Page generated in 0.01750 seconds