Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Test Execution Error - NoClassDefFoundError
Test Execution Error - NoClassDefFoundError [message #37761] Thu, 27 October 2005 14:42 Go to next message
Alisa Smith is currently offline Alisa Smith
Messages: 6
Registered: July 2009
Junior Member
I am getting this error message when trying to run an imported Junit test
(TPTP 4.0.0 / Eclipse 3.1.0):

java.lang.NoClassDefFoundError:
com/teamcenter/bmide/tcmodel/GenericDataType

at java.lang.Class.forName0(Native Method)

at java.lang.Class.forName(Unknown Source)

at org.eclipse.hyades.test.java.runner.HyadesJUnitRunner.main

(HyadesJUnitRunner.java:124)

Can someone please provide some advise on how to fix this error? Thanks
for your help.
Re: Test Execution Error - NoClassDefFoundError [message #37833 is a reply to message #37761] Thu, 27 October 2005 15:21 Go to previous messageGo to next message
No real name is currently offline No real name
Messages: 404
Registered: July 2009
Senior Member
Did you update your Agent Controller when you obtained a copy of TPTP? It
seems that it can't find the runner that is used to execute JUnit test
suites. The runner is container in the following jar:

<AGENT-CONTROLLER-HOME>\plugins\org.eclipse.hyades.test.tools.core_4.1.0\jav
a.runner.jar

The version that appears after the plugin name may of course be different.

"Alisa Smith" <smithali@ugs.com> wrote in message
news:5db0cb47d001e547c40c2a5ce2bcdf01$1@www.eclipse.org...
> I am getting this error message when trying to run an imported Junit test
> (TPTP 4.0.0 / Eclipse 3.1.0):
>
> java.lang.NoClassDefFoundError:
> com/teamcenter/bmide/tcmodel/GenericDataType
>
> at java.lang.Class.forName0(Native Method)
>
> at java.lang.Class.forName(Unknown Source)
>
> at org.eclipse.hyades.test.java.runner.HyadesJUnitRunner.main
>
> (HyadesJUnitRunner.java:124)
>
> Can someone please provide some advise on how to fix this error? Thanks
> for your help.
>
>
Re: Test Execution Error - NoClassDefFoundError [message #37866 is a reply to message #37833] Thu, 27 October 2005 19:01 Go to previous messageGo to next message
Alisa Smith is currently offline Alisa Smith
Messages: 6
Registered: July 2009
Junior Member
I did download/installed version 4.0.0 of Agent Controller and I see that
I do have org.eclipse.hyades.test.tools.core_4.0.0 in my plugins
directory. What else could it be?

Thanks again for the help.
Re: Test Execution Error - NoClassDefFoundError [message #38218 is a reply to message #37761] Mon, 31 October 2005 14:45 Go to previous message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Hi Alisa,
This issue has since been fixed under defect
https://bugs.eclipse.org/bugs/show_bug.cgi?id=109668. Please use the latest
stable TPTP v4.1.0 build.

Paul

"Alisa Smith" <smithali@ugs.com> wrote in message
news:5db0cb47d001e547c40c2a5ce2bcdf01$1@www.eclipse.org...
> I am getting this error message when trying to run an imported Junit test
> (TPTP 4.0.0 / Eclipse 3.1.0):
>
> java.lang.NoClassDefFoundError:
> com/teamcenter/bmide/tcmodel/GenericDataType
>
> at java.lang.Class.forName0(Native Method)
>
> at java.lang.Class.forName(Unknown Source)
>
> at org.eclipse.hyades.test.java.runner.HyadesJUnitRunner.main
>
> (HyadesJUnitRunner.java:124)
>
> Can someone please provide some advise on how to fix this error? Thanks
> for your help.
>
>
Previous Topic:How to send and receive CommonBaseEvents?
Next Topic:AutoGUI and deployments
Goto Forum:
  


Current Time: Mon Oct 20 10:04:03 GMT 2014

Powered by FUDForum. Page generated in 0.07422 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software