Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » BIRT 2.3.1 using connection profile, no SQB
BIRT 2.3.1 using connection profile, no SQB [message #365747] Thu, 30 October 2008 05:01 Go to next message
Eclipse UserFriend
Originally posted by: jackh.jackh.com

I've tried with both RCP and the all-in-one. I'm creating a new dataset off
of a datasource from a connection profile. The new sql query builder (SQB)
is not there. It only has the old manual SQL entry tool. Any ideas??

Thanks
Re: BIRT 2.3.1 using connection profile, no SQB [message #365751 is a reply to message #365747] Thu, 30 October 2008 15:55 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: jasonweathersby.alltel.net

Can you try the following:
1 - create a new datasource
2 - choose the radial for create connection from connection profile
3 - Select next, then new.
4 - Choose BIRT Classic Models Sample Database
5 - Put in a file name, such as c:/tmp/myprof
6 - Finish

create a dataset and see if the SQB is available.

Jason

jackh wrote:
> I've tried with both RCP and the all-in-one. I'm creating a new dataset off
> of a datasource from a connection profile. The new sql query builder (SQB)
> is not there. It only has the old manual SQL entry tool. Any ideas??
>
> Thanks
>
>
Re: BIRT 2.3.1 using connection profile, no SQB [message #365764 is a reply to message #365751] Fri, 31 October 2008 06:08 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: jackh.jackh.com

Yes that works. My db is postgres. Is it a bug?


"Jason Weathersby" <jasonweathersby@alltel.net> wrote in message
news:geclfa$a68$1@build.eclipse.org...
> Can you try the following:
> 1 - create a new datasource
> 2 - choose the radial for create connection from connection profile
> 3 - Select next, then new.
> 4 - Choose BIRT Classic Models Sample Database
> 5 - Put in a file name, such as c:/tmp/myprof
> 6 - Finish
>
> create a dataset and see if the SQB is available.
>
> Jason
>
> jackh wrote:
>> I've tried with both RCP and the all-in-one. I'm creating a new dataset
>> off of a datasource from a connection profile. The new sql query builder
>> (SQB) is not there. It only has the old manual SQL entry tool. Any
>> ideas??
>>
>> Thanks
Re: BIRT 2.3.1 using connection profile, no SQB [message #365770 is a reply to message #365764] Fri, 31 October 2008 14:11 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: jasonweathersby.alltel.net

postgres should work as well. Can you try to open the Data Source
Explorer view:
window->show view->other->Connectivity->Data Source Explorer

and add your data source under databases. As a test supply username and
password. Once you create it swap step 4 with your new database.

Jason

jackh wrote:
> Yes that works. My db is postgres. Is it a bug?
>
>
> "Jason Weathersby" <jasonweathersby@alltel.net> wrote in message
> news:geclfa$a68$1@build.eclipse.org...
>> Can you try the following:
>> 1 - create a new datasource
>> 2 - choose the radial for create connection from connection profile
>> 3 - Select next, then new.
>> 4 - Choose BIRT Classic Models Sample Database
>> 5 - Put in a file name, such as c:/tmp/myprof
>> 6 - Finish
>>
>> create a dataset and see if the SQB is available.
>>
>> Jason
>>
>> jackh wrote:
>>> I've tried with both RCP and the all-in-one. I'm creating a new dataset
>>> off of a datasource from a connection profile. The new sql query builder
>>> (SQB) is not there. It only has the old manual SQL entry tool. Any
>>> ideas??
>>>
>>> Thanks
>
>
Re: BIRT 2.3.1 using connection profile, no SQB [message #365820 is a reply to message #365770] Wed, 05 November 2008 04:21 Go to previous message
Linda ChanFriend
Messages: 845
Registered: July 2009
Senior Member
Using the Data Source Explorer view to create a postgres connection profile
would work, but not really required.
Alternatively,
>>> 1 - create a new datasource
>>> 2 - choose the radial for create connection from connection profile
>>> 3 - Select next, then new.
>>> 4a - In the "Create a Connection Profile Store" dialog, select "New..."
>>> button
4b - In the "New Connection Profile" dialog, select PostgreSQL,
press Next to specify your JDBC driver definition and connection profile
properties. Press Finish.
4c - The connection profile that you just created is now added to
the check box list. Select the checkbox of that profile.
>>> 5 - Put in a file name, such as c:/tmp/myprof
>>> 6 - Finish

Linda

"Jason Weathersby" <jasonweathersby@alltel.net> wrote in message
news:gef3o8$oh8$1@build.eclipse.org...
> postgres should work as well. Can you try to open the Data Source
> Explorer view:
> window->show view->other->Connectivity->Data Source Explorer
>
> and add your data source under databases. As a test supply username and
> password. Once you create it swap step 4 with your new database.
>
> Jason
>
> jackh wrote:
>> Yes that works. My db is postgres. Is it a bug?
>>
>>
>> "Jason Weathersby" <jasonweathersby@alltel.net> wrote in message
>> news:geclfa$a68$1@build.eclipse.org...
>>> Can you try the following:
>>> 1 - create a new datasource
>>> 2 - choose the radial for create connection from connection profile
>>> 3 - Select next, then new.
>>> 4 - Choose BIRT Classic Models Sample Database
>>> 5 - Put in a file name, such as c:/tmp/myprof
>>> 6 - Finish
>>>
>>> create a dataset and see if the SQB is available.
>>>
>>> Jason
>>>
>>> jackh wrote:
>>>> I've tried with both RCP and the all-in-one. I'm creating a new
>>>> dataset off of a datasource from a connection profile. The new sql
>>>> query builder (SQB) is not there. It only has the old manual SQL entry
>>>> tool. Any ideas??
>>>>
>>>> Thanks
>>
Previous Topic:Get the datasource URL in the property binding ?
Next Topic:Problems providing BIRT a JDBC connection using ODA driverBridge
Goto Forum:
  


Current Time: Sun Nov 23 06:21:01 GMT 2014

Powered by FUDForum. Page generated in 0.01739 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software