Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DTP » DTP update problem with org.eclipse.datatools.doc.user
DTP update problem with org.eclipse.datatools.doc.user [message #36789] Tue, 02 October 2007 09:48 Go to next message
Eclipse User
Originally posted by: listacctc.gmail.com

I'm trying to perform an upgrade of my eclipse install. Everything went
fine except for the following error:

Data Tools Platform SQL Development Tools (1.5.1.200709261) requires
feature "org.eclipse.datatools.doc.user (1.5.1)", or later version.

When I checked the details this is what I found:

Requested operation cannot be performed because it would invalidate the
current configuration. See details for more information.

- Data Tools Platform SQL Development Tools (1.5.1.200709261) requires
feature "org.eclipse.datatools.doc.user (1.5.1)", or later version.
- Data Tools Platform SQL Development Tools Results View
(1.5.1.200709261) requires feature "org.eclipse.datatools.doc.user
(1.5.1)", or later version.
- Data Tools Platform Open Data Access Designer (1.5.1.200709261)
requires feature "org.eclipse.datatools.doc.user (1.5.1)", or later version.


Because of this problem I can't complete the DTP updates. This seems a
little strange, I just asked Eclipse to run an update. I would think
the update process would keep track of conversioning for me.

What could I have done differently? Is there a way to pick up the
necessary dependencies so I can complete the update?

Thanks for any feedback.


- Tod
Re: DTP update problem with org.eclipse.datatools.doc.user [message #36823 is a reply to message #36789] Tue, 02 October 2007 17:06 Go to previous messageGo to next message
Eclipse User
Originally posted by: john.graham.sybase.com

I tried the same and encountered the problem as well. For some reason, the
option "Search for updates of currently installed features" is not
collecting the entire DTP 1.5.1 feature set from the update site, and
hence the error.

As a work-around, I did "Search for new features to install", selected
only DTP, and it worked correctly. We'll continue to investigate why the
first option is not working, but the second option will allow you to
update your installed feature, granted with a bit more work.

HTH,
John Graham
Eclipse Data Tools Platform PMC Chair

List Acctc wrote:

> I'm trying to perform an upgrade of my eclipse install. Everything went
> fine except for the following error:

> Data Tools Platform SQL Development Tools (1.5.1.200709261) requires
> feature "org.eclipse.datatools.doc.user (1.5.1)", or later version.

> When I checked the details this is what I found:

> Requested operation cannot be performed because it would invalidate the
> current configuration. See details for more information.

> - Data Tools Platform SQL Development Tools (1.5.1.200709261) requires
> feature "org.eclipse.datatools.doc.user (1.5.1)", or later version.
> - Data Tools Platform SQL Development Tools Results View
> (1.5.1.200709261) requires feature "org.eclipse.datatools.doc.user
> (1.5.1)", or later version.
> - Data Tools Platform Open Data Access Designer (1.5.1.200709261)
> requires feature "org.eclipse.datatools.doc.user (1.5.1)", or later version.


> Because of this problem I can't complete the DTP updates. This seems a
> little strange, I just asked Eclipse to run an update. I would think
> the update process would keep track of conversioning for me.

> What could I have done differently? Is there a way to pick up the
> necessary dependencies so I can complete the update?

> Thanks for any feedback.


> - Tod
Re: DTP update problem with org.eclipse.datatools.doc.user [message #36925 is a reply to message #36823] Wed, 03 October 2007 12:28 Go to previous message
Eclipse User
Originally posted by: listacctc.gmail.com

That worked great John, thanks for the assist.

Regards,

Tod

John Graham wrote:
> I tried the same and encountered the problem as well. For some reason,
> the option "Search for updates of currently installed features" is not
> collecting the entire DTP 1.5.1 feature set from the update site, and
> hence the error.
> As a work-around, I did "Search for new features to install", selected
> only DTP, and it worked correctly. We'll continue to investigate why the
> first option is not working, but the second option will allow you to
> update your installed feature, granted with a bit more work.
>
> HTH,
> John Graham
> Eclipse Data Tools Platform PMC Chair
>
> List Acctc wrote:
>
>> I'm trying to perform an upgrade of my eclipse install. Everything
>> went fine except for the following error:
>
>> Data Tools Platform SQL Development Tools (1.5.1.200709261) requires
>> feature "org.eclipse.datatools.doc.user (1.5.1)", or later version.
>
>> When I checked the details this is what I found:
>
>> Requested operation cannot be performed because it would invalidate
>> the current configuration. See details for more information.
>
>> - Data Tools Platform SQL Development Tools (1.5.1.200709261) requires
>> feature "org.eclipse.datatools.doc.user (1.5.1)", or later version.
>> - Data Tools Platform SQL Development Tools Results View
>> (1.5.1.200709261) requires feature "org.eclipse.datatools.doc.user
>> (1.5.1)", or later version.
>> - Data Tools Platform Open Data Access Designer (1.5.1.200709261)
>> requires feature "org.eclipse.datatools.doc.user (1.5.1)", or later
>> version.
>
>
>> Because of this problem I can't complete the DTP updates. This seems
>> a little strange, I just asked Eclipse to run an update. I would
>> think the update process would keep track of conversioning for me.
>
>> What could I have done differently? Is there a way to pick up the
>> necessary dependencies so I can complete the update?
>
>> Thanks for any feedback.
>
>
>> - Tod
>
>
Re: DTP update problem with org.eclipse.datatools.doc.user [message #588052 is a reply to message #36789] Tue, 02 October 2007 17:06 Go to previous message
John Graham is currently offline John Graham
Messages: 183
Registered: July 2009
Senior Member
I tried the same and encountered the problem as well. For some reason, the
option "Search for updates of currently installed features" is not
collecting the entire DTP 1.5.1 feature set from the update site, and
hence the error.

As a work-around, I did "Search for new features to install", selected
only DTP, and it worked correctly. We'll continue to investigate why the
first option is not working, but the second option will allow you to
update your installed feature, granted with a bit more work.

HTH,
John Graham
Eclipse Data Tools Platform PMC Chair

List Acctc wrote:

> I'm trying to perform an upgrade of my eclipse install. Everything went
> fine except for the following error:

> Data Tools Platform SQL Development Tools (1.5.1.200709261) requires
> feature "org.eclipse.datatools.doc.user (1.5.1)", or later version.

> When I checked the details this is what I found:

> Requested operation cannot be performed because it would invalidate the
> current configuration. See details for more information.

> - Data Tools Platform SQL Development Tools (1.5.1.200709261) requires
> feature "org.eclipse.datatools.doc.user (1.5.1)", or later version.
> - Data Tools Platform SQL Development Tools Results View
> (1.5.1.200709261) requires feature "org.eclipse.datatools.doc.user
> (1.5.1)", or later version.
> - Data Tools Platform Open Data Access Designer (1.5.1.200709261)
> requires feature "org.eclipse.datatools.doc.user (1.5.1)", or later version.


> Because of this problem I can't complete the DTP updates. This seems a
> little strange, I just asked Eclipse to run an update. I would think
> the update process would keep track of conversioning for me.

> What could I have done differently? Is there a way to pick up the
> necessary dependencies so I can complete the update?

> Thanks for any feedback.


> - Tod
Re: DTP update problem with org.eclipse.datatools.doc.user [message #588079 is a reply to message #36823] Wed, 03 October 2007 12:28 Go to previous message
Eclipse User
Originally posted by: listacctc.gmail.com

That worked great John, thanks for the assist.

Regards,

Tod

John Graham wrote:
> I tried the same and encountered the problem as well. For some reason,
> the option "Search for updates of currently installed features" is not
> collecting the entire DTP 1.5.1 feature set from the update site, and
> hence the error.
> As a work-around, I did "Search for new features to install", selected
> only DTP, and it worked correctly. We'll continue to investigate why the
> first option is not working, but the second option will allow you to
> update your installed feature, granted with a bit more work.
>
> HTH,
> John Graham
> Eclipse Data Tools Platform PMC Chair
>
> List Acctc wrote:
>
>> I'm trying to perform an upgrade of my eclipse install. Everything
>> went fine except for the following error:
>
>> Data Tools Platform SQL Development Tools (1.5.1.200709261) requires
>> feature "org.eclipse.datatools.doc.user (1.5.1)", or later version.
>
>> When I checked the details this is what I found:
>
>> Requested operation cannot be performed because it would invalidate
>> the current configuration. See details for more information.
>
>> - Data Tools Platform SQL Development Tools (1.5.1.200709261) requires
>> feature "org.eclipse.datatools.doc.user (1.5.1)", or later version.
>> - Data Tools Platform SQL Development Tools Results View
>> (1.5.1.200709261) requires feature "org.eclipse.datatools.doc.user
>> (1.5.1)", or later version.
>> - Data Tools Platform Open Data Access Designer (1.5.1.200709261)
>> requires feature "org.eclipse.datatools.doc.user (1.5.1)", or later
>> version.
>
>
>> Because of this problem I can't complete the DTP updates. This seems
>> a little strange, I just asked Eclipse to run an update. I would
>> think the update process would keep track of conversioning for me.
>
>> What could I have done differently? Is there a way to pick up the
>> necessary dependencies so I can complete the update?
>
>> Thanks for any feedback.
>
>
>> - Tod
>
>
Previous Topic:DTP update problem with org.eclipse.datatools.doc.user
Next Topic:dtp 1.6M2?
Goto Forum:
  


Current Time: Wed Apr 16 00:43:35 EDT 2014

Powered by FUDForum. Page generated in 0.10531 seconds