Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » OHF » bridge using registry url instead of repository url
bridge using registry url instead of repository url [message #36550] Thu, 08 November 2007 21:34 Go to next message
Jesse Pangburn is currently offline Jesse Pangburn
Messages: 166
Registered: July 2009
Senior Member
Hi,
I'm trying to test 11746 which is the XDS provide and registry
transaction. However, it appears that the bridge is using the registry
url instead of the repository url. The following is a relevant snippet
from the bridge's log where it examines my rhioConfig.xml and displays the
config info:

mXdsRepositoryConfig=[{mesa=XdsRepositoryConfig ( XDS Type=[a]
retrieveUrl=[null] provideRegisterUrl=[IheUri (
mUnsecured=[http://129.6.24.109:9080/axis2/services/repositoryAonedoc]
mSecured=[null] )] )}]

mXdsRegistryConfig=[XdsRegistryConfig ( XDS Type=[a]
nonStoredQueryUrl=[IheUri (
mUnsecured=[http://129.6.24.109:9080/axis2/services/xdsregistrya]
mSecured=[null] )] storedQueriesUrl=[IheUri (
mUnsecured=[http://129.6.24.109:9080/axis2/services/xdsregistryb]
mSecured=[null] )]

And then there's the part where it logs where the transaction is actually
being sent to (from a couple different sections of the log in case it was
just one wrong print statement):
[INFO ][2007-11-08T12:15:39.067-0800][ipse.ohf.ihe.xds.source.Sour ce]
Submitting Provide and Register Document Set transaction to Repository:
http://129.6.24.109:9080/axis2/services/xdsregistrya

[DEBUG][2007-11-08T12:15:40.379-0800][httpclient.wire.header ] >>
"POST /axis2/services/xdsregistrya HTTP/1.1[\r][\n]"

You can see the url listed there is from the registry's nonStoredQueryUrl
parameter, not from the repository url.

Let me know if you agree this is a bug, and I'll submit one to the
bugzilla.

thanks,
Jesse
Re: bridge using registry url instead of repository url [message #36658 is a reply to message #36550] Thu, 08 November 2007 23:05 Go to previous messageGo to next message
No real name is currently offline No real name
Messages: 292
Registered: July 2009
Senior Member
Jesse,

Please submit this as a bug and we can look into it in more detail.
Please additionally submit your debug log as an attachment.

Thanks!
- Sarah


Jesse Pangburn wrote:
> Hi,
> I'm trying to test 11746 which is the XDS provide and registry
> transaction. However, it appears that the bridge is using the registry
> url instead of the repository url. The following is a relevant snippet
> from the bridge's log where it examines my rhioConfig.xml and displays
> the config info:
>
> mXdsRepositoryConfig=[{mesa=XdsRepositoryConfig ( XDS Type=[a]
> retrieveUrl=[null] provideRegisterUrl=[IheUri (
> mUnsecured=[http://129.6.24.109:9080/axis2/services/repositoryAonedoc]
> mSecured=[null] )] )}]
> mXdsRegistryConfig=[XdsRegistryConfig ( XDS Type=[a]
> nonStoredQueryUrl=[IheUri (
> mUnsecured=[http://129.6.24.109:9080/axis2/services/xdsregistrya]
> mSecured=[null] )] storedQueriesUrl=[IheUri (
> mUnsecured=[http://129.6.24.109:9080/axis2/services/xdsregistryb]
> mSecured=[null] )]
>
> And then there's the part where it logs where the transaction is
> actually being sent to (from a couple different sections of the log in
> case it was just one wrong print statement):
> [INFO ][2007-11-08T12:15:39.067-0800][ipse.ohf.ihe.xds.source.Sour ce]
> Submitting Provide and Register Document Set transaction to Repository:
> http://129.6.24.109:9080/axis2/services/xdsregistrya
>
> [DEBUG][2007-11-08T12:15:40.379-0800][httpclient.wire.header ] >>
> "POST /axis2/services/xdsregistrya HTTP/1.1[\r][\n]"
>
> You can see the url listed there is from the registry's
> nonStoredQueryUrl parameter, not from the repository url.
>
> Let me know if you agree this is a bug, and I'll submit one to the
> bugzilla.
>
> thanks,
> Jesse
>
>
Re: bridge using registry url instead of repository url [message #36762 is a reply to message #36658] Fri, 09 November 2007 19:42 Go to previous messageGo to next message
Jesse Pangburn is currently offline Jesse Pangburn
Messages: 166
Registered: July 2009
Senior Member
Hi Sarah,
OK, it is submitted as Bug 209378
https://bugs.eclipse.org/bugs/show_bug.cgi?id=209378

thank you!
Jesse

Sarah Knoop wrote:

> Jesse,

> Please submit this as a bug and we can look into it in more detail.
> Please additionally submit your debug log as an attachment.

> Thanks!
> - Sarah


> Jesse Pangburn wrote:
>> Hi,
>> I'm trying to test 11746 which is the XDS provide and registry
>> transaction. However, it appears that the bridge is using the registry
>> url instead of the repository url. The following is a relevant snippet
>> from the bridge's log where it examines my rhioConfig.xml and displays
>> the config info:
>>
>> mXdsRepositoryConfig=[{mesa=XdsRepositoryConfig ( XDS Type=[a]
>> retrieveUrl=[null] provideRegisterUrl=[IheUri (
>> mUnsecured=[http://129.6.24.109:9080/axis2/services/repositoryAonedoc]
>> mSecured=[null] )] )}]
>> mXdsRegistryConfig=[XdsRegistryConfig ( XDS Type=[a]
>> nonStoredQueryUrl=[IheUri (
>> mUnsecured=[http://129.6.24.109:9080/axis2/services/xdsregistrya]
>> mSecured=[null] )] storedQueriesUrl=[IheUri (
>> mUnsecured=[http://129.6.24.109:9080/axis2/services/xdsregistryb]
>> mSecured=[null] )]
>>
>> And then there's the part where it logs where the transaction is
>> actually being sent to (from a couple different sections of the log in
>> case it was just one wrong print statement):
>> [INFO ][2007-11-08T12:15:39.067-0800][ipse.ohf.ihe.xds.source.Sour ce]
>> Submitting Provide and Register Document Set transaction to Repository:
>> http://129.6.24.109:9080/axis2/services/xdsregistrya
>>
>> [DEBUG][2007-11-08T12:15:40.379-0800][httpclient.wire.header ] >>
>> "POST /axis2/services/xdsregistrya HTTP/1.1[r][n]"
>>
>> You can see the url listed there is from the registry's
>> nonStoredQueryUrl parameter, not from the repository url.
>>
>> Let me know if you agree this is a bug, and I'll submit one to the
>> bugzilla.
>>
>> thanks,
>> Jesse
>>
>>
Re: bridge using registry url instead of repository url [message #36898 is a reply to message #36762] Mon, 12 November 2007 01:02 Go to previous message
No real name is currently offline No real name
Messages: 292
Registered: July 2009
Senior Member
I have committed a fix to the main branch of the OHF code in the CVS.
Please update from there. This fix may have some logic issues pending
(related to how the bridge manages the concept of a "defalut repository"
in it's support of both XDS.a and XDS.b) ... but try it for now. If
difficulties arise, please submit a new bug related to the repository
URL issues experienced.

- Sarah

Jesse Pangburn wrote:
> Hi Sarah,
> OK, it is submitted as Bug 209378
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=209378
>
> thank you!
> Jesse
>
> Sarah Knoop wrote:
>
>> Jesse,
>
>
>> Please submit this as a bug and we can look into it in more detail.
>> Please additionally submit your debug log as an attachment.
>
>
>> Thanks!
>> - Sarah
>
>
>
>> Jesse Pangburn wrote:
>>
>>> Hi,
>>> I'm trying to test 11746 which is the XDS provide and registry
>>> transaction. However, it appears that the bridge is using the
>>> registry url instead of the repository url. The following is a
>>> relevant snippet from the bridge's log where it examines my
>>> rhioConfig.xml and displays the config info:
>>>
>>> mXdsRepositoryConfig=[{mesa=XdsRepositoryConfig ( XDS Type=[a]
>>> retrieveUrl=[null] provideRegisterUrl=[IheUri (
>>> mUnsecured=[http://129.6.24.109:9080/axis2/services/repositoryAonedoc]
>>> mSecured=[null] )] )}]
>>> mXdsRegistryConfig=[XdsRegistryConfig ( XDS Type=[a]
>>> nonStoredQueryUrl=[IheUri (
>>> mUnsecured=[http://129.6.24.109:9080/axis2/services/xdsregistrya]
>>> mSecured=[null] )] storedQueriesUrl=[IheUri (
>>> mUnsecured=[http://129.6.24.109:9080/axis2/services/xdsregistryb]
>>> mSecured=[null] )]
>>>
>>> And then there's the part where it logs where the transaction is
>>> actually being sent to (from a couple different sections of the log
>>> in case it was just one wrong print statement):
>>> [INFO ][2007-11-08T12:15:39.067-0800][ipse.ohf.ihe.xds.source.Sour ce]
>>> Submitting Provide and Register Document Set transaction to
>>> Repository: http://129.6.24.109:9080/axis2/services/xdsregistrya
>>>
>>> [DEBUG][2007-11-08T12:15:40.379-0800][httpclient.wire.header ]
>>> >> "POST /axis2/services/xdsregistrya HTTP/1.1[r][n]"
>>>
>>> You can see the url listed there is from the registry's
>>> nonStoredQueryUrl parameter, not from the repository url.
>>>
>>> Let me know if you agree this is a bug, and I'll submit one to the
>>> bugzilla.
>>>
>>> thanks,
>>> Jesse
>>>
>>>
>
>
Re: bridge using registry url instead of repository url [message #582940 is a reply to message #36550] Thu, 08 November 2007 23:05 Go to previous message
No real name is currently offline No real name
Messages: 292
Registered: July 2009
Senior Member
Jesse,

Please submit this as a bug and we can look into it in more detail.
Please additionally submit your debug log as an attachment.

Thanks!
- Sarah


Jesse Pangburn wrote:
> Hi,
> I'm trying to test 11746 which is the XDS provide and registry
> transaction. However, it appears that the bridge is using the registry
> url instead of the repository url. The following is a relevant snippet
> from the bridge's log where it examines my rhioConfig.xml and displays
> the config info:
>
> mXdsRepositoryConfig=[{mesa=XdsRepositoryConfig ( XDS Type=[a]
> retrieveUrl=[null] provideRegisterUrl=[IheUri (
> mUnsecured=[http://129.6.24.109:9080/axis2/services/repositoryAonedoc]
> mSecured=[null] )] )}]
> mXdsRegistryConfig=[XdsRegistryConfig ( XDS Type=[a]
> nonStoredQueryUrl=[IheUri (
> mUnsecured=[http://129.6.24.109:9080/axis2/services/xdsregistrya]
> mSecured=[null] )] storedQueriesUrl=[IheUri (
> mUnsecured=[http://129.6.24.109:9080/axis2/services/xdsregistryb]
> mSecured=[null] )]
>
> And then there's the part where it logs where the transaction is
> actually being sent to (from a couple different sections of the log in
> case it was just one wrong print statement):
> [INFO ][2007-11-08T12:15:39.067-0800][ipse.ohf.ihe.xds.source.Sour ce]
> Submitting Provide and Register Document Set transaction to Repository:
> http://129.6.24.109:9080/axis2/services/xdsregistrya
>
> [DEBUG][2007-11-08T12:15:40.379-0800][httpclient.wire.header ] >>
> "POST /axis2/services/xdsregistrya HTTP/1.1[\r][\n]"
>
> You can see the url listed there is from the registry's
> nonStoredQueryUrl parameter, not from the repository url.
>
> Let me know if you agree this is a bug, and I'll submit one to the
> bugzilla.
>
> thanks,
> Jesse
>
>
Re: bridge using registry url instead of repository url [message #582966 is a reply to message #36658] Fri, 09 November 2007 19:42 Go to previous message
Jesse Pangburn is currently offline Jesse Pangburn
Messages: 166
Registered: July 2009
Senior Member
Hi Sarah,
OK, it is submitted as Bug 209378
https://bugs.eclipse.org/bugs/show_bug.cgi?id=209378

thank you!
Jesse

Sarah Knoop wrote:

> Jesse,

> Please submit this as a bug and we can look into it in more detail.
> Please additionally submit your debug log as an attachment.

> Thanks!
> - Sarah


> Jesse Pangburn wrote:
>> Hi,
>> I'm trying to test 11746 which is the XDS provide and registry
>> transaction. However, it appears that the bridge is using the registry
>> url instead of the repository url. The following is a relevant snippet
>> from the bridge's log where it examines my rhioConfig.xml and displays
>> the config info:
>>
>> mXdsRepositoryConfig=[{mesa=XdsRepositoryConfig ( XDS Type=[a]
>> retrieveUrl=[null] provideRegisterUrl=[IheUri (
>> mUnsecured=[http://129.6.24.109:9080/axis2/services/repositoryAonedoc]
>> mSecured=[null] )] )}]
>> mXdsRegistryConfig=[XdsRegistryConfig ( XDS Type=[a]
>> nonStoredQueryUrl=[IheUri (
>> mUnsecured=[http://129.6.24.109:9080/axis2/services/xdsregistrya]
>> mSecured=[null] )] storedQueriesUrl=[IheUri (
>> mUnsecured=[http://129.6.24.109:9080/axis2/services/xdsregistryb]
>> mSecured=[null] )]
>>
>> And then there's the part where it logs where the transaction is
>> actually being sent to (from a couple different sections of the log in
>> case it was just one wrong print statement):
>> [INFO ][2007-11-08T12:15:39.067-0800][ipse.ohf.ihe.xds.source.Sour ce]
>> Submitting Provide and Register Document Set transaction to Repository:
>> http://129.6.24.109:9080/axis2/services/xdsregistrya
>>
>> [DEBUG][2007-11-08T12:15:40.379-0800][httpclient.wire.header ] >>
>> "POST /axis2/services/xdsregistrya HTTP/1.1[r][n]"
>>
>> You can see the url listed there is from the registry's
>> nonStoredQueryUrl parameter, not from the repository url.
>>
>> Let me know if you agree this is a bug, and I'll submit one to the
>> bugzilla.
>>
>> thanks,
>> Jesse
>>
>>
Re: bridge using registry url instead of repository url [message #583017 is a reply to message #36762] Mon, 12 November 2007 01:02 Go to previous message
No real name is currently offline No real name
Messages: 292
Registered: July 2009
Senior Member
I have committed a fix to the main branch of the OHF code in the CVS.
Please update from there. This fix may have some logic issues pending
(related to how the bridge manages the concept of a "defalut repository"
in it's support of both XDS.a and XDS.b) ... but try it for now. If
difficulties arise, please submit a new bug related to the repository
URL issues experienced.

- Sarah

Jesse Pangburn wrote:
> Hi Sarah,
> OK, it is submitted as Bug 209378
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=209378
>
> thank you!
> Jesse
>
> Sarah Knoop wrote:
>
>> Jesse,
>
>
>> Please submit this as a bug and we can look into it in more detail.
>> Please additionally submit your debug log as an attachment.
>
>
>> Thanks!
>> - Sarah
>
>
>
>> Jesse Pangburn wrote:
>>
>>> Hi,
>>> I'm trying to test 11746 which is the XDS provide and registry
>>> transaction. However, it appears that the bridge is using the
>>> registry url instead of the repository url. The following is a
>>> relevant snippet from the bridge's log where it examines my
>>> rhioConfig.xml and displays the config info:
>>>
>>> mXdsRepositoryConfig=[{mesa=XdsRepositoryConfig ( XDS Type=[a]
>>> retrieveUrl=[null] provideRegisterUrl=[IheUri (
>>> mUnsecured=[http://129.6.24.109:9080/axis2/services/repositoryAonedoc]
>>> mSecured=[null] )] )}]
>>> mXdsRegistryConfig=[XdsRegistryConfig ( XDS Type=[a]
>>> nonStoredQueryUrl=[IheUri (
>>> mUnsecured=[http://129.6.24.109:9080/axis2/services/xdsregistrya]
>>> mSecured=[null] )] storedQueriesUrl=[IheUri (
>>> mUnsecured=[http://129.6.24.109:9080/axis2/services/xdsregistryb]
>>> mSecured=[null] )]
>>>
>>> And then there's the part where it logs where the transaction is
>>> actually being sent to (from a couple different sections of the log
>>> in case it was just one wrong print statement):
>>> [INFO ][2007-11-08T12:15:39.067-0800][ipse.ohf.ihe.xds.source.Sour ce]
>>> Submitting Provide and Register Document Set transaction to
>>> Repository: http://129.6.24.109:9080/axis2/services/xdsregistrya
>>>
>>> [DEBUG][2007-11-08T12:15:40.379-0800][httpclient.wire.header ]
>>> >> "POST /axis2/services/xdsregistrya HTTP/1.1[r][n]"
>>>
>>> You can see the url listed there is from the registry's
>>> nonStoredQueryUrl parameter, not from the repository url.
>>>
>>> Let me know if you agree this is a bug, and I'll submit one to the
>>> bugzilla.
>>>
>>> thanks,
>>> Jesse
>>>
>>>
>
>
Previous Topic:confidentiality code when submitting CDA works strangely
Next Topic:Re: OHF bridge for IHE project
Goto Forum:
  


Current Time: Thu Oct 02 02:31:33 GMT 2014

Powered by FUDForum. Page generated in 0.02387 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software