Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DTP » Connect just hangs
Connect just hangs [message #36505] Wed, 19 September 2007 06:17 Go to next message
Richard Emerson is currently offline Richard Emerson
Messages: 3
Registered: July 2009
Junior Member
Hi there

I've recently installed DTP 1.5 in Eclipse 3.3. I set up a couple of JDBC
driver definitions (jConnect3 and jTDS). In the Data Source Explorer, I
define a new database connection.

When I try to connect to the database, the 'Creating JDBC Connection'
progress dialog opens, but the connection is never made and the dialog
never goes away (choosing Cancel does not work).

Pinging the database does the same. If I try to test the connection from
the Connection Properties page, Eclipse hangs and I have to kill it.

Here's what I've tried so far:
- I can ping the DB box and telnet to the port.
- A little test program to make the same connection (same URL, userid etc)
using the same JDBC driver works fine and connects instantly.
- Using a different JDBC driver doesn't seem to help.
- Running Eclipse in a 1.5 JDK instead of 1.6 doesn't help.
- I can't see anything relevant in the workspace .log file or in the
Eclipse Error Log.
- I haven't found reports of a similar problem on this newsgroup or
elsewhere.

I'm not sure what to do next to diagnose this problem - does anyone have
any suggestions?

Many thanks and regards,
Richard
Re: Connect just hangs [message #36653 is a reply to message #36505] Wed, 26 September 2007 16:46 Go to previous message
Eclipse User
Originally posted by: john.graham.sybase.com

Richard,

You might want to try DTP 1.5.1, due out at the end of this week. We've
made some changes in these areas, and it might cure your problem.

HTH,
John Graham
Eclipse Data Tools Platform PMC Chair

Richard Emerson wrote:

> Hi there

> I've recently installed DTP 1.5 in Eclipse 3.3. I set up a couple of JDBC
> driver definitions (jConnect3 and jTDS). In the Data Source Explorer, I
> define a new database connection.

> When I try to connect to the database, the 'Creating JDBC Connection'
> progress dialog opens, but the connection is never made and the dialog
> never goes away (choosing Cancel does not work).

> Pinging the database does the same. If I try to test the connection from
> the Connection Properties page, Eclipse hangs and I have to kill it.

> Here's what I've tried so far:
> - I can ping the DB box and telnet to the port.
> - A little test program to make the same connection (same URL, userid etc)
> using the same JDBC driver works fine and connects instantly.
> - Using a different JDBC driver doesn't seem to help.
> - Running Eclipse in a 1.5 JDK instead of 1.6 doesn't help.
> - I can't see anything relevant in the workspace .log file or in the
> Eclipse Error Log.
> - I haven't found reports of a similar problem on this newsgroup or
> elsewhere.

> I'm not sure what to do next to diagnose this problem - does anyone have
> any suggestions?

> Many thanks and regards,
> Richard
Re: Connect just hangs [message #587990 is a reply to message #36505] Wed, 26 September 2007 16:46 Go to previous message
John Graham is currently offline John Graham
Messages: 183
Registered: July 2009
Senior Member
Richard,

You might want to try DTP 1.5.1, due out at the end of this week. We've
made some changes in these areas, and it might cure your problem.

HTH,
John Graham
Eclipse Data Tools Platform PMC Chair

Richard Emerson wrote:

> Hi there

> I've recently installed DTP 1.5 in Eclipse 3.3. I set up a couple of JDBC
> driver definitions (jConnect3 and jTDS). In the Data Source Explorer, I
> define a new database connection.

> When I try to connect to the database, the 'Creating JDBC Connection'
> progress dialog opens, but the connection is never made and the dialog
> never goes away (choosing Cancel does not work).

> Pinging the database does the same. If I try to test the connection from
> the Connection Properties page, Eclipse hangs and I have to kill it.

> Here's what I've tried so far:
> - I can ping the DB box and telnet to the port.
> - A little test program to make the same connection (same URL, userid etc)
> using the same JDBC driver works fine and connects instantly.
> - Using a different JDBC driver doesn't seem to help.
> - Running Eclipse in a 1.5 JDK instead of 1.6 doesn't help.
> - I can't see anything relevant in the workspace .log file or in the
> Eclipse Error Log.
> - I haven't found reports of a similar problem on this newsgroup or
> elsewhere.

> I'm not sure what to do next to diagnose this problem - does anyone have
> any suggestions?

> Many thanks and regards,
> Richard
Previous Topic:HowTo load database-driver dynamically
Next Topic:DTP 1.5.1 Finalized
Goto Forum:
  


Current Time: Thu Apr 17 08:33:39 EDT 2014

Powered by FUDForum. Page generated in 0.02114 seconds