Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » OHF » using bridge build Nov1, log entry about "AuditSourceID"
using bridge build Nov1, log entry about "AuditSourceID" [message #36432] Thu, 08 November 2007 14:21 Go to next message
Jesse Pangburn is currently offline Jesse Pangburn
Messages: 166
Registered: July 2009
Senior Member
Hi,
With the Nov 1 version of the bridge installer I get log entries that seem
to be warnings when I submit a document:

<ns2:log xmlns:ns2="http://type.bridge.ohf.eclipse.org"><ns3:item
xmlns:ns3="http://localhost/bridge/services/ohf-bridge-wrapped">2007-11-08T11:04:48.497-08:00
Defaulting to IP Address for AuditSourceID. This should be set by calling
setAuditSourceId.</ns3:item><ns4:item
xmlns:ns4="http://localhost/bridge/services/ohf-bridge-wrapped">2007-11-08T11:04:52.753-08:00
Defaulting to IP Address for AuditSourceID. This should be set by calling
setAuditSourceId.</ns4:item><ns5:item
xmlns:ns5="http://localhost/bridge/services/ohf-bridge-wrapped">2007-11-08T11:04:52.783-08:00
Defaulting to IP Address for AuditSourceID. This should be set by calling
setAuditSourceId.</ns5:item></ns2:log>

This "setAuditSourceId" seems to be something you can only do through the
API. I can't find anything in the Bridge's wsdl to indicate you can set
this. I checked the rhio.xsd to see if there was a way to set it for a
rhio, but there isn't (which makes sense because it doesn't seem like it
should be a rhio setting).

Maybe the level of this message could be lower so when we turn the log
level to WARN, we don't get this message in the bridge? Or specifically
call the setAuditSourceID in the bridge2API code so it doesn't generate
the warning message at all- since maybe WARN is the right level message
for API users?

thanks,
Jesse
Re: using bridge build Nov1, log entry about "AuditSourceID" [message #36461 is a reply to message #36432] Thu, 08 November 2007 14:45 Go to previous messageGo to next message
No real name is currently offline No real name
Messages: 292
Registered: July 2009
Senior Member
Hi Jesse,

This was an oversight on our part and you should be able to submit the
audit source ID via the bridge. Please submit a bug to bugzilla with the
information below. This will not inhibit your MESA testing what-so-ever.
Being able to set the audit source ID is "nice" but not required for
these tests.

Thanks!
- Sarah


Jesse Pangburn wrote:
> Hi,
> With the Nov 1 version of the bridge installer I get log entries that
> seem to be warnings when I submit a document:
>
> <ns2:log xmlns:ns2="http://type.bridge.ohf.eclipse.org"><ns3:item
> xmlns:ns3="http://localhost/bridge/services/ohf-bridge-wrapped">2007-11-08T11:04:48.497-08:00
> Defaulting to IP Address for AuditSourceID. This should be set by
> calling setAuditSourceId.</ns3:item><ns4:item
> xmlns:ns4="http://localhost/bridge/services/ohf-bridge-wrapped">2007-11-08T11:04:52.753-08:00
> Defaulting to IP Address for AuditSourceID. This should be set by
> calling setAuditSourceId.</ns4:item><ns5:item
> xmlns:ns5="http://localhost/bridge/services/ohf-bridge-wrapped">2007-11-08T11:04:52.783-08:00
> Defaulting to IP Address for AuditSourceID. This should be set by
> calling setAuditSourceId.</ns5:item></ns2:log>
>
> This "setAuditSourceId" seems to be something you can only do through
> the API. I can't find anything in the Bridge's wsdl to indicate you can
> set this. I checked the rhio.xsd to see if there was a way to set it
> for a rhio, but there isn't (which makes sense because it doesn't seem
> like it should be a rhio setting).
>
> Maybe the level of this message could be lower so when we turn the log
> level to WARN, we don't get this message in the bridge? Or specifically
> call the setAuditSourceID in the bridge2API code so it doesn't generate
> the warning message at all- since maybe WARN is the right level message
> for API users?
>
> thanks,
> Jesse
>
Re: using bridge build Nov1, log entry about "AuditSourceID" [message #36517 is a reply to message #36461] Thu, 08 November 2007 15:43 Go to previous messageGo to next message
Jesse Pangburn is currently offline Jesse Pangburn
Messages: 166
Registered: July 2009
Senior Member
Hi Sarah,
Bug is submitted as "Bug 209258"
https://bugs.eclipse.org/bugs/show_bug.cgi?id=209258

Thanks for the clarification that it won't impact any tests!
Jesse

Sarah Knoop wrote:

> Hi Jesse,

> This was an oversight on our part and you should be able to submit the
> audit source ID via the bridge. Please submit a bug to bugzilla with the
> information below. This will not inhibit your MESA testing what-so-ever.
> Being able to set the audit source ID is "nice" but not required for
> these tests.

> Thanks!
> - Sarah


> Jesse Pangburn wrote:
>> Hi,
>> With the Nov 1 version of the bridge installer I get log entries that
>> seem to be warnings when I submit a document:
>>
>> <ns2:log xmlns:ns2="http://type.bridge.ohf.eclipse.org"><ns3:item
>>
xmlns:ns3="http://localhost/bridge/services/ohf-bridge-wrapped">2007-11-08T11:04:48.497-08:00
>> Defaulting to IP Address for AuditSourceID. This should be set by
>> calling setAuditSourceId.</ns3:item><ns4:item
>>
xmlns:ns4="http://localhost/bridge/services/ohf-bridge-wrapped">2007-11-08T11:04:52.753-08:00
>> Defaulting to IP Address for AuditSourceID. This should be set by
>> calling setAuditSourceId.</ns4:item><ns5:item
>>
xmlns:ns5="http://localhost/bridge/services/ohf-bridge-wrapped">2007-11-08T11:04:52.783-08:00
>> Defaulting to IP Address for AuditSourceID. This should be set by
>> calling setAuditSourceId.</ns5:item></ns2:log>
>>
>> This "setAuditSourceId" seems to be something you can only do through
>> the API. I can't find anything in the Bridge's wsdl to indicate you can
>> set this. I checked the rhio.xsd to see if there was a way to set it
>> for a rhio, but there isn't (which makes sense because it doesn't seem
>> like it should be a rhio setting).
>>
>> Maybe the level of this message could be lower so when we turn the log
>> level to WARN, we don't get this message in the bridge? Or specifically
>> call the setAuditSourceID in the bridge2API code so it doesn't generate
>> the warning message at all- since maybe WARN is the right level message
>> for API users?
>>
>> thanks,
>> Jesse
>>
Re: using bridge build Nov1, log entry about "AuditSourceID" [message #37605 is a reply to message #36517] Tue, 20 November 2007 18:28 Go to previous message
Matthew Davis
Messages: 269
Registered: July 2009
Senior Member
Right now, the AuditSourceId is being set from the
SessionContext.UserApplicationName value.

However, since this is only really relevant for the HL7-based
transactions, I have added a new field to SessionContext:
AuditSourceId. This will now call ATNA and set the value within the
context scope.

I have also renamed the SessionContext.User field to
SessionContext.InitiatingUser. This makes the usage of the field now
align more directly with the ATNA API.

Both of these changes constitute an API change in the Bridge and will
require a regeneration of any WSDL proxies that you may be using.

Thanks,

-Matt

Jesse Pangburn wrote:
> Hi Sarah,
> Bug is submitted as "Bug 209258"
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=209258
>
> Thanks for the clarification that it won't impact any tests!
> Jesse
>
> Sarah Knoop wrote:
>
>> Hi Jesse,
>
>> This was an oversight on our part and you should be able to submit the
>> audit source ID via the bridge. Please submit a bug to bugzilla with
>> the information below. This will not inhibit your MESA testing
>> what-so-ever. Being able to set the audit source ID is "nice" but not
>> required for these tests.
>
>> Thanks!
>> - Sarah
>
>
>> Jesse Pangburn wrote:
>>> Hi,
>>> With the Nov 1 version of the bridge installer I get log entries that
>>> seem to be warnings when I submit a document:
>>>
>>> <ns2:log xmlns:ns2="http://type.bridge.ohf.eclipse.org"><ns3:item
> xmlns:ns3="http://localhost/bridge/services/ohf-bridge-wrapped">2007-11-08T11:04:48.497-08:00
>
>>> Defaulting to IP Address for AuditSourceID. This should be set by
>>> calling setAuditSourceId.</ns3:item><ns4:item
> xmlns:ns4="http://localhost/bridge/services/ohf-bridge-wrapped">2007-11-08T11:04:52.753-08:00
>
>>> Defaulting to IP Address for AuditSourceID. This should be set by
>>> calling setAuditSourceId.</ns4:item><ns5:item
> xmlns:ns5="http://localhost/bridge/services/ohf-bridge-wrapped">2007-11-08T11:04:52.783-08:00
>
>>> Defaulting to IP Address for AuditSourceID. This should be set by
>>> calling setAuditSourceId.</ns5:item></ns2:log>
>>>
>>> This "setAuditSourceId" seems to be something you can only do through
>>> the API. I can't find anything in the Bridge's wsdl to indicate you
>>> can set this. I checked the rhio.xsd to see if there was a way to
>>> set it for a rhio, but there isn't (which makes sense because it
>>> doesn't seem like it should be a rhio setting).
>>>
>>> Maybe the level of this message could be lower so when we turn the
>>> log level to WARN, we don't get this message in the bridge? Or
>>> specifically call the setAuditSourceID in the bridge2API code so it
>>> doesn't generate the warning message at all- since maybe WARN is the
>>> right level message for API users?
>>>
>>> thanks,
>>> Jesse
>>>
>
>
Re: using bridge build Nov1, log entry about "AuditSourceID" [message #582869 is a reply to message #36432] Thu, 08 November 2007 14:45 Go to previous message
No real name is currently offline No real name
Messages: 292
Registered: July 2009
Senior Member
Hi Jesse,

This was an oversight on our part and you should be able to submit the
audit source ID via the bridge. Please submit a bug to bugzilla with the
information below. This will not inhibit your MESA testing what-so-ever.
Being able to set the audit source ID is "nice" but not required for
these tests.

Thanks!
- Sarah


Jesse Pangburn wrote:
> Hi,
> With the Nov 1 version of the bridge installer I get log entries that
> seem to be warnings when I submit a document:
>
> <ns2:log xmlns:ns2="http://type.bridge.ohf.eclipse.org"><ns3:item
> xmlns:ns3="http://localhost/bridge/services/ohf-bridge-wrapped">2007-11-08T11:04:48.497-08:00
> Defaulting to IP Address for AuditSourceID. This should be set by
> calling setAuditSourceId.</ns3:item><ns4:item
> xmlns:ns4="http://localhost/bridge/services/ohf-bridge-wrapped">2007-11-08T11:04:52.753-08:00
> Defaulting to IP Address for AuditSourceID. This should be set by
> calling setAuditSourceId.</ns4:item><ns5:item
> xmlns:ns5="http://localhost/bridge/services/ohf-bridge-wrapped">2007-11-08T11:04:52.783-08:00
> Defaulting to IP Address for AuditSourceID. This should be set by
> calling setAuditSourceId.</ns5:item></ns2:log>
>
> This "setAuditSourceId" seems to be something you can only do through
> the API. I can't find anything in the Bridge's wsdl to indicate you can
> set this. I checked the rhio.xsd to see if there was a way to set it
> for a rhio, but there isn't (which makes sense because it doesn't seem
> like it should be a rhio setting).
>
> Maybe the level of this message could be lower so when we turn the log
> level to WARN, we don't get this message in the bridge? Or specifically
> call the setAuditSourceID in the bridge2API code so it doesn't generate
> the warning message at all- since maybe WARN is the right level message
> for API users?
>
> thanks,
> Jesse
>
Re: using bridge build Nov1, log entry about "AuditSourceID" [message #582892 is a reply to message #36461] Thu, 08 November 2007 15:43 Go to previous message
Jesse Pangburn is currently offline Jesse Pangburn
Messages: 166
Registered: July 2009
Senior Member
Hi Sarah,
Bug is submitted as "Bug 209258"
https://bugs.eclipse.org/bugs/show_bug.cgi?id=209258

Thanks for the clarification that it won't impact any tests!
Jesse

Sarah Knoop wrote:

> Hi Jesse,

> This was an oversight on our part and you should be able to submit the
> audit source ID via the bridge. Please submit a bug to bugzilla with the
> information below. This will not inhibit your MESA testing what-so-ever.
> Being able to set the audit source ID is "nice" but not required for
> these tests.

> Thanks!
> - Sarah


> Jesse Pangburn wrote:
>> Hi,
>> With the Nov 1 version of the bridge installer I get log entries that
>> seem to be warnings when I submit a document:
>>
>> <ns2:log xmlns:ns2="http://type.bridge.ohf.eclipse.org"><ns3:item
>>
xmlns:ns3="http://localhost/bridge/services/ohf-bridge-wrapped">2007-11-08T11:04:48.497-08:00
>> Defaulting to IP Address for AuditSourceID. This should be set by
>> calling setAuditSourceId.</ns3:item><ns4:item
>>
xmlns:ns4="http://localhost/bridge/services/ohf-bridge-wrapped">2007-11-08T11:04:52.753-08:00
>> Defaulting to IP Address for AuditSourceID. This should be set by
>> calling setAuditSourceId.</ns4:item><ns5:item
>>
xmlns:ns5="http://localhost/bridge/services/ohf-bridge-wrapped">2007-11-08T11:04:52.783-08:00
>> Defaulting to IP Address for AuditSourceID. This should be set by
>> calling setAuditSourceId.</ns5:item></ns2:log>
>>
>> This "setAuditSourceId" seems to be something you can only do through
>> the API. I can't find anything in the Bridge's wsdl to indicate you can
>> set this. I checked the rhio.xsd to see if there was a way to set it
>> for a rhio, but there isn't (which makes sense because it doesn't seem
>> like it should be a rhio setting).
>>
>> Maybe the level of this message could be lower so when we turn the log
>> level to WARN, we don't get this message in the bridge? Or specifically
>> call the setAuditSourceID in the bridge2API code so it doesn't generate
>> the warning message at all- since maybe WARN is the right level message
>> for API users?
>>
>> thanks,
>> Jesse
>>
Re: using bridge build Nov1, log entry about "AuditSourceID" [message #583322 is a reply to message #36517] Tue, 20 November 2007 18:28 Go to previous message
Matthew Davis
Messages: 269
Registered: July 2009
Senior Member
Right now, the AuditSourceId is being set from the
SessionContext.UserApplicationName value.

However, since this is only really relevant for the HL7-based
transactions, I have added a new field to SessionContext:
AuditSourceId. This will now call ATNA and set the value within the
context scope.

I have also renamed the SessionContext.User field to
SessionContext.InitiatingUser. This makes the usage of the field now
align more directly with the ATNA API.

Both of these changes constitute an API change in the Bridge and will
require a regeneration of any WSDL proxies that you may be using.

Thanks,

-Matt

Jesse Pangburn wrote:
> Hi Sarah,
> Bug is submitted as "Bug 209258"
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=209258
>
> Thanks for the clarification that it won't impact any tests!
> Jesse
>
> Sarah Knoop wrote:
>
>> Hi Jesse,
>
>> This was an oversight on our part and you should be able to submit the
>> audit source ID via the bridge. Please submit a bug to bugzilla with
>> the information below. This will not inhibit your MESA testing
>> what-so-ever. Being able to set the audit source ID is "nice" but not
>> required for these tests.
>
>> Thanks!
>> - Sarah
>
>
>> Jesse Pangburn wrote:
>>> Hi,
>>> With the Nov 1 version of the bridge installer I get log entries that
>>> seem to be warnings when I submit a document:
>>>
>>> <ns2:log xmlns:ns2="http://type.bridge.ohf.eclipse.org"><ns3:item
> xmlns:ns3="http://localhost/bridge/services/ohf-bridge-wrapped">2007-11-08T11:04:48.497-08:00
>
>>> Defaulting to IP Address for AuditSourceID. This should be set by
>>> calling setAuditSourceId.</ns3:item><ns4:item
> xmlns:ns4="http://localhost/bridge/services/ohf-bridge-wrapped">2007-11-08T11:04:52.753-08:00
>
>>> Defaulting to IP Address for AuditSourceID. This should be set by
>>> calling setAuditSourceId.</ns4:item><ns5:item
> xmlns:ns5="http://localhost/bridge/services/ohf-bridge-wrapped">2007-11-08T11:04:52.783-08:00
>
>>> Defaulting to IP Address for AuditSourceID. This should be set by
>>> calling setAuditSourceId.</ns5:item></ns2:log>
>>>
>>> This "setAuditSourceId" seems to be something you can only do through
>>> the API. I can't find anything in the Bridge's wsdl to indicate you
>>> can set this. I checked the rhio.xsd to see if there was a way to
>>> set it for a rhio, but there isn't (which makes sense because it
>>> doesn't seem like it should be a rhio setting).
>>>
>>> Maybe the level of this message could be lower so when we turn the
>>> log level to WARN, we don't get this message in the bridge? Or
>>> specifically call the setAuditSourceID in the bridge2API code so it
>>> doesn't generate the warning message at all- since maybe WARN is the
>>> right level message for API users?
>>>
>>> thanks,
>>> Jesse
>>>
>
>
Previous Topic:Hash, Size and URI missing in metadata
Next Topic:Bridge: secured connection forced with public XDS registry
Goto Forum:
  


Current Time: Tue Jul 29 00:51:19 EDT 2014

Powered by FUDForum. Page generated in 0.01871 seconds