Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DTP » Connection wizard - Picture 1.png (1/1)
Connection wizard - Picture 1.png (1/1) [message #36277] Sat, 15 September 2007 09:42 Go to next message
Eclipse User
Originally posted by: nova67f.yahoo.de

Hi,

i'm trying to create a jdbc connection profile for mysql.

So i go into the datasource explorer, click on Databases, SQL Model-JDBC
Connection, fill in the name/description, and then the driver selection
screen.

It asks to select a driver from the dropdown. the button on the right
shows me a list of available driver definitions, i choose mysql 5.0 and
click ok.

however, when i click ok, the driver selection screen goes away and
still no driver is selected in the drop-down.
also, when i enter the database, username and password, and click finish
or next, nothing happens. the buttons don't react.
the only one that reacts is "cancel" or "back". "Cancel" closes the
screen and "back" goes back one screen.

I guess this is not normal behaviour. However, i have the plugins in the
plugins directory and according to help/software updates/manage
installation/product configuration, i have all DTP, GEF and EMF
features. there's no cross to indicate a faulty module.

However, my mysql installation is just fine. i can connect with MAMP,
myphpadmin and cocoamysql to /Applications/MAMP/tmp/mysql/mysql.sock

can anyone help pls?

cheers,
Andy

  • Attachment: Picture 1.png
    (Size: 22.52KB, Downloaded 156 times)
Re: Connection wizard - Picture 1.png (1/1) [message #36310 is a reply to message #36277] Sat, 15 September 2007 10:30 Go to previous messageGo to next message
Eclipse User
Originally posted by: nova67f.yahoo.de

In article <nova67f-7EAEA8.11421615092007@news.eclipse.org>,
Andy Vandenberghe <nova67f@yahoo.de> wrote:

> Hi,
>
> i'm trying to create a jdbc connection profile for mysql.
>
> So i go into the datasource explorer, click on Databases, SQL Model-JDBC
> Connection, fill in the name/description, and then the driver selection
> screen.
>
> It asks to select a driver from the dropdown. the button on the right
> shows me a list of available driver definitions, i choose mysql 5.0 and
> click ok.
>
> however, when i click ok, the driver selection screen goes away and
> still no driver is selected in the drop-down.
> also, when i enter the database, username and password, and click finish
> or next, nothing happens. the buttons don't react.
> the only one that reacts is "cancel" or "back". "Cancel" closes the
> screen and "back" goes back one screen.
>
> I guess this is not normal behaviour. However, i have the plugins in the
> plugins directory and according to help/software updates/manage
> installation/product configuration, i have all DTP, GEF and EMF
> features. there's no cross to indicate a faulty module.
>
> However, my mysql installation is just fine. i can connect with MAMP,
> myphpadmin and cocoamysql to /Applications/MAMP/tmp/mysql/mysql.sock
>
> can anyone help pls?
>
> cheers,
> Andy
>
> begin 644 Picture 1.png

i found a lead : first i have to add a driver definition in the
preferences. so i added
/library/Java/extensions/mysql-connector-java-5.0.7-bin.jar

with the following standard parameters for my test db :
connection url : jdbc:mysql://localhost:3306/database
database name : avathar_be
user name : root
password : root

however, when i use that profile in data source explorer, i get

com.mysql.jdbc.exceptions.MySQLSyntaxErrorException: Unknown database
'database' at
com.mysql.jdbc.SQLError.createSQLException(SQLError.java:936 ) at
com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:2985) at
com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:885) at
com.mysql.jdbc.MysqlIO.secureAuth411(MysqlIO.java:3421) at
com.mysql.jdbc.MysqlIO.doHandshake(MysqlIO.java:1247) at
com.mysql.jdbc.Connection.createNewIO(Connection.java:2748) at
com.mysql.jdbc.Connection.<init>(Connection.java:1553) at
com.mysql.jdbc.NonRegisteringDriver.connect(NonRegisteringDr iver.java:285
) at
org.eclipse.datatools.connectivity.db.generic.JDBCConnection .createConnec
tion(JDBCConnection.java:87) at
org.eclipse.datatools.connectivity.DriverConnectionBase.inte rnalCreateCon
nection(DriverConnectionBase.java:104) at
org.eclipse.datatools.connectivity.DriverConnectionBase.open (DriverConnec
tionBase.java:53) at
org.eclipse.datatools.connectivity.db.generic.JDBCConnection Factory.creat
eConnection(JDBCConnectionFactory.java:52) at
org.eclipse.datatools.connectivity.internal.ConnectionFactor yProvider.cre
ateConnection(ConnectionFactoryProvider.java:77) at
org.eclipse.datatools.connectivity.internal.ConnectionProfil e.createConne
ction(ConnectionProfile.java:354) at
org.eclipse.datatools.connectivity.ui.PingJob.run(PingJob.ja va:57) at
org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
Re: Connection wizard - Picture 1.png (1/1) [message #36343 is a reply to message #36310] Sat, 15 September 2007 11:03 Go to previous message
Eclipse User
Originally posted by: nova67f.yahoo.de

In article <nova67f-3197AB.12300015092007@news.eclipse.org>,
Andy Vandenberghe <nova67f@yahoo.de> wrote:

> In article <nova67f-7EAEA8.11421615092007@news.eclipse.org>,
> Andy Vandenberghe <nova67f@yahoo.de> wrote:
>
> > Hi,
> >
> > i'm trying to create a jdbc connection profile for mysql.
> >
> > So i go into the datasource explorer, click on Databases, SQL Model-JDBC
> > Connection, fill in the name/description, and then the driver selection
> > screen.
> >
> > It asks to select a driver from the dropdown. the button on the right
> > shows me a list of available driver definitions, i choose mysql 5.0 and
> > click ok.
> >
> > however, when i click ok, the driver selection screen goes away and
> > still no driver is selected in the drop-down.
> > also, when i enter the database, username and password, and click finish
> > or next, nothing happens. the buttons don't react.
> > the only one that reacts is "cancel" or "back". "Cancel" closes the
> > screen and "back" goes back one screen.
> >
> > I guess this is not normal behaviour. However, i have the plugins in the
> > plugins directory and according to help/software updates/manage
> > installation/product configuration, i have all DTP, GEF and EMF
> > features. there's no cross to indicate a faulty module.
> >
> > However, my mysql installation is just fine. i can connect with MAMP,
> > myphpadmin and cocoamysql to /Applications/MAMP/tmp/mysql/mysql.sock
> >
> > can anyone help pls?
> >
> > cheers,
> > Andy
> >
> > begin 644 Picture 1.png
>
> i found a lead : first i have to add a driver definition in the
> preferences. so i added
> /library/Java/extensions/mysql-connector-java-5.0.7-bin.jar
>
> with the following standard parameters for my test db :
> connection url : jdbc:mysql://localhost:3306/database
> database name : avathar_be
> user name : root
> password : root
>
> however, when i use that profile in data source explorer, i get
>
> com.mysql.jdbc.exceptions.MySQLSyntaxErrorException: Unknown database
> 'database' at
> com.mysql.jdbc.SQLError.createSQLException(SQLError.java:936 ) at
> com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:2985) at
> com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:885) at
> com.mysql.jdbc.MysqlIO.secureAuth411(MysqlIO.java:3421) at
> com.mysql.jdbc.MysqlIO.doHandshake(MysqlIO.java:1247) at
> com.mysql.jdbc.Connection.createNewIO(Connection.java:2748) at
> com.mysql.jdbc.Connection.<init>(Connection.java:1553) at
> com.mysql.jdbc.NonRegisteringDriver.connect(NonRegisteringDr iver.java:285
> ) at
> org.eclipse.datatools.connectivity.db.generic.JDBCConnection .createConnec
> tion(JDBCConnection.java:87) at
> org.eclipse.datatools.connectivity.DriverConnectionBase.inte rnalCreateCon
> nection(DriverConnectionBase.java:104) at
> org.eclipse.datatools.connectivity.DriverConnectionBase.open (DriverConnec
> tionBase.java:53) at
> org.eclipse.datatools.connectivity.db.generic.JDBCConnection Factory.creat
> eConnection(JDBCConnectionFactory.java:52) at
> org.eclipse.datatools.connectivity.internal.ConnectionFactor yProvider.cre
> ateConnection(ConnectionFactoryProvider.java:77) at
> org.eclipse.datatools.connectivity.internal.ConnectionProfil e.createConne
> ction(ConnectionProfile.java:354) at
> org.eclipse.datatools.connectivity.ui.PingJob.run(PingJob.ja va:57) at
> org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

ok it works now. my connectiono url wasnt right
jdbc:mysql://localhost:3306/database
should have been jdbc:mysql://localhost:3306/avathar_be

now im gonna test further ;)

cheers,
Andy
Re: Connection wizard - Picture 1.png (1/1) [message #587887 is a reply to message #36277] Sat, 15 September 2007 10:30 Go to previous message
Eclipse User
Originally posted by: nova67f.yahoo.de

In article <nova67f-7EAEA8.11421615092007@news.eclipse.org>,
Andy Vandenberghe <nova67f@yahoo.de> wrote:

> Hi,
>
> i'm trying to create a jdbc connection profile for mysql.
>
> So i go into the datasource explorer, click on Databases, SQL Model-JDBC
> Connection, fill in the name/description, and then the driver selection
> screen.
>
> It asks to select a driver from the dropdown. the button on the right
> shows me a list of available driver definitions, i choose mysql 5.0 and
> click ok.
>
> however, when i click ok, the driver selection screen goes away and
> still no driver is selected in the drop-down.
> also, when i enter the database, username and password, and click finish
> or next, nothing happens. the buttons don't react.
> the only one that reacts is "cancel" or "back". "Cancel" closes the
> screen and "back" goes back one screen.
>
> I guess this is not normal behaviour. However, i have the plugins in the
> plugins directory and according to help/software updates/manage
> installation/product configuration, i have all DTP, GEF and EMF
> features. there's no cross to indicate a faulty module.
>
> However, my mysql installation is just fine. i can connect with MAMP,
> myphpadmin and cocoamysql to /Applications/MAMP/tmp/mysql/mysql.sock
>
> can anyone help pls?
>
> cheers,
> Andy
>
> begin 644 Picture 1.png

i found a lead : first i have to add a driver definition in the
preferences. so i added
/library/Java/extensions/mysql-connector-java-5.0.7-bin.jar

with the following standard parameters for my test db :
connection url : jdbc:mysql://localhost:3306/database
database name : avathar_be
user name : root
password : root

however, when i use that profile in data source explorer, i get

com.mysql.jdbc.exceptions.MySQLSyntaxErrorException: Unknown database
'database' at
com.mysql.jdbc.SQLError.createSQLException(SQLError.java:936 ) at
com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:2985) at
com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:885) at
com.mysql.jdbc.MysqlIO.secureAuth411(MysqlIO.java:3421) at
com.mysql.jdbc.MysqlIO.doHandshake(MysqlIO.java:1247) at
com.mysql.jdbc.Connection.createNewIO(Connection.java:2748) at
com.mysql.jdbc.Connection.<init>(Connection.java:1553) at
com.mysql.jdbc.NonRegisteringDriver.connect(NonRegisteringDr iver.java:285
) at
org.eclipse.datatools.connectivity.db.generic.JDBCConnection .createConnec
tion(JDBCConnection.java:87) at
org.eclipse.datatools.connectivity.DriverConnectionBase.inte rnalCreateCon
nection(DriverConnectionBase.java:104) at
org.eclipse.datatools.connectivity.DriverConnectionBase.open (DriverConnec
tionBase.java:53) at
org.eclipse.datatools.connectivity.db.generic.JDBCConnection Factory.creat
eConnection(JDBCConnectionFactory.java:52) at
org.eclipse.datatools.connectivity.internal.ConnectionFactor yProvider.cre
ateConnection(ConnectionFactoryProvider.java:77) at
org.eclipse.datatools.connectivity.internal.ConnectionProfil e.createConne
ction(ConnectionProfile.java:354) at
org.eclipse.datatools.connectivity.ui.PingJob.run(PingJob.ja va:57) at
org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
Re: Connection wizard - Picture 1.png (1/1) [message #587902 is a reply to message #36310] Sat, 15 September 2007 11:03 Go to previous message
Eclipse User
Originally posted by: nova67f.yahoo.de

In article <nova67f-3197AB.12300015092007@news.eclipse.org>,
Andy Vandenberghe <nova67f@yahoo.de> wrote:

> In article <nova67f-7EAEA8.11421615092007@news.eclipse.org>,
> Andy Vandenberghe <nova67f@yahoo.de> wrote:
>
> > Hi,
> >
> > i'm trying to create a jdbc connection profile for mysql.
> >
> > So i go into the datasource explorer, click on Databases, SQL Model-JDBC
> > Connection, fill in the name/description, and then the driver selection
> > screen.
> >
> > It asks to select a driver from the dropdown. the button on the right
> > shows me a list of available driver definitions, i choose mysql 5.0 and
> > click ok.
> >
> > however, when i click ok, the driver selection screen goes away and
> > still no driver is selected in the drop-down.
> > also, when i enter the database, username and password, and click finish
> > or next, nothing happens. the buttons don't react.
> > the only one that reacts is "cancel" or "back". "Cancel" closes the
> > screen and "back" goes back one screen.
> >
> > I guess this is not normal behaviour. However, i have the plugins in the
> > plugins directory and according to help/software updates/manage
> > installation/product configuration, i have all DTP, GEF and EMF
> > features. there's no cross to indicate a faulty module.
> >
> > However, my mysql installation is just fine. i can connect with MAMP,
> > myphpadmin and cocoamysql to /Applications/MAMP/tmp/mysql/mysql.sock
> >
> > can anyone help pls?
> >
> > cheers,
> > Andy
> >
> > begin 644 Picture 1.png
>
> i found a lead : first i have to add a driver definition in the
> preferences. so i added
> /library/Java/extensions/mysql-connector-java-5.0.7-bin.jar
>
> with the following standard parameters for my test db :
> connection url : jdbc:mysql://localhost:3306/database
> database name : avathar_be
> user name : root
> password : root
>
> however, when i use that profile in data source explorer, i get
>
> com.mysql.jdbc.exceptions.MySQLSyntaxErrorException: Unknown database
> 'database' at
> com.mysql.jdbc.SQLError.createSQLException(SQLError.java:936 ) at
> com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:2985) at
> com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:885) at
> com.mysql.jdbc.MysqlIO.secureAuth411(MysqlIO.java:3421) at
> com.mysql.jdbc.MysqlIO.doHandshake(MysqlIO.java:1247) at
> com.mysql.jdbc.Connection.createNewIO(Connection.java:2748) at
> com.mysql.jdbc.Connection.<init>(Connection.java:1553) at
> com.mysql.jdbc.NonRegisteringDriver.connect(NonRegisteringDr iver.java:285
> ) at
> org.eclipse.datatools.connectivity.db.generic.JDBCConnection .createConnec
> tion(JDBCConnection.java:87) at
> org.eclipse.datatools.connectivity.DriverConnectionBase.inte rnalCreateCon
> nection(DriverConnectionBase.java:104) at
> org.eclipse.datatools.connectivity.DriverConnectionBase.open (DriverConnec
> tionBase.java:53) at
> org.eclipse.datatools.connectivity.db.generic.JDBCConnection Factory.creat
> eConnection(JDBCConnectionFactory.java:52) at
> org.eclipse.datatools.connectivity.internal.ConnectionFactor yProvider.cre
> ateConnection(ConnectionFactoryProvider.java:77) at
> org.eclipse.datatools.connectivity.internal.ConnectionProfil e.createConne
> ction(ConnectionProfile.java:354) at
> org.eclipse.datatools.connectivity.ui.PingJob.run(PingJob.ja va:57) at
> org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

ok it works now. my connectiono url wasnt right
jdbc:mysql://localhost:3306/database
should have been jdbc:mysql://localhost:3306/avathar_be

now im gonna test further ;)

cheers,
Andy
Previous Topic:Connection wizard - Picture 1.png (1/1)
Next Topic:Getting connection profile content
Goto Forum:
  


Current Time: Thu Sep 18 15:46:19 GMT 2014

Powered by FUDForum. Page generated in 0.10081 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software