Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » SWTBot » [3.5 M7] Test launch problem
[3.5 M7] Test launch problem [message #35095] Fri, 08 May 2009 07:18 Go to next message
Alexey Markevich is currently offline Alexey Markevich
Messages: 18
Registered: July 2009
Junior Member
I tried to run my SWTbot test from eclipse 3.5 M7. On eclipse 3.5 M6 it
works ok. On my test I right click and select Run As - SWT bot.
I receive error "An internal error occurred during: "Launching AllTests".
org.eclipse.pde.internal.ui.launcher.LaunchPluginValidator.g etPluginsToRun(Lorg/eclipse/debug/core/ILaunchConfiguration; )Ljava/util/Map; "
Re: [3.5 M7] Test launch problem [message #35167 is a reply to message #35095] Sat, 09 May 2009 03:43 Go to previous messageGo to next message
Ketan Padegaonkar is currently offline Ketan Padegaonkar
Messages: 873
Registered: July 2009
Senior Member
Fixed as part of https://bugs.eclipse.org/bugs/show_bug.cgi?id=274083.

You may just checkout and build the org.eclipse.swtbot.eclipse.ui plugin
and drop it into your plugins directory if you want to work with 3.5M7.

-- Ketan

On 8/5/09 16:48, Alexey Markevich wrote:
> I tried to run my SWTbot test from eclipse 3.5 M7. On eclipse 3.5 M6 it
> works ok. On my test I right click and select Run As - SWT bot.
> I receive error "An internal error occurred during: "Launching AllTests".
> org.eclipse.pde.internal.ui.launcher.LaunchPluginValidator.g etPluginsToRun(Lorg/eclipse/debug/core/ILaunchConfiguration; )Ljava/util/Map; "
>
>
Re: [3.5 M7] Test launch problem [message #35261 is a reply to message #35167] Mon, 11 May 2009 04:10 Go to previous message
Peter Enevoldsen is currently offline Peter Enevoldsen
Messages: 2
Registered: July 2009
Junior Member
When do you expect this to be in the nightly builds?

-Peter

On 2009-05-09 10:13:15 +0200, Ketan Padegaonkar
<ketanpadegaonkar@gmail.com> said:

> Fixed as part of https://bugs.eclipse.org/bugs/show_bug.cgi?id=274083.
>
> You may just checkout and build the org.eclipse.swtbot.eclipse.ui
> plugin and drop it into your plugins directory if you want to work with
> 3.5M7.
>
> -- Ketan
>
> On 8/5/09 16:48, Alexey Markevich wrote:
>> I tried to run my SWTbot test from eclipse 3.5 M7. On eclipse 3.5 M6 it
>> works ok. On my test I right click and select Run As - SWT bot.
>> I receive error "An internal error occurred during: "Launching AllTests".
>> org.eclipse.pde.internal.ui.launcher.LaunchPluginValidator.g etPluginsToRun(Lorg/eclipse/debug/core/ILaunchConfiguration; )Ljava/util/Map; "


>>
Previous Topic:Eclipse 3.4.2 Ganymede supported by SWTBot?
Next Topic:PDE headless throws java return 13 error
Goto Forum:
  


Current Time: Tue Jul 22 11:37:23 EDT 2014

Powered by FUDForum. Page generated in 0.02513 seconds