Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Getting started with demo agent
Getting started with demo agent [message #34294] Fri, 07 October 2005 13:19 Go to next message
Norbert Plött is currently offline Norbert Plött
Messages: 233
Registered: July 2009
Senior Member
Hello folks,

I am trying to get started with a demo agent and can't quite get things
running. Here is my setup:

- Win XP, eclipse 3.1.1, TPTP 4.0.0 with all the other prerequisites (EMF
....) I can switch to the profiling and logging perspective so I think this
is all o.k.
- eclipseCon demo sources from the TPTP documentation page
( http://www.eclipse.org/tptp/home/documents/eclipseCon2005/Ec lipseCon_2005_Tutorial_22_Source_Code_Antony_Miguel_Paul_Sla uenwhite.zip)
- Imported eclipsecon.tutorial.datacollection and
eclipsecon.tutorial.datacollection.agent projects into the workspace. Fixed
a few compiler errors where package names have changed. I can now run
eclipsecon.tutorial.datacollection.agent as a java application and the agend
keeps telling me that it is not being monitored yet.
- Downloaded and unpacked the windows agent controller, ran SetConfig.bat
but left everything as default. Started the RAServer as an application (from
the command line). It doesn't say anything but keeps running until I kill it
so I guess this must be o.k.
- Create a new eclipseCon Agent launch configuration and leave the host
entry as "localhost". With RAServer and the agent running I start the launch
configuration. Here is the console output:

asked to connect to localhost:10002
connecting to RAC
connected to RAC
problem initialising loader
org.eclipse.hyades.internal.execution.local.control.NoSuchAp plicationException
at
org.eclipse.hyades.internal.execution.local.control.ProcessI mpl.launch(ProcessImpl.java:192)
at
eclipsecon.tutorial.datacollection.AgentLoader$ProcessLaunch .run(AgentLoader.java:302)
at org.eclipse.swt.widgets.Synchronizer.syncExec(Synchronizer.j ava:152)
at org.eclipse.ui.internal.UISynchronizer.syncExec(UISynchroniz er.java:28)
at org.eclipse.swt.widgets.Display.syncExec(Display.java:3413)
at
eclipsecon.tutorial.datacollection.AgentLoader.init(AgentLoa der.java:206)
at
eclipsecon.tutorial.datacollection.AgentLoader.<init>(AgentLoader.java:63)
at
eclipsecon.tutorial.datacollection.launchconfig.AgentLaunche r$StatConRun.run(AgentLauncher.java:106)
at
org.eclipse.ui.internal.UILockListener.doPendingWork(UILockL istener.java:150)
at org.eclipse.ui.internal.UISynchronizer$1.run(UISynchronizer. java:36)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:3 5)
at
org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchr onizer.java:123)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.jav a:3057)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :2716)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.jav a:1699)
....

So I figure:
- The eclipse launch can actually contact the RAServer
- The RAServer does not know anything about the demo Agent, even though it
is running.

How do I get the two acquainted?
Or what else can I do ?


Thanks for reading this far - and for responses!


Norbert Ploett
Re: Getting started with demo agent [message #34327 is a reply to message #34294] Fri, 07 October 2005 13:51 Go to previous messageGo to next message
Eclipse User
Originally posted by: Navid_Mehregani_nmehrega.ca.ibm.com

This is a multipart message in MIME format.
--=_alternative 004C26AA85257093_=
Content-Type: text/plain; charset="US-ASCII"

I haven't worked with that particular demo so I'm not that familiar with
it, but from the stack trace you posted, it seems that the RAC is spitting
out an error message (RA_ERROR_STRING), which causes the
NoSuchApplicationException in ProcessImpl. I'd suggest you first profile
a simple application to make sure your RAC is properly configured. You
can follow the instructions in this document to do that
http://www.eclipse.org/tptp/home/documents/tutorials/profili ngtool/profilingexample_32.html
If that works, then the RAC is having problems launching the agent
specified in the demo (i.e. there is something wrong with the demo.)

Navid Mehregani
IBM Canada
--=_alternative 004C26AA85257093_=
Content-Type: text/html; charset="US-ASCII"


<br><font size=2 face="sans-serif">I haven't worked with that particular
demo so I'm not that familiar with it, but from the stack trace you posted,
it seems that the RAC is spitting out an error message (RA_ERROR_STRING),
which causes the </font><font size=2><tt>NoSuchApplicationException</tt></font><font size=2 face="sans-serif">
in ProcessImpl. &nbsp;I'd suggest you first profile a simple application
to make sure your RAC is properly configured. &nbsp;You can follow the
instructions in this document to do that http://www.eclipse.org/tptp/home/documents/tutorials/profili ngtool/profilingexample_32.html
&nbsp;If that works, then the RAC is having problems launching the agent
specified in the demo (i.e. there is something wrong with the demo.)</font>
<br>
<br><font size=2 face="sans-serif">Navid Mehregani</font>
<br><font size=2 face="sans-serif">IBM Canada</font>
--=_alternative 004C26AA85257093_=--
Re: Getting started with demo agent [message #38122 is a reply to message #34294] Mon, 31 October 2005 13:41 Go to previous message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Hi Norbert,
This sample code was originally written for Hyades v3.2.0 due to a
defect in Hyades v3.1.0. However, the defect has since been fix so with the
appropriate refactoring (see
http://www.eclipse.org/tptp/home/downloads/migrateguide/4.0/ tptp_4_0_migration_guide.html),
it should work in later releases of Hyades/TPTP.

When installing the Agent Controller, did you follow all of the steps in
teh Agent Controller's getting_started.html, including adding the Agent
Controller's bin directory to the system's PATH variable? If so and you can
successfully profile a sample application, please post the Agent
Controller's servicelog.log.

Also, consider using the later release of this sample which is in the
source download for the 'Using and Extending the Test and Performance Tools
Platform' EclipseWorld presentation.

Paul

"Norbert Ploett" <norbert.ploett@siemens.com> wrote in message
news:1128691153.990373@baruth.khe.siemens.de...
> Hello folks,
>
> I am trying to get started with a demo agent and can't quite get things
> running. Here is my setup:
>
> - Win XP, eclipse 3.1.1, TPTP 4.0.0 with all the other prerequisites (EMF
> ...) I can switch to the profiling and logging perspective so I think this
> is all o.k.
> - eclipseCon demo sources from the TPTP documentation page
>
( http://www.eclipse.org/tptp/home/documents/eclipseCon2005/Ec lipseCon_2005_T
utorial_22_Source_Code_Antony_Miguel_Paul_Slauenwhite.zip)
> - Imported eclipsecon.tutorial.datacollection and
> eclipsecon.tutorial.datacollection.agent projects into the workspace.
Fixed
> a few compiler errors where package names have changed. I can now run
> eclipsecon.tutorial.datacollection.agent as a java application and the
agend
> keeps telling me that it is not being monitored yet.
> - Downloaded and unpacked the windows agent controller, ran SetConfig.bat
> but left everything as default. Started the RAServer as an application
(from
> the command line). It doesn't say anything but keeps running until I kill
it
> so I guess this must be o.k.
> - Create a new eclipseCon Agent launch configuration and leave the host
> entry as "localhost". With RAServer and the agent running I start the
launch
> configuration. Here is the console output:
>
> asked to connect to localhost:10002
> connecting to RAC
> connected to RAC
> problem initialising loader
>
org.eclipse.hyades.internal.execution.local.control.NoSuchAp plicationExcepti
on
> at
>
org.eclipse.hyades.internal.execution.local.control.ProcessI mpl.launch(Proce
ssImpl.java:192)
> at
>
eclipsecon.tutorial.datacollection.AgentLoader$ProcessLaunch .run(AgentLoader
..java:302)
> at org.eclipse.swt.widgets.Synchronizer.syncExec(Synchronizer.j ava:152)
> at
org.eclipse.ui.internal.UISynchronizer.syncExec(UISynchroniz er.java:28)
> at org.eclipse.swt.widgets.Display.syncExec(Display.java:3413)
> at
> eclipsecon.tutorial.datacollection.AgentLoader.init(AgentLoa der.java:206)
> at
> eclipsecon.tutorial.datacollection.AgentLoader.<init>(AgentLoader.java:63)
> at
>
eclipsecon.tutorial.datacollection.launchconfig.AgentLaunche r$StatConRun.run
(AgentLauncher.java:106)
> at
>
org.eclipse.ui.internal.UILockListener.doPendingWork(UILockL istener.java:150
)
> at org.eclipse.ui.internal.UISynchronizer$1.run(UISynchronizer. java:36)
> at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:3 5)
> at
>
org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchr onizer.java:123)
> at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.jav a:3057)
> at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :2716)
> at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.jav a:1699)
> ...
>
> So I figure:
> - The eclipse launch can actually contact the RAServer
> - The RAServer does not know anything about the demo Agent, even though it
> is running.
>
> How do I get the two acquainted?
> Or what else can I do ?
>
>
> Thanks for reading this far - and for responses!
>
>
> Norbert Ploett
>
>
Previous Topic:RAServer error ..
Next Topic:How to send and receive CommonBaseEvents?
Goto Forum:
  


Current Time: Mon Oct 20 21:28:19 GMT 2014

Powered by FUDForum. Page generated in 0.01803 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software