Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » JBoss / Eclipse RCP: Could not dereference object
JBoss / Eclipse RCP: Could not dereference object [message #336997] Mon, 20 July 2009 13:10
Robert Wilson is currently offline Robert WilsonFriend
Messages: 1
Registered: July 2009
Junior Member
I have a problem instantiating my remote session bean from my Eclipse RCP
client. I get a nest of 3 exceptions:

javax.naming.NamingException: Could not dereference object
Caused by: java.lang.reflect.UndeclaredThrowableException
Caused by: company.service.SessionRemote

Interestingly, this final exception is thrown from the JBoss
ClassLoaderUtility. It appears to me that JBoss is overriding Eclipse's
ClassLoader, and can't find the relevant class.

This is definetely an Eclipse/JBoss issue - when I run a standalone JUnit
test, all the tests pass. When I run it from an Eclipse plug-in test, it

Has anyone run across this before? (X-Posted to the JBoss forums here: mp;p=4244641#4244641)

Other key points:

* There is no output on the server (i.e. client-side issue)
* Currently both the client and the JBoss server are running from the same


Previous Topic:usage of dropAssistant for org.eclipse.ui.navigator.navigatorContent
Next Topic:How To Extend An Existing Perspective Such As The Web Perspective
Goto Forum:

Current Time: Thu May 24 12:31:37 GMT 2018

Powered by FUDForum. Page generated in 0.01307 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top