Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Trying to get P2 to work
Trying to get P2 to work [message #336945] Wed, 15 July 2009 11:11 Go to next message
Phill Perryman is currently offline Phill PerrymanFriend
Messages: 214
Registered: July 2009
Senior Member
This is a multipart message in MIME format.
--=_alternative 003D7635802575F4_=
Content-Type: text/plain; charset="US-ASCII"

I am trying (with a lot of difficulty) to get my existing 3.3 application
upgraded to using P2 auto updates.

I have migrated to 3.5 and rebuilt the application with all plugins and
features at 2.2.0. Used the export wizard to create the application and
set the p2.inf location to point to the local update site. I also included
all the p2 and ecf plugins to that the standard install and update menu
items appear.

I then update one of the features and plugin to 2.2.1 and build the update
site (build all). The update software menu says there is nothing to update
which I suspect is because of the problem below which gets reported when I
try an install new software.

It lets me know it is already installed at 2.2.0 so it will do an update
instead (great) but then it fails with this cryptic error message. In 3.3
it was fine to have a 2.2.0 and a 2.2.1 version of a feature installed and
eclipse would just load the latest version. Why is this complaining.

Also if anyone knows of a step by step guide to making P2 updating work it
would be appreciated. All the articles so far read say do something but
without telling you exactly what than means.

Your original request has been modified.
"Proposal Generator Custom Editor" is already installed, so an update
will be performed instead.
Cannot complete the install because of a conflicting dependency.
Software being installed: Proposal Generator Custom Editor 2.2.1
(com.mitel.mpg.editor.feature.feature.group 2.2.1)
Software currently installed: com.mitel.swb.Application 2.2.0
Only one of the following can be installed at once:
Proposal Generator Custom Editor 2.2.0
(com.mitel.mpg.editor.feature.feature.jar 2.2.0)
Proposal Generator Custom Editor 2.2.1
(com.mitel.mpg.editor.feature.feature.jar 2.2.1)
Cannot satisfy dependency:
From: Proposal Generator Custom Editor 2.2.0
(com.mitel.mpg.editor.feature.feature.group 2.2.0)
To: com.mitel.mpg.editor.feature.feature.jar [2.2.0]
Cannot satisfy dependency:
From: Proposal Generator Custom Editor 2.2.1
(com.mitel.mpg.editor.feature.feature.group 2.2.1)
To: com.mitel.mpg.editor.feature.feature.jar [2.2.1]
Cannot satisfy dependency:
From: com.mitel.swb.Application 2.2.0
To: com.mitel.mpg.editor.feature.feature.group [2.2.0]
--=_alternative 003D7635802575F4_=
Content-Type: text/html; charset="US-ASCII"


<br><font size=2 face="sans-serif">I am trying (with a lot of difficulty)
to get my existing 3.3 application upgraded to using P2 auto updates.</font>
<br>
<br><font size=2 face="sans-serif">I have migrated to 3.5 and rebuilt the
application with all plugins and features at 2.2.0. Used the export wizard
to create the application and set the p2.inf location to point to the local
update site. I also included all the p2 and ecf plugins to that the standard
install and update menu items appear.</font>
<br>
<br><font size=2 face="sans-serif">I then update one of the features and
plugin to 2.2.1 and build the update site (build all). The update software
menu says there is nothing to update which I suspect is because of the
problem below which gets reported when I try an install new software.</font>
<br>
<br><font size=2 face="sans-serif">It lets me know it is already installed
at 2.2.0 so it will do an update instead (great) but then it fails with
this cryptic error message. In 3.3 it was fine to have a 2.2.0 and a 2.2.1
version of a feature installed and eclipse would just load the latest version.
Why is this complaining.</font>
<br>
<br><font size=2 face="sans-serif">Also if anyone knows of a step by step
guide to making P2 updating work it would be appreciated. All the articles
so far read say do something but without telling you exactly what than
means.</font>
<br>
<br><font size=2 face="sans-serif">Your original request has been modified.</font>
<br><font size=2 face="sans-serif">&nbsp; &quot;Proposal Generator &nbsp;Custom
Editor&quot; is already installed, so an update will be performed instead.</font>
<br><font size=2 face="sans-serif">Cannot complete the install because
of a conflicting dependency.</font>
<br><font size=2 face="sans-serif">&nbsp; Software being installed: Proposal
Generator &nbsp;Custom Editor 2.2.1 (com.mitel.mpg.editor.feature.feature.group
2.2.1)</font>
<br><font size=2 face="sans-serif">&nbsp; Software currently installed:
com.mitel.swb.Application 2.2.0</font>
<br><font size=2 face="sans-serif">&nbsp; Only one of the following can
be installed at once: </font>
<br><font size=2 face="sans-serif">&nbsp; &nbsp; Proposal Generator &nbsp;Custom
Editor 2.2.0 (com.mitel.mpg.editor.feature.feature.jar 2.2.0)</font>
<br><font size=2 face="sans-serif">&nbsp; &nbsp; Proposal Generator &nbsp;Custom
Editor 2.2.1 (com.mitel.mpg.editor.feature.feature.jar 2.2.1)</font>
<br><font size=2 face="sans-serif">&nbsp; Cannot satisfy dependency:</font>
<br><font size=2 face="sans-serif">&nbsp; &nbsp; From: Proposal Generator
&nbsp;Custom Editor 2.2.0 (com.mitel.mpg.editor.feature.feature.group 2.2.0)</font>
<br><font size=2 face="sans-serif">&nbsp; &nbsp; To: com.mitel.mpg.editor.feature.feature.jar
[2.2.0]</font>
<br><font size=2 face="sans-serif">&nbsp; Cannot satisfy dependency:</font>
<br><font size=2 face="sans-serif">&nbsp; &nbsp; From: Proposal Generator
&nbsp;Custom Editor 2.2.1 (com.mitel.mpg.editor.feature.feature.group 2.2.1)</font>
<br><font size=2 face="sans-serif">&nbsp; &nbsp; To: com.mitel.mpg.editor.feature.feature.jar
[2.2.1]</font>
<br><font size=2 face="sans-serif">&nbsp; Cannot satisfy dependency:</font>
<br><font size=2 face="sans-serif">&nbsp; &nbsp; From: com.mitel.swb.Application
2.2.0</font>
<br><font size=2 face="sans-serif">&nbsp; &nbsp; To: com.mitel.mpg.editor.feature.feature.group
[2.2.0]</font>
--=_alternative 003D7635802575F4_=--
Re: Trying to get P2 to work [message #336951 is a reply to message #336945] Wed, 15 July 2009 17:27 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: fakemail.xyz.de

instead of using exported features / update site ...
use the repository build when exporting the product as update site.

it seems like you can only update features not part of the product by
themselve (easiest by exporting them from the features page and a
category.xml file not with an update site project)

Christian

Phill_Perryman@Mitel.COM schrieb:
>
> I am trying (with a lot of difficulty) to get my existing 3.3
> application upgraded to using P2 auto updates.
>
> I have migrated to 3.5 and rebuilt the application with all plugins and
> features at 2.2.0. Used the export wizard to create the application and
> set the p2.inf location to point to the local update site. I also
> included all the p2 and ecf plugins to that the standard install and
> update menu items appear.
>
> I then update one of the features and plugin to 2.2.1 and build the
> update site (build all). The update software menu says there is nothing
> to update which I suspect is because of the problem below which gets
> reported when I try an install new software.
>
> It lets me know it is already installed at 2.2.0 so it will do an update
> instead (great) but then it fails with this cryptic error message. In
> 3.3 it was fine to have a 2.2.0 and a 2.2.1 version of a feature
> installed and eclipse would just load the latest version. Why is this
> complaining.
>
> Also if anyone knows of a step by step guide to making P2 updating work
> it would be appreciated. All the articles so far read say do something
> but without telling you exactly what than means.
>
> Your original request has been modified.
> "Proposal Generator Custom Editor" is already installed, so an update
> will be performed instead.
> Cannot complete the install because of a conflicting dependency.
> Software being installed: Proposal Generator Custom Editor 2.2.1
> (com.mitel.mpg.editor.feature.feature.group 2.2.1)
> Software currently installed: com.mitel.swb.Application 2.2.0
> Only one of the following can be installed at once:
> Proposal Generator Custom Editor 2.2.0
> (com.mitel.mpg.editor.feature.feature.jar 2.2.0)
> Proposal Generator Custom Editor 2.2.1
> (com.mitel.mpg.editor.feature.feature.jar 2.2.1)
> Cannot satisfy dependency:
> From: Proposal Generator Custom Editor 2.2.0
> (com.mitel.mpg.editor.feature.feature.group 2.2.0)
> To: com.mitel.mpg.editor.feature.feature.jar [2.2.0]
> Cannot satisfy dependency:
> From: Proposal Generator Custom Editor 2.2.1
> (com.mitel.mpg.editor.feature.feature.group 2.2.1)
> To: com.mitel.mpg.editor.feature.feature.jar [2.2.1]
> Cannot satisfy dependency:
> From: com.mitel.swb.Application 2.2.0
> To: com.mitel.mpg.editor.feature.feature.group [2.2.0]
Re: Trying to get P2 to work [message #336959 is a reply to message #336951] Thu, 16 July 2009 07:54 Go to previous messageGo to next message
Phill Perryman is currently offline Phill PerrymanFriend
Messages: 214
Registered: July 2009
Senior Member
This is a multipart message in MIME format.
--=_alternative 002B7213802575F5_=
Content-Type: text/plain; charset="US-ASCII"

I used te repository instead and I found I had to push up the version in
the .product file as well as a bundle then it will update from there.
Thanks for the pointer.
--=_alternative 002B7213802575F5_=
Content-Type: text/html; charset="US-ASCII"


<br><font size=2 face="sans-serif">I used te repository instead and I found
I had to push up the version in the .product file as well as a bundle then
it will update from there. Thanks for the pointer.</font>
--=_alternative 002B7213802575F5_=--
Re: Trying to get P2 to work [message #336999 is a reply to message #336959] Mon, 20 July 2009 15:06 Go to previous messageGo to next message
Andrew Niefer is currently offline Andrew NieferFriend
Messages: 990
Registered: July 2009
Senior Member
Phill_Perryman@Mitel.COM wrote:
>
> I used te repository instead and I found I had to push up the version in
> the .product file as well as a bundle then it will update from there.
> Thanks for the pointer.

You might find this interesting:
http://aniefer.blogspot.com/2009/07/composing-and-updating-c ustom-eclipse.html
Re: Trying to get P2 to work [message #337001 is a reply to message #336999] Mon, 20 July 2009 18:17 Go to previous message
Eclipse UserFriend
Originally posted by: fakemail.xyz.de

Andrew Niefer schrieb:
> Phill_Perryman@Mitel.COM wrote:
>>
>> I used te repository instead and I found I had to push up the version
>> in the .product file as well as a bundle then it will update from
>> there. Thanks for the pointer.
>
> You might find this interesting:
> http://aniefer.blogspot.com/2009/07/composing-and-updating-c ustom-eclipse.html
>

He probably has seen that already..
Andrew I fear without your Blog nobody on this planet can get P2 to work.
Previous Topic:Programmatic menus
Next Topic:How To Extend An Existing Perspective Such As The Web Perspective
Goto Forum:
  


Current Time: Thu Nov 27 14:51:48 GMT 2014

Powered by FUDForum. Page generated in 0.02359 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software