Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » How to extend an update site reliably and easily ?
How to extend an update site reliably and easily ? [message #336891] Fri, 10 July 2009 06:47
Kristof Szabados is currently offline Kristof SzabadosFriend
Messages: 69
Registered: July 2009
Member
The situation:
I have an internal update site, that I wish to extend incrementally,
whenever a bug gets fixed ... but this is becoming harder and harder.

In eclipse 3.2: I built the new version of my feature, copied it t the
update site and updated the site.xml there.

In eclipse 3.3-3.4: I downloaded the site.xml, content.xml and
artifacts.xml to my computer, built my feature and copied the new
binaries and *.xml files back.
/* If the content.xml and artifacts.xml was not filled out the features
sometimes did not appear */

In eclipse 3.5: I download the *.xml files, build my feature ... edit
the artifacts.xml and content.xml so that the name of the site stays the
same (it is always renamed at build to be ${p2...}, and my users did not
like that naming convention). Copy back the new binaries and *.xml files.
And even so when grouping is enabled at the user he will not see any of
the new version ... although when building the site I placed them in the
same category.

Can anyone give me any information on how I can update my update site,
in an easy and fast way, so that users actually see the new items
(preferably in the category I put them into)?
And as an extra: the final site used by the users should look the same
way for eclipse 3.2 - 3.5 /* backward compatibility */.

Is this possible at all?

As a side note, as jars produced by eclipse 3.3 or newer are not working
for me on eclipse 3.2 I have to build the binaries in 3.2 anyway ... but
to update the structure of the update site, I have to build the features
in 3.4, or 3.5 too /* I just can't fill in those xml -s by hand */

Best Regards
Kristof
Previous Topic:Displaying the "About" box in my feature based RCP makes all bundles change into INSTALLED
Next Topic:Where is the eclipse.buildId property set?
Goto Forum:
  


Current Time: Tue Nov 25 01:55:13 GMT 2014

Powered by FUDForum. Page generated in 0.02376 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software