Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Eclipse freezes after stopping at breakpoint in a static block
Eclipse freezes after stopping at breakpoint in a static block [message #336796] Fri, 03 July 2009 06:51 Go to next message
Thomas Wiedmann is currently offline Thomas Wiedmann
Messages: 69
Registered: July 2009
Member
Hello,

trying to debug code written in Java 5 I set a breakpoint within a static
block like

static {
x Java statements
}

The x indicates the breakpoint. Debugging the application it really stopped
at the breakpoint and for a short moment I could even see the stacktrace of
the thread. Afterwards - without any further interaction - the screen became
white and Eclipse hang. There was no chance to access Eclipse in order to
continue the debug run.

What may be the reason for this behaviour, which I only observed with the
breakpoint the static block, or how can the cause be determined?
How can it be avoided, that Eclipse suddenly hangs after stopping at the
breakpoint?
I work with Eclipse 3.4.2.

Thomas Wiedmann
Re: Eclipse freezes after stopping at breakpoint in a static block [message #336812 is a reply to message #336796] Fri, 03 July 2009 18:27 Go to previous messageGo to next message
Eclipse User
Originally posted by: eclipse-news.rizzoweb.com

Thomas Wiedmann wrote:
> Hello,
>
> trying to debug code written in Java 5 I set a breakpoint within a
> static block like
>
> static {
> x Java statements
> }
>
> The x indicates the breakpoint. Debugging the application it really
> stopped at the breakpoint and for a short moment I could even see the
> stacktrace of the thread. Afterwards - without any further interaction -
> the screen became white and Eclipse hang. There was no chance to access
> Eclipse in order to continue the debug run.
>
> What may be the reason for this behaviour, which I only observed with
> the breakpoint the static block, or how can the cause be determined?
> How can it be avoided, that Eclipse suddenly hangs after stopping at the
> breakpoint?
> I work with Eclipse 3.4.2.

I tried to reproduce this in both 3.4.2 and 3.5 but it works just fine.
Can you provide more detailed steps to reproduce it?
Some information that would be useful:
What OS are you using? What JVM? Have you specified in eclipse.ini what
JVM it should use?

Eric
Re: Eclipse freezes after stopping at breakpoint in a static block [message #336825 is a reply to message #336812] Mon, 06 July 2009 06:40 Go to previous message
Thomas Wiedmann is currently offline Thomas Wiedmann
Messages: 69
Registered: July 2009
Member
> I tried to reproduce this in both 3.4.2 and 3.5 but it works just fine.
> Can you provide more detailed steps to reproduce it?
> Some information that would be useful:
> What OS are you using? What JVM? Have you specified in eclipse.ini what
> JVM it should use?

When trying it again, I couldn't reproduce that problem case, too. Sorry.
I suppose, the problem, observed recently, must have another reason - I'll
observe, whether it would happen again.

Thomas Wiedmann
Previous Topic:How to programmatically remove all files during / after uninstall?
Next Topic:qualifier replacement in site.xml
Goto Forum:
  


Current Time: Tue Oct 21 08:56:12 GMT 2014

Powered by FUDForum. Page generated in 0.02529 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software