Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » I found a bug, not sure what todo
I found a bug, not sure what todo [message #336740] Tue, 30 June 2009 08:10 Go to next message
Alessandro Carraro is currently offline Alessandro Carraro
Messages: 27
Registered: July 2009
Junior Member
Hi, I've found a very little bug, but I don't know what to do.

Since I'm new to plugin development, I'm not 100% sure that it is a bug or
I've done an error, and I don't want to mae an Eclipse developer waste his
time because I reported a fake error.
Everithing that is foolowing in this post is in my VERY HUMBLE opinion

The error is in the class
org.eclipse.ui.texteditor.AbstractDecoratedTextEditor and affect the
method gotoMarker(IMarker);

(next to last row of method ):

if (end - 1 < length && start < length)

The error IMHO is that '-1'. I've found that the goto works if start==end
(this means that it is a simple move of the caret, while start!=end means
a goto+text selection

However, the -1 prevents the goto to go to the end of the file (I needed
in my plugin to open an editor at the end of a file so the user can start
appending text without any other keystroke)

Should I post a bug to bugzilla, or even put a patch? Is there any
official reference about eclipse contributing, may you provide link?

thanks

Alex
Re: I found a bug, not sure what todo [message #336741 is a reply to message #336740] Tue, 30 June 2009 08:41 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 26137
Registered: July 2009
Senior Member
This is a multi-part message in MIME format.
--------------020807090407030600010107
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 7bit

Alex,

It sounds like a bug to be able to move anywhere except past the last
character. Your description is simple enough that a bugzilla with this
information should be sufficient. Because the fix is also trivial, a
patch shouldn't make a significant difference. The getting involved
link on this page doesn't provide much help

http://www.eclipse.org/users/

Perhaps there's a better one, but it's not easy to find...


Alessandro Carraro wrote:
> Hi, I've found a very little bug, but I don't know what to do.
> Since I'm new to plugin development, I'm not 100% sure that it is a
> bug or I've done an error, and I don't want to mae an Eclipse
> developer waste his time because I reported a fake error.
> Everithing that is foolowing in this post is in my VERY HUMBLE opinion
>
> The error is in the class
> org.eclipse.ui.texteditor.AbstractDecoratedTextEditor and affect the
> method gotoMarker(IMarker);
>
> (next to last row of method ):
>
> if (end - 1 < length && start < length)
>
> The error IMHO is that '-1'. I've found that the goto works if
> start==end (this means that it is a simple move of the caret, while
> start!=end means a goto+text selection
>
> However, the -1 prevents the goto to go to the end of the file (I
> needed in my plugin to open an editor at the end of a file so the user
> can start appending text without any other keystroke)
>
> Should I post a bug to bugzilla, or even put a patch? Is there any
> official reference about eclipse contributing, may you provide link?
>
> thanks
>
> Alex
>

--------------020807090407030600010107
Content-Type: text/html; charset=ISO-8859-15
Content-Transfer-Encoding: 8bit

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html;charset=ISO-8859-15"
http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Alex,<br>
<br>
It sounds like a bug to be able to move anywhere except past the last
character.
Re: I found a bug, not sure what todo [message #336746 is a reply to message #336741] Tue, 30 June 2009 13:30 Go to previous message
Alessandro Carraro is currently offline Alessandro Carraro
Messages: 27
Registered: July 2009
Junior Member
Ok became a bug

https://bugs.eclipse.org/bugs/show_bug.cgi?id=281978
Previous Topic:Eclipse startup peformance
Next Topic:Generation build.xml programatically
Goto Forum:
  


Current Time: Thu Oct 23 03:11:10 GMT 2014

Powered by FUDForum. Page generated in 0.16930 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software