Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Problem with Galileo
Problem with Galileo [message #336615] Thu, 25 June 2009 09:34 Go to next message
Patrick Gell is currently offline Patrick Gell
Messages: 15
Registered: July 2009
Junior Member
Hello,

I installed the new Galileo release and have a problem. Everytime I
start eclipse it starts with the workspace @user_home/workspace.
In Preferences the checkbox "Prompt for workspace on startup" is marked.
What can I do that the select workspace dialog appears on startup?

regards,
patrick
Re: Problem with Galileo [message #336618 is a reply to message #336615] Thu, 25 June 2009 11:07 Go to previous messageGo to next message
Dani Megert is currently offline Dani Megert
Messages: 3801
Registered: July 2009
Senior Member
Patrick Gell wrote:
> Hello,
>
> I installed the new Galileo release and have a problem. Everytime I
> start eclipse it starts with the workspace @user_home/workspace.
> In Preferences the checkbox "Prompt for workspace on startup" is
> marked. What can I do that the select workspace dialog appears on
> startup?
Make sure you don't start with the -data command line option.

Dani
>
> regards,
> patrick
Re: Problem with Galileo [message #336619 is a reply to message #336618] Thu, 25 June 2009 12:29 Go to previous messageGo to next message
Patrick Gell is currently offline Patrick Gell
Messages: 15
Registered: July 2009
Junior Member
Hello,

my command line options are following:
-startup
plugins/org.eclipse.equinox.launcher_1.0.200.v20090520.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.0.200 .v20090519
-product
org.eclipse.epp.package.rcp.product
--launcher.XXMaxPermSize
256M
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Xms40m
-Xmx512m

So there ist no -data option.

regards,
patrick


Daniel Megert schrieb:
> Patrick Gell wrote:
>> Hello,
>>
>> I installed the new Galileo release and have a problem. Everytime I
>> start eclipse it starts with the workspace @user_home/workspace.
>> In Preferences the checkbox "Prompt for workspace on startup" is
>> marked. What can I do that the select workspace dialog appears on
>> startup?
> Make sure you don't start with the -data command line option.
>
> Dani
>>
>> regards,
>> patrick
Re: Problem with Galileo [message #336632 is a reply to message #336619] Thu, 25 June 2009 15:13 Go to previous messageGo to next message
Andrew Niefer is currently offline Andrew Niefer
Messages: 990
Registered: July 2009
Senior Member
Does your eclipse/configuration/config.ini specify a value for
"osgi.instance.area"?

That is another way of specifying the workspace location.
-Andrew

Patrick Gell wrote:
> Hello,
>
> my command line options are following:
> -startup
> plugins/org.eclipse.equinox.launcher_1.0.200.v20090520.jar
> --launcher.library
> plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.0.200 .v20090519
> -product
> org.eclipse.epp.package.rcp.product
> --launcher.XXMaxPermSize
> 256M
> -showsplash
> org.eclipse.platform
> --launcher.XXMaxPermSize
> 256m
> -showsplash
> org.eclipse.platform
> --launcher.XXMaxPermSize
> 256m
> -showsplash
> org.eclipse.platform
> --launcher.XXMaxPermSize
> 256m
> -vmargs
> -Dosgi.requiredJavaVersion=1.5
> -Xms40m
> -Xmx512m
>
> So there ist no -data option.
>
> regards,
> patrick
>
>
> Daniel Megert schrieb:
>> Patrick Gell wrote:
>>> Hello,
>>>
>>> I installed the new Galileo release and have a problem. Everytime I
>>> start eclipse it starts with the workspace @user_home/workspace.
>>> In Preferences the checkbox "Prompt for workspace on startup" is
>>> marked. What can I do that the select workspace dialog appears on
>>> startup?
>> Make sure you don't start with the -data command line option.
>>
>> Dani
>>>
>>> regards,
>>> patrick
Re: Problem with Galileo [message #336656 is a reply to message #336632] Fri, 26 June 2009 07:22 Go to previous message
Patrick Gell is currently offline Patrick Gell
Messages: 15
Registered: July 2009
Junior Member
No, there is no osgi.instance.area in my config.ini


#This configuration file was written by:
org.eclipse.equinox.internal.frameworkadmin.equinox.EquinoxF wConfigFileParser
#Thu Jun 25 15:00:44 CEST 2009
org.eclipse.update.reconcile=false
eclipse.p2.profile=epp.package.rcp
osgi.framework=file\:plugins/org.eclipse.osgi_3.5.0.v2009052 0.jar
eclipse.buildId=I20090611-1540
osgi.bundles=reference\:file\: org.eclipse.equinox.simpleconfigurator_1.0.100.v20090520-190 5.jar @1\:start
org.eclipse.equinox.simpleconfigurator.configUrl=file\:org.e clipse.equinox.simpleconfigurator/bundles.info
eclipse.product=org.eclipse.sdk.ide
osgi.splashPath=platform\:/base/plugins/org.eclipse.platform
osgi.framework.extensions=reference\:file\:javax.transaction _1.1.1.v200906161300.jar,reference\:file\:org.eclipse.persis tence.jpa.equinox.weaving_1.1.2.v20090612-r4475.jar
osgi.bundles.defaultStartLevel=4
eclipse.application=org.eclipse.ui.ide.workbench
eclipse.p2.data.area=@config.dir/../p2/

patrick


Andrew Niefer schrieb:
> Does your eclipse/configuration/config.ini specify a value for
> "osgi.instance.area"?
>
> That is another way of specifying the workspace location.
> -Andrew
>
> Patrick Gell wrote:
>> Hello,
>>
>> my command line options are following:
>> -startup
>> plugins/org.eclipse.equinox.launcher_1.0.200.v20090520.jar
>> --launcher.library
>> plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.0.200 .v20090519
>> -product
>> org.eclipse.epp.package.rcp.product
>> --launcher.XXMaxPermSize
>> 256M
>> -showsplash
>> org.eclipse.platform
>> --launcher.XXMaxPermSize
>> 256m
>> -showsplash
>> org.eclipse.platform
>> --launcher.XXMaxPermSize
>> 256m
>> -showsplash
>> org.eclipse.platform
>> --launcher.XXMaxPermSize
>> 256m
>> -vmargs
>> -Dosgi.requiredJavaVersion=1.5
>> -Xms40m
>> -Xmx512m
>>
>> So there ist no -data option.
>>
>> regards,
>> patrick
>>
>>
>> Daniel Megert schrieb:
>>> Patrick Gell wrote:
>>>> Hello,
>>>>
>>>> I installed the new Galileo release and have a problem. Everytime I
>>>> start eclipse it starts with the workspace @user_home/workspace.
>>>> In Preferences the checkbox "Prompt for workspace on startup" is
>>>> marked. What can I do that the select workspace dialog appears on
>>>> startup?
>>> Make sure you don't start with the -data command line option.
>>>
>>> Dani
>>>>
>>>> regards,
>>>> patrick
Previous Topic:Why some items aren't uninstallable with galileo?
Next Topic:eclipse debug platform: starting directly in suspend mode and connecting variable view
Goto Forum:
  


Current Time: Sat Nov 01 00:36:05 GMT 2014

Powered by FUDForum. Page generated in 0.03655 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software