Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Eclipse 3.x for AIX 5.3
Eclipse 3.x for AIX 5.3 [message #336567] Tue, 23 June 2009 22:15 Go to next message
Barbara Iszard is currently offline Barbara Iszard
Messages: 2
Registered: July 2009
Junior Member
I have ownership of installing Eclipse on a couple AIX 5.3 servers. I have
2 elementary questions that I'm hoping someone can answer.

Question 1)
When I go to download eclipse-SDK-3.x.x-aix-motif.zip I get a message that
says:

To run Eclipse on AIX, you must ensure that your AIX install includes the
necessary filesets and service updates. Please use the following command
to determine the service level of an AIX fileset on your machine:
lslpp -l | grep FilesetName

Please see the section below that corresponds to your AIX release.

All AIX releases:
Fileset X11.adt.lib must be installed (this is available on the AIX
installation media).

AIX Version 4.3.3:
For fileset X11.base.lib:
If service level < 4.3.3.79, you must apply APAR IY27694
For fileset X11.motif.lib:
If service level > 4.3.3.81, you must apply APAR IY41939

AIX Version 5.1:
For fileset X11.base.lib:
If service level < 5.1.0.25, you must apply APAR IY27695
For fileset X11.motif.lib:
If service level > 5.1.0.36, you must apply APAR IY41942

AIX Version 5.2:
For fileset X11.motif.lib:
If service level > 5.2.0.0, you must apply APAR IY41944

Is there really no requirement for AIX Version 5.3? Or is it just that
it's not compatible with AIX 5.3 or something else?

Question 2:
I'm suspicious of the download because it is a zip file. When I open it in
Windows it looks like it would install to Windows directories (ie. the
slashes in the path are going the wrong direction). Normally compressed
AIX files end in TAR or gz. That is the case for the Eclipse download
files for Linux. Am I missing something?

Any help would be appreciated
Re: Eclipse 3.x for AIX 5.3 [message #336598 is a reply to message #336567] Wed, 24 June 2009 17:36 Go to previous messageGo to next message
Andrew Niefer is currently offline Andrew Niefer
Messages: 990
Registered: July 2009
Senior Member
I don't know much about AIX. It could just be that the download note
just hasn't been updated recently. You should ask on
eclipse.platform.swt, I think they take care of that download message.

As for the archive, the back slashes are likely just because you are
looking at it on windows. The archive itself would have been created on
linux. I see this:

/eclipse/zips> unzip -l eclipse-SDK-3.5-aix-motif.zip
Archive: eclipse-SDK-3.5-aix-motif.zip
Length Date Time Name
-------- ---- ---- ----
0 06-11-09 18:57 eclipse/
6506 03-17-05 17:12 eclipse/notice.html
0 06-11-09 18:57 eclipse/configuration/
817 06-11-09 18:57 eclipse/configuration/config.ini
0 06-11-09 18:57 eclipse/configuration/org.eclipse.update/
.......

-Andrew
Barbara Iszard wrote:
> I have ownership of installing Eclipse on a couple AIX 5.3 servers. I
> have 2 elementary questions that I'm hoping someone can answer.
>
> Question 1)
> When I go to download eclipse-SDK-3.x.x-aix-motif.zip I get a message
> that says:
>
> To run Eclipse on AIX, you must ensure that your AIX install includes
> the necessary filesets and service updates. Please use the following
> command
> to determine the service level of an AIX fileset on your machine:
> lslpp -l | grep FilesetName
>
> Please see the section below that corresponds to your AIX release.
>
> All AIX releases:
> Fileset X11.adt.lib must be installed (this is available on the AIX
> installation media).
>
> AIX Version 4.3.3:
> For fileset X11.base.lib:
> If service level < 4.3.3.79, you must apply APAR IY27694 For
> fileset X11.motif.lib:
> If service level > 4.3.3.81, you must apply APAR IY41939
> AIX Version 5.1:
> For fileset X11.base.lib:
> If service level < 5.1.0.25, you must apply APAR IY27695
> For fileset X11.motif.lib:
> If service level > 5.1.0.36, you must apply APAR IY41942
>
> AIX Version 5.2:
> For fileset X11.motif.lib:
> If service level > 5.2.0.0, you must apply APAR IY41944
>
> Is there really no requirement for AIX Version 5.3? Or is it just that
> it's not compatible with AIX 5.3 or something else?
>
> Question 2:
> I'm suspicious of the download because it is a zip file. When I open it
> in Windows it looks like it would install to Windows directories (ie.
> the slashes in the path are going the wrong direction). Normally
> compressed AIX files end in TAR or gz. That is the case for the Eclipse
> download files for Linux. Am I missing something?
> Any help would be appreciated
>
>
Re: Eclipse 3.x for AIX 5.3 [message #336599 is a reply to message #336598] Wed, 24 June 2009 17:47 Go to previous messageGo to next message
Andrew Niefer is currently offline Andrew Niefer
Messages: 990
Registered: July 2009
Senior Member
I just talked to an SWT committer, our AIX drop is actually built on
5.3, so it will work there. He wasn't sure about the APARs, but he
thought you might be good to go straight out of the box.

-Andrew

Andrew Niefer wrote:
> I don't know much about AIX. It could just be that the download note
> just hasn't been updated recently. You should ask on
> eclipse.platform.swt, I think they take care of that download message.
>
> As for the archive, the back slashes are likely just because you are
> looking at it on windows. The archive itself would have been created on
> linux. I see this:
>
> /eclipse/zips> unzip -l eclipse-SDK-3.5-aix-motif.zip
> Archive: eclipse-SDK-3.5-aix-motif.zip
> Length Date Time Name
> -------- ---- ---- ----
> 0 06-11-09 18:57 eclipse/
> 6506 03-17-05 17:12 eclipse/notice.html
> 0 06-11-09 18:57 eclipse/configuration/
> 817 06-11-09 18:57 eclipse/configuration/config.ini
> 0 06-11-09 18:57 eclipse/configuration/org.eclipse.update/
> ......
>
> -Andrew
> Barbara Iszard wrote:
>> I have ownership of installing Eclipse on a couple AIX 5.3 servers. I
>> have 2 elementary questions that I'm hoping someone can answer.
>>
>> Question 1)
>> When I go to download eclipse-SDK-3.x.x-aix-motif.zip I get a message
>> that says:
>>
>> To run Eclipse on AIX, you must ensure that your AIX install includes
>> the necessary filesets and service updates. Please use the following
>> command
>> to determine the service level of an AIX fileset on your machine:
>> lslpp -l | grep FilesetName
>>
>> Please see the section below that corresponds to your AIX release.
>>
>> All AIX releases:
>> Fileset X11.adt.lib must be installed (this is available on the AIX
>> installation media).
>>
>> AIX Version 4.3.3:
>> For fileset X11.base.lib:
>> If service level < 4.3.3.79, you must apply APAR IY27694
>> For fileset X11.motif.lib:
>> If service level > 4.3.3.81, you must apply APAR IY41939
>> AIX Version 5.1:
>> For fileset X11.base.lib:
>> If service level < 5.1.0.25, you must apply APAR IY27695
>> For fileset X11.motif.lib:
>> If service level > 5.1.0.36, you must apply APAR IY41942
>>
>> AIX Version 5.2:
>> For fileset X11.motif.lib:
>> If service level > 5.2.0.0, you must apply APAR IY41944
>>
>> Is there really no requirement for AIX Version 5.3? Or is it just that
>> it's not compatible with AIX 5.3 or something else?
>>
>> Question 2:
>> I'm suspicious of the download because it is a zip file. When I open
>> it in Windows it looks like it would install to Windows directories
>> (ie. the slashes in the path are going the wrong direction). Normally
>> compressed AIX files end in TAR or gz. That is the case for the
>> Eclipse download files for Linux. Am I missing something?
>> Any help would be appreciated
>>
>>
Re: Eclipse 3.x for AIX 5.3 [message #336604 is a reply to message #336599] Wed, 24 June 2009 22:27 Go to previous message
Barbara Iszard is currently offline Barbara Iszard
Messages: 2
Registered: July 2009
Junior Member
Thanks for your reply. I've seen a number of postings of Eclipse 3.2 and
AIX 5.3 issues so I'm planning to go with Eclipse 3.0. That's what's
recommended for the app that I'm planning to plug into anyway.

I'm still confused as to why the Eclipse folks would tar the Linux install
and not the AIX install. Because the AIX installs are zipped I now have to
go find some unzip software and get it approved to be installed on the AIX
servers.

I'll get over it.
Previous Topic:Delta pack not working in 3.5
Next Topic:Treeview with Documents as node
Goto Forum:
  


Current Time: Thu Oct 30 19:15:44 GMT 2014

Powered by FUDForum. Page generated in 0.01684 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software