Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » eclipse.ini listing very specific plugins - problem when updating ?
eclipse.ini listing very specific plugins - problem when updating ? [message #336342] Tue, 09 June 2009 05:52 Go to next message
Eclipse User
Originally posted by: max.andersen.redhat.com

Hi,

This might have been an old change but I just recently noticed it since
it caused our products not to launch properly on Galileo build.

eclipse.ini now contains 2 very specific plugin references:

-startup
plugins/org.eclipse.equinox.launcher_1.0.200.v20090520.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.0.200 .v20090519

And if you don't list them eclipse won't start and we work around this
by using the specific names in the build.

So..

1) What is the reason for these two entries ? Why are they needed for
Galileo, but not for Ganymede ?

2) How is updates of these two entries handled by p2 ?

/max
Re: eclipse.ini listing very specific plugins - problem when updating ? [message #336365 is a reply to message #336342] Tue, 09 June 2009 13:44 Go to previous message
Andrew Niefer is currently offline Andrew Niefer
Messages: 990
Registered: July 2009
Senior Member
In general, an install may contain multiple versions of the launchers.
Either because the install has been updated/reverted a few times, or
perhaps bundle pooling is being used and multiple products are sharing
the plugins folder.

The point of view of the launcher, these arguments are only strictly
necessary if the launchers aren't going to be found in the default
locations or if you don't want the highest version that is found.
However, p2 may be using these arguments (particularly on the mac) to
figure out what it needs to write in the config.ini

The metadata for a product is generally going to express a dependency on
a certain version of the launchers. The product will also include
configuration IUs that set the -startup and --launcher.library arguments
automatically.

p2 will automatically update the eclipse.ini based on the metadata.

For the SDK, to see the metadata that sets these arguments, look at the
highest versioned
eclipse/p2/org.eclipse.equinox.p2.engine/profileRegistry/SDK Profile.profile/*.profile

In there do a search on
toolingorg.eclipse.equinox.launcher
toolingorg.eclipse.equinox.launcher.win32.win32.x86

Max Rydahl Andersen wrote:
> Hi,
>
> This might have been an old change but I just recently noticed it since
> it caused our products not to launch properly on Galileo build.
>
> eclipse.ini now contains 2 very specific plugin references:
>
> -startup
> plugins/org.eclipse.equinox.launcher_1.0.200.v20090520.jar
> --launcher.library
> plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.0.200 .v20090519
>
> And if you don't list them eclipse won't start and we work around this
> by using the specific names in the build.
>
> So..
>
> 1) What is the reason for these two entries ? Why are they needed for
> Galileo, but not for Ganymede ?
>
> 2) How is updates of these two entries handled by p2 ?
>
> /max
Previous Topic:Dynamic visibility toolbar button
Next Topic:Downloaded Eclipse 3.4.2 JST version--but no Eclipse source plugins included.
Goto Forum:
  


Current Time: Fri Jul 25 07:30:26 EDT 2014

Powered by FUDForum. Page generated in 0.02349 seconds