Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » getWebBrowser returns null
getWebBrowser returns null [message #336305] Fri, 05 June 2009 14:58 Go to next message
Kim Starks is currently offline Kim Starks
Messages: 1
Registered: July 2009
Junior Member
I need to use Mozilla as the underlying rederer because I need to be able
to do the following with the browser:
Know when the user has selected text (or double-clicked) and get it
Search within the web page
Add custom context menu capabilities
etc.

System
Windows XP SP2
Eclipse 3.4.1
XUL Runner 1.9 (registered with register-global)

The project is a plug-in.

I created the browser with
browser = new Browser(comp, SWT.BORDER|SWT.MOZILLA);

When I call browser.getWebBrowser() I get null back.

I found another post on this board that indicated that I needed to add the
following to my manifest.mf:
DynamicImport-Package: org.mozilla.xpcom

This hasn't resolved my problem.

I'm just creating a simple sample right now. Working from the samples
from

http://www.apress.com/book/downloadfile/4330

ch02.WebBrowser is the project I'm working with. Any ideas as to what the
issue is?

Kim Starks
Re: getWebBrowser returns null [message #336323 is a reply to message #336305] Mon, 08 June 2009 16:02 Go to previous message
Grant Gayed is currently offline Grant Gayed
Messages: 2150
Registered: July 2009
Senior Member
Does http://www.eclipse.org/swt/faq.php#howusejavaxpcom help?

Grant


"Kim Starks" <kim.starks@sap.com> wrote in message
news:cee7ed8ebd4ef55cde989115215421bb$1@www.eclipse.org...
> I need to use Mozilla as the underlying rederer because I need to be able
> to do the following with the browser:
> Know when the user has selected text (or double-clicked) and get it
> Search within the web page
> Add custom context menu capabilities
> etc.
>
> System
> Windows XP SP2
> Eclipse 3.4.1
> XUL Runner 1.9 (registered with register-global)
>
> The project is a plug-in.
>
> I created the browser with
> browser = new Browser(comp, SWT.BORDER|SWT.MOZILLA);
>
> When I call browser.getWebBrowser() I get null back.
>
> I found another post on this board that indicated that I needed to add the
> following to my manifest.mf:
> DynamicImport-Package: org.mozilla.xpcom
>
> This hasn't resolved my problem.
>
> I'm just creating a simple sample right now. Working from the samples
> from
>
> http://www.apress.com/book/downloadfile/4330
>
> ch02.WebBrowser is the project I'm working with. Any ideas as to what the
> issue is?
>
> Kim Starks
>
>
>
>
Previous Topic:CNF: Eclipse copy/cut/paste override
Next Topic:Java/Eclipse case against VB/VStudio.net
Goto Forum:
  


Current Time: Tue Sep 02 21:31:01 GMT 2014

Powered by FUDForum. Page generated in 0.01700 seconds