Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » [CommonNavigator] Adding the New Menu
[CommonNavigator] Adding the New Menu [message #336090] Wed, 20 May 2009 20:47 Go to next message
Andy Czerwonka is currently offline Andy Czerwonka
Messages: 42
Registered: July 2009
Member
I'm trying to add the New Wizard Menu to the Common Navigator. I have
the following in my plugin.xml:

<navigatorContent
activeByDefault="true"

contentProvider="com.ap.projectsets.navigator.ProjectSetsContentProvider "


icon="icons/folder_gear.png"
id="com.ap.projectsets.projectSetsContent"

labelProvider="com.ap.projectsets.navigator.ProjectSetsLabelProvider "
name="Project Sets"
priority="higher"
providesSaveables="false">
<triggerPoints>
<or>
<instanceof value="com.ap.navigator.ManageNavigator$Root" />
<instanceof
value="com.ap.projectsets.ProjectsSetsModel$Root" />
</or>
</triggerPoints>
<possibleChildren>
<or>
<instanceof
value="com.ap.projectsets.ProjectsSetsModel$Root" />
<instanceof value="com.ap.projectsets.ProjectSet" />
</or>
</possibleChildren>
<actionProvider

class="com.ap.projectsets.navigator.ProjectSetsActionProvider "
id="com.ap.projectsets.navigator.ProjectSetsActionProvider" >
</actionProvider>
<commonWizard
type="new"
wizardId="com.ap.projectsets.wizards.NewProjectSetWizard">
<enablement>
<or>
<instanceof
value="com.ap.projectsets.ProjectSet">
</instanceof>
<instanceof
value="com.ap.projectsets.ProjectsSetsModel$Root">
</instanceof>
<instanceof
value="com.ap.navigator.ManageNavigator$Root">
</instanceof>
</or>
</enablement>
</commonWizard>
</navigatorContent>


The NewProjectSetWizard is configured and working in the main toolbar,
but I can't get it to show up in the Common Navigator. Do I have to
somehow add the menu first before the wizard can attach?
Re: [CommonNavigator] Adding the New Menu [message #336127 is a reply to message #336090] Mon, 25 May 2009 08:02 Go to previous message
Jiyul is currently offline Jiyul
Messages: 23
Registered: July 2009
Junior Member
Did you bind your navigatorContent with specific instance of
CommonNavigator through ViewerContentBinding extension point?

CommonNavigator is not static single navigator. you needs to define an
instanceof CommonNavigator or use one already defined.

then

you need to bind your content with an instance of CommonNavigator
through ViewerContentBinding Extension.

Andy Czerwonka wrote:
> I'm trying to add the New Wizard Menu to the Common Navigator. I have
> the following in my plugin.xml:
>
> <navigatorContent
> activeByDefault="true"
>
> contentProvider="com.ap.projectsets.navigator.ProjectSetsContentProvider "
>
>
> icon="icons/folder_gear.png"
> id="com.ap.projectsets.projectSetsContent"
>
> labelProvider="com.ap.projectsets.navigator.ProjectSetsLabelProvider "
> name="Project Sets"
> priority="higher"
> providesSaveables="false">
> <triggerPoints>
> <or>
> <instanceof
> value="com.ap.navigator.ManageNavigator$Root" />
> <instanceof
> value="com.ap.projectsets.ProjectsSetsModel$Root" />
> </or>
> </triggerPoints>
> <possibleChildren>
> <or>
> <instanceof
> value="com.ap.projectsets.ProjectsSetsModel$Root" />
> <instanceof value="com.ap.projectsets.ProjectSet" />
> </or>
> </possibleChildren>
> <actionProvider
>
> class="com.ap.projectsets.navigator.ProjectSetsActionProvider "
>
> id="com.ap.projectsets.navigator.ProjectSetsActionProvider" >
> </actionProvider>
> <commonWizard
> type="new"
> wizardId="com.ap.projectsets.wizards.NewProjectSetWizard">
> <enablement>
> <or>
> <instanceof
> value="com.ap.projectsets.ProjectSet">
> </instanceof>
> <instanceof
> value="com.ap.projectsets.ProjectsSetsModel$Root">
> </instanceof>
> <instanceof
> value="com.ap.navigator.ManageNavigator$Root">
> </instanceof>
> </or>
> </enablement>
> </commonWizard>
> </navigatorContent>
>
>
> The NewProjectSetWizard is configured and working in the main toolbar,
> but I can't get it to show up in the Common Navigator. Do I have to
> somehow add the menu first before the wizard can attach?
>
Previous Topic:Problems generating a headless build application
Next Topic:Why the problemd view don't use the AdapterManager
Goto Forum:
  


Current Time: Sat Oct 25 20:54:16 GMT 2014

Powered by FUDForum. Page generated in 0.01861 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software