Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Package uses conflict when exporting
Package uses conflict when exporting [message #336073] Tue, 19 May 2009 16:30
Ola Spjuth is currently offline Ola Spjuth
Messages: 47
Registered: July 2009
Member
Hi,

A recent refactoring has rendered us in a situation where we can build
and run from inside Eclipse, but we get a strange "package uses
conflict" when trying to export. The complete error is:

Problems during export
Bundle net.bioclipse.managers_0.0.0 failed to resolve.:
Package uses conflict: Require-Bundle:
org.springframework.bundle.spring.core; bundle-version="2.5.1"
Package uses conflict: Require-Bundle:
org.springframework.bundle.spring.core; bundle-version="2.5.1"

Bundle net.bioclipse.managers_0.0.0 failed to resolve.:
Package uses conflict: Require-Bundle:
org.springframework.bundle.spring.core; bundle-version="2.5.1"
Package uses conflict: Require-Bundle:
org.springframework.bundle.spring.core; bundle-version="2.5.1"

What are the differences with respect to this when running inside
eclipse and exporting? How can we diagnose the cause of this problem to
resolve it?

Further details about the problem can be found in this blog:
http://chemicalrcp.blogspot.com/2009/05/eclipse-spring-expor t-problem-uses.html

Looking forward to hearing from you,

/Ola Spjuth
Previous Topic:removing the breadcrumb
Next Topic:SQL File Editor > Execute All not skipping comment lines
Goto Forum:
  


Current Time: Wed Oct 22 12:13:04 GMT 2014

Powered by FUDForum. Page generated in 0.03368 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software