Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Editor has no focus after "Open Resource"
Editor has no focus after "Open Resource" [message #336027] Thu, 14 May 2009 04:43 Go to next message
Sebastian Beigel is currently offline Sebastian Beigel
Messages: 6
Registered: July 2009
Junior Member
Hi,

using Eclipse 3.5 M7 (Java EE package, cocoa-build on Mac OS 10.5.7, clean
install, new workspace) I've noticed a bug using the "Open Resource"
dialog. After selecting a file, the according editor opens and the file
content is shown but the editor pane has no focus. The first line is
highlighted but the cursor/caret is invisible and the editor receives no
key presses. It doesn't matter what filetype, i.e. editor is used (I tried
Text, XML, Java, JSP).

This does not happen when the file is opened by a double click in the
(Package) Explorer view neither using the "Open Type" dialog (for Java
files).

The bug also occurs when a file (e.g. foo.xml) is already opend (in the
background) and another editor (with a different file) is focused (in the
foreground) and the first file (foo.xml) is re-opend with "Open Resource".

It does not occur switching editors (using the Command-E shortcut).

Regards,
Sebastian
Re: Editor has no focus after "Open Resource" [message #336038 is a reply to message #336027] Thu, 14 May 2009 08:42 Go to previous messageGo to next message
Ben Vitale is currently offline Ben Vitale
Messages: 247
Registered: July 2009
Senior Member
Not able to reproduce on XP. Don't have a mac to check with.

Since cocoa support is new for 3.5 you probably should open a bug
against Platform UI. If its an SWT bug then they will reassign as
appropriate.

Cheers
Ben

Sebastian Beigel wrote:
> Hi,
>
> using Eclipse 3.5 M7 (Java EE package, cocoa-build on Mac OS 10.5.7,
> clean install, new workspace) I've noticed a bug using the "Open
> Resource" dialog. After selecting a file, the according editor opens and
> the file content is shown but the editor pane has no focus. The first
> line is highlighted but the cursor/caret is invisible and the editor
> receives no key presses. It doesn't matter what filetype, i.e. editor is
> used (I tried Text, XML, Java, JSP).
>
> This does not happen when the file is opened by a double click in the
> (Package) Explorer view neither using the "Open Type" dialog (for Java
> files).
>
> The bug also occurs when a file (e.g. foo.xml) is already opend (in the
> background) and another editor (with a different file) is focused (in
> the foreground) and the first file (foo.xml) is re-opend with "Open
> Resource".
>
> It does not occur switching editors (using the Command-E shortcut).
>
> Regards,
> Sebastian
>
Re: Editor has no focus after "Open Resource" [message #336041 is a reply to message #336038] Thu, 14 May 2009 09:04 Go to previous messageGo to next message
Prakash G.R. is currently offline Prakash G.R.
Messages: 621
Registered: July 2009
Senior Member
https://bugs.eclipse.org/bugs/show_bug.cgi?id=276200

Is this bug you are facing? Its been fixed in the recent builds. Can you
try with a latest I Build?


- Prakash

---
http://blog.eclipse-tips.com
Re: Editor has no focus after "Open Resource" [message #336062 is a reply to message #336041] Mon, 18 May 2009 03:48 Go to previous message
Sebastian Beigel is currently offline Sebastian Beigel
Messages: 6
Registered: July 2009
Junior Member
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=276200
>
> Is this bug you are facing? Its been fixed in the recent builds. Can you
> try with a latest I Build?

Yes, I've submitted a bug report as well (now marked as duplicate of this bug).
Everything works as expected in I20090513-2000.

Thanks,
Sebastian
Previous Topic:Adding console filter to external tool?
Next Topic:Sort Preference Pages
Goto Forum:
  


Current Time: Fri Aug 01 01:57:45 EDT 2014

Powered by FUDForum. Page generated in 0.01527 seconds